Skip to main content
Topic: SACD playback and "Skip Silence" problem (Read 863 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

SACD playback and "Skip Silence" problem

I've never noticed this before, so I must assume this is a problem that has come up recently on my PC. When playing back SACDs, and the plugin-in "Skip Silence" is active in DSP, playback becomes choppy. This is the case no matter which output I choose (DS or WASAPI). CPU load is 20% for 5.1 playback, so that's not it either. There are no latency spikes which usually cause that kind of effect, either. I'm stumped. To be sure I've eliminated all user components except for WASAPI output and the SACD decoder. The issue persists. You can best hear it with long drawn sounds, for example chorals.

Core (2013-05-04 11:44:10 UTC)
    foobar2000 core 1.2.6
foo_albumlist.dll (2013-02-11 11:28:58 UTC)
    Album List 4.5
foo_cdda.dll (2013-03-07 09:48:32 UTC)
    CD Audio Decoder 3.0
foo_converter.dll (2013-05-04 11:40:14 UTC)
    Converter 1.5
foo_dsp_eq.dll (2013-02-11 11:28:58 UTC)
    Equalizer 1.0
foo_dsp_std.dll (2013-02-11 11:28:50 UTC)
    Standard DSP Array 1.2
foo_fileops.dll (2013-02-11 11:28:10 UTC)
    File Operations 2.2
foo_freedb2.dll (2013-02-11 11:27:56 UTC)
    Online Tagger 0.7
foo_input_sacd.dll (2013-04-19 22:43:58 UTC)
    Super Audio CD Decoder 0.6.4
foo_input_std.dll (2013-05-04 11:44:12 UTC)
    Standard Input Array 1.0
foo_out_wasapi.dll (2013-03-10 11:38:32 UTC)
    WASAPI output support 3.2.3
foo_rgscan.dll (2013-05-04 11:40:18 UTC)
    ReplayGain Scanner 2.2
foo_ui_std.dll (2013-05-04 11:44:10 UTC)
    Default User Interface 0.9.5
foo_unpack.dll (2013-02-11 11:28:10 UTC)
    ZIP/GZIP/RAR Reader 1.6

Can someone replicate and confirm this issue?

 

SACD playback and "Skip Silence" problem

Reply #1
Ok, it looks like the choppiness has to do with the buffer length in Preferences -> Playback -> Output. It was set to 50ms there because I was under the impression that the buffer size for WASAPI output is fixed, or rather set within the limits given in Advanced Preferences.

Not so. When I raise the buffer length above 1000ms, the choppiness ceases to be noticeable. This is weird, I guess I haven't understood what's going on with the buffer in WASAPI mode. Can someone enlighten me, please?

Or maybe the Skip Silence feature does need some finetuning and a buffer by itself?

 
SimplePortal 1.0.0 RC1 © 2008-2019