Skip to main content
Topic: How to disable the local shortcut CTRL+F (Playlist Search) (Read 1562 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

How to disable the local shortcut CTRL+F (Playlist Search)

Hi,
i installed a clean foobar2000 v1.2.4 on my Win7 (ger) and removed all the Shortcuts in the prefs (exept CTRL+P as beeing told by the Wiki) but i still can press CTRL+F and get the Playlist Search window.

Which is why i write here, because i don't want the Playlist Search poping up with that shortcut.

I created a shortcut SHIFT+CTRL+F and everytime i press SHIFT+CTRL+F the Playlist Search windows pops up in addition to my added binding.

How to disable that behaviour, so i can use my binding without having to close the Playlist Search window every time i press SHIFT+CTRL+F ?

cheers,

How to disable the local shortcut CTRL+F (Playlist Search)

Reply #1
Edit your binding to some other combination of SHIFT+<SOME-OTHER-KEY>+F . . . . problem solved.
Any other questions?

Looking at this deeper . . . . I suppose foobar2000 should allow 3-key mappings to have precedence and have no influence over 2-key mappings, therefore it is possible to view this behaviour as a built-in flaw (bug?) which should be addressesd by foobar2000's developer.

How to disable the local shortcut CTRL+F (Playlist Search)

Reply #2
Edit your binding to some other combination of SHIFT+<SOME-OTHER-KEY>+F . . . . problem solved.

No.
not solved, as no OTHER KEYS are available which do not cause other undesired behaviour. i.e. ALT+SHIFT will pull down the File Menu too.

Those are my used shortcuts:


Any other questions?

Yes.
Why is it, that with NO BINDING TO CTRL+F OR F3 the Playlist Window shows up, while pressing those keys?
The Wiki does not tell that those keys are special. instead, i had the impression, that the bindings are highly customizable.



(i read your Edit too late, sorry. It seems not to be possible to use the WIN Key as a Modifyer too.)

How to disable the local shortcut CTRL+F (Playlist Search)

Reply #3
Do you use the Playlist View that comes with the Default User Interface? I can reproduce the described behaviour with the SimPlaylist UI element. Ctrl+F seems to be a hard-coded default at some level.

How to disable the local shortcut CTRL+F (Playlist Search)

Reply #4
FWIW, changing ctrl+f to <whatever> doesn't invoke a search, neither on elplaylist viewer nor on the default one
also, setting ctrl+shift+f to <whatever> while having ctrl+f set to search, doesn't invoke a searcg

How to disable the local shortcut CTRL+F (Playlist Search)

Reply #5
Do you use the Playlist View that comes with the Default User Interface? I can reproduce the described behaviour with the SimPlaylist UI element.

I did a clean install of foobar2000, changed nothing, but removing ALL the shortcuts exept CTRL+P. so i guess, the answer is yes. Never heard/read about SimPlaylist UI.
anyway, usually, i use Colums UI (if this is matters for the shortcuts... i don't know) and it shows the same problem.


Ctrl+F seems to be a hard-coded default at some level.
ok, looks that the wiki does not cover this and the keyboars-shortcut-preferences-screen neither.

thanks.

what can i do now to ask someone of the developers to change this behaviour either to: make CTRL+F / F3 not deletable in the preferences, or let the user override/change it, as expected via the foobar preferences screen ?

How to disable the local shortcut CTRL+F (Playlist Search)

Reply #6
FWIW, changing ctrl+f to <whatever> doesn't invoke a search, neither on elplaylist viewer nor on the default one
also, setting ctrl+shift+f to <whatever> while having ctrl+f set to search, doesn't invoke a searcg

thats odd. (or not... i don't know...:-) )

how can we tell, whats wrong and which of us has things broken? (obviously me, because things won't work as configured...)

could it be a keyboard-driver problem? i use a logitech G15 under Win7.

How to disable the local shortcut CTRL+F (Playlist Search)

Reply #7
hi,
problem continues on several computers, so its actually no kb-driver problem.

is it worthwhile to make a feature request, for having (the maybe) hardcoded shortcut inserted to the settings in the preferences (where it should be listet, imho) ?
so the user can delet it OR change it, if needed.

now, its someway a strange behaviour, i think.

Steps to Reproduce: How to disable the local shortcut CTRL+F (Playlist Search)

Reply #8
Hello,

I just want to bump this, because its still not working as expected and as @ruebe tells. (at least not here on Win7 64 on)

So, to reproduce, please follow this simple steps.

1) Install foobar2000_v1.4.1_beta_1.exe (or any other older version) in portable mode. choose FULL install.
2) Start foobar2000
3) Cancel or OK the upcoming "Quick Appearance Setup"
4) Press CTRL+P or go to Library->Configure->Keyboard Shortcuts and remove each and every bound shorcut and press OK.
5) Restart foobar
6) Press CTRL+F and the Playlist Search Window pops up.

Can anyone confirm this misbehaviour/bug?
(I consider it a bug, because NO shortcut is defined)



Hi,
i installed a clean foobar2000 v1.2.4 on my Win7 (ger) and removed all the Shortcuts in the prefs (exept CTRL+P as beeing told by the Wiki) but i still can press CTRL+F and get the Playlist Search window.

Which is why i write here, because i don't want the Playlist Search poping up with that shortcut.

I created a shortcut SHIFT+CTRL+F and everytime i press SHIFT+CTRL+F the Playlist Search windows pops up in addition to my added binding.

How to disable that behaviour, so i can use my binding without having to close the Playlist Search window every time i press SHIFT+CTRL+F ?

cheers,

Re: How to disable the local shortcut CTRL+F (Playlist Search)

Reply #9
Finally, this has been fixed in f2k 1.5betas :-)
Thank you!

 
SimplePortal 1.0.0 RC1 © 2008-2019