Skip to main content
Topic: foo_vst: VST 2.4 adapter (Read 382882 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_vst: VST 2.4 adapter

Reply #175
My bad. I've been on the wiki and didn't remember.

How stable is 0.9.0.2? 0.8.1.0 is performing quite well, so I might wait for a stable release.

foo_vst: VST 2.4 adapter

Reply #176
I think if you don't need features of the new version then it's better for you to wait for a final release.

The UI for Toneboosters Isone: http://www.toneboosters.com/tb-isone/ isn't displaying in 0.9.0.2.  All my other VSTs including the old JB Isone are showing up fine.
Well, it works fine for me:


Could you try any other host just to make sure this plug-in works, please?

foo_vst: VST 2.4 adapter

Reply #177
Well, presets and support for conversion and playback with matched DSP chain presets is nice. But I'll just run things without too much changes and that won't affect me much, for now.

foo_vst: VST 2.4 adapter

Reply #178
VST window is not closed when user removes VST from DSP manager

PS I don't know if this is mentioned, thread is rather long

foo_vst: VST 2.4 adapter

Reply #179
It will not I think. There are some technical difficulties which prevent this bug from being fixed. Don't use it this way please.

foo_vst: VST 2.4 adapter

Reply #180
[quote author=Entrase link=msg=0 date=]Well, it works fine for me:[/quote]
I just installed the newest tb_Isone 1.5 and it's working. Perhaps it was something odd in my machine, sorry for the false alarm.

foo_vst: VST 2.4 adapter

Reply #181
Hello, I checked 0.9 version and it's not running. Foobar says that some component is damaged. I know it's preview version, but..

foo_vst: VST 2.4 adapter

Reply #182
Did v0.8.0.1 work there before? Or is it clean installation of Foobar2000? Which operating system is that?

foo_vst: VST 2.4 adapter

Reply #183
8.0.1 works. It's not fresh instalation. My OS is Win7 64bit.

foo_vst: VST 2.4 adapter

Reply #184
Amazing!

Bug(?): When I try to configure "George Yohng's W1 Limiter" (the VST that comes with his VST wrapper), I get "This feature isn't implemented for no-GUI plug-ins yet. Sorry." (both 0.8.x and 0.9.0.2). (Same via "configure selected" and "View -> VST -> ...".) It's a GUI plug-in, because using his VST wrapper, it's configurable.

(if someone can recommend an alternative simple limiter/compressor, either vst or dsp...)

foo_vst: VST 2.4 adapter

Reply #185
Quote
Amazing!
Thanks!

Quote
It's a GUI plug-in, because using his VST wrapper, it's configurable.
In VST, being configurable has nothing to do with having custom GUI. Try a different host and you'll see different appearance of what you take as plug-in's GUI.


foo_vst: VST 2.4 adapter

Reply #186
Quote
(Yohng W1 Limiter is) a GUI plug-in, because using his VST wrapper, it's configurable.
In VST, being configurable has nothing to do with having custom GUI. Try a different host and you'll see different appearance of what you take as plug-in's GUI.
Is there an ETA for that feature? Or is there some other way to make it work? Manually entering the values somewhere?

foo_vst: VST 2.4 adapter

Reply #187
Yes, the feature is essential to any VST host and it'll be implemented by 1.0 release. The only way to get it configurable is to use with a VST chainer. Ironically, this is what users were to get rid of in this adapter. And technically, you can edit something manually, but that involves HEX editing and other black magic.

foo_vst: VST 2.4 adapter

Reply #188
foobar 1.1.4 disabled foo_vst when installing. Though while 0.8.0.1 was disabled and deleted on install, 0.9.0.2 does work 

...still waiting for an updated midi plugin as well as that was deleted too...

foo_vst: VST 2.4 adapter

Reply #189
? foo_vst 0.8.0.1 is still kicking here after the 1.1.3 and 1.1.4 upgrades. Might be there's something else is wrong with your configuration.

foo_vst: VST 2.4 adapter

Reply #190
There's nothing wrong with my config. During the install of 1.1.4 (from a 1.1.2 install) I get a notification that two components are going to be disabled for not being compatible.

If you check the official components list, there are already components being rewritten to be compatible with 1.1.3 and above.

foo_vst: VST 2.4 adapter

Reply #191
If you check the official components list, there are already components being rewritten to be compatible with 1.1.3 and above.
Just because an official component was modified for a new version does not imply that any other components need alteration. Official components can occasionally use undocumented APIs and various other things. While I don't know for certain, the fact that thuan has no difficulty makes me suspect your configuration rather than a change in foobar2000.

You should buy yourself one of those jump-to-conclusions mats. They have all these different conclusions you can jump to. Maybe that'll help with your burning desire to do so here on the forums.

foo_vst: VST 2.4 adapter

Reply #192
Since I said on a previous post that I intended on using the latest stable foo_vst, I'm merely stating what happened with my situation.

If advising for the good of others is frowned upon, don't worry, that won't happen again.

Whatever makes your day shine brighter...

foo_vst: VST 2.4 adapter

Reply #193
? foo_vst 0.8.0.1 is still kicking here after the 1.1.3 and 1.1.4 upgrades.

same here. tribaljet don't play the offended role, there must be something else going on. Why don't you try and add those 2 plugins again?
In theory, there is no difference between theory and practice. In practice there is.

foo_vst: VST 2.4 adapter

Reply #194
? foo_vst 0.8.0.1 is still kicking here after the 1.1.3 and 1.1.4 upgrades.

same here. tribaljet don't play the offended role, there must be something else going on. Why don't you try and add those 2 plugins again?


I already added the new version of foo_vst, and will wait for an updated version of foo_midi.

foo_vst: VST 2.4 adapter

Reply #195
You can just reinstall current version of foo_midi. Installer removed it most likely because you had all the supporting dlls extracted into the components directory where they couldn't be loaded from. Either use the new per-user component installation method or manually move bass.dll and bassmidi.dll into the foobar2000 installation directory.

foo_vst: VST 2.4 adapter

Reply #196
Entrase, if you get p_api as NULL in foobar2000_get_interface(), don't do anything and just return the foobar2000_client_impl which can report interface version. The installed does this to check for outdated components, foo_vst currently crashes on the NULL pointer and thus gets deleted.
Full-quoting makes you scroll past the same junk over and over.

foo_vst: VST 2.4 adapter

Reply #197
Oh! Thanks a lot! There really is a custom foobar2000_get_interface() and I'll fix it. Thanks again.

foo_vst: VST 2.4 adapter

Reply #198
Great work! Entrase. It's a nice VST host plugin.

Here may i know where to store the plugin information? I try to download the reg cleaner you attached.But it seems not there any more.

I try to zip foobar working folder to copy whole components instead of installing foobar and other components every time. But if this, foobar can't keep VST plugin configuartion every launch and i need to configure it again. Any suggestion?

Thanks.

foo_vst: VST 2.4 adapter

Reply #199
You can just reinstall current version of foo_midi. Installer removed it most likely because you had all the supporting dlls extracted into the components directory where they couldn't be loaded from. Either use the new per-user component installation method or manually move bass.dll and bassmidi.dll into the foobar2000 installation directory.


Thanks, Case, moving bass.dll and bassmidi.dll to the main install folder did fix things. Now after updating from 1.1.4 to 1.1.5 there is no longer an issue with foo_midi. On the other hand, foo_vst was once again removed (0.9.0.2), forcing me to copy it again. Would be nice if this didn't happen on future versions.

On a non related note, does anyone know why foobar does some sort of check of all files in the previous install folder? This is only happening since 1.1.3, and I would just like to understand how relevant it is.

 
SimplePortal 1.0.0 RC1 © 2008-2019