Skip to main content
Topic: [ToS#6]How foobar handles 'Pre-Emphasis' status bit to ASIO dr (Read 909 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[ToS#6]How foobar handles 'Pre-Emphasis' status bit to ASIO dr

Hi,
I play an CD-Image with integrated cue-sheet and "FLAGS PRE" with foobar2000 from the Computer Hard-disk through the S/PDIF interface (Soundcard Asus Xonar Essence ST) to the Benchmark DAC1 coaxial interface.

The Benchmark will automatically perform Digital De-Emphasis if the 'Pre-Emphasis' status bit is set properly at the S/PDIF interface.

--------------------------------------------
Elias Gwinn from Benchmark submitted:

I did some research, and I believe you are correct. There is 'pre-emphasis' meta-data in some ripped audio files, as you indicated in your previous post.

Now, the question is: how can you get it to be de-emphasized properly? The DAC1 will apply de-empasis if it receives the 'pre-emphasis' status bit. However, it seems like it isn't receiving it. There are a number of reasons this may be happening, since there are many different API's, drivers, and firmware steps that the audio must go through before leaving the sound card. All of the software and hardware, from Foobar to SPDIF output, would need to properly carry the bit through until the end. It seems like it is getting lost somewhere in that distance. You may need to contact the manufacturer of the soundcard to see if they have addressed this issue.
--------------------------------------------

My Question is: Is the Pre-Emphasis status bit set properly from foobar and could foobar pass the status bit to an ASIO driver?

thanks in advance

 
SimplePortal 1.0.0 RC1 © 2008-2019