Skip to main content
Topic: [crashware] foo_uie_lyrics2 (Read 405201 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[crashware] foo_uie_lyrics2

Reply #650
Strange that it is labeled as crashware.

[crashware] foo_uie_lyrics2

Reply #651
That's definitely strange, since it doesn't crash ever.

[crashware] foo_uie_lyrics2

Reply #652
To make something constructive out of this, I suggest those of us who have experienced crashes to briefly and coherently describe the circumstances that led to crashes, so that anyone who picks up development can have useful information.

I've only had it crash Foobar when I use this component in combination with foo_preview to briefly play thousands of songs to automatically download and save synced lyrics.  Foobar consistently crashes after a few hundred songs.  I had one song corrupted beyond recovery only once.

I've never had it crash Foobar when I turned off the options to save lyrics.

[crashware] foo_uie_lyrics2

Reply #653
Just to clarify, I was talking about foo_uie_lyrics, not lyrics2. Lyrics2 definitely did crash when I used it. Never had foobar crash with foo_uie_lyrics running though. Perhaps it does crash if you download lyrics and try to write them to the mp3? I don't know about that, I save them all to one directory.

[crashware] foo_uie_lyrics2

Reply #654
I wasn't clear enough either.  I use lyrics2 to save synced lyrics within mp3 and flac files.

[crashware] foo_uie_lyrics2

Reply #655
I tried to compile this in Visual Studio 2010.

I'm amazed how all the header files (.h) have almost all lines of code of the project.  The original developer defined classes and implemented methods in the header files and left the .cpp files for static functions.  That's VERY confusing.

Anyway that was just for fun, this component has never ever crashed on me.  But if I compile it myself, it does crash everytime with an assertion about a subscript out of range.

[crashware] foo_uie_lyrics2

Reply #656
This plugin's worked great for me until about last week, and since then I haven't been able to fetch any lyrics online. Anyone else experiencing this? I haven't changed anything recently, but oddly it does work for my mate, which signals that the problem lies at my end. I've tried disabling firewall (Comodo), twiddling with the server settings (viewlyrics/lyricsfly etc) and "reinstalling" the plugin. None of these worked.

Any suggestions in case I'm really alone with this? I'm running the latest versions of both (stable) Foobar and this plugin.

[crashware] foo_uie_lyrics2

Reply #657
you are not alone. with a trivial search you will learn the issue is with lyric providers and not any of the various components

[crashware] foo_uie_lyrics2

Reply #658
you are not alone. with a trivial search you will learn the issue is with lyric providers and not any of the various components
Heh, alright, but I have no clue as to what to search for. Mind pointing me at some direction?

And cheers for the reply.

[crashware] foo_uie_lyrics2

Reply #659
Quote
This plugin's worked great for me until about last week, and since then I haven't been able to fetch any lyrics online. Anyone else experiencing this? I haven't changed anything recently, but oddly it does work for my mate, which signals that the problem lies at my end. I've tried disabling firewall (Comodo), twiddling with the server settings (viewlyrics/lyricsfly etc) and "reinstalling" the plugin. None of these worked.


I'm also having same problem does anyone know any solution

thanks

[crashware] foo_uie_lyrics2

Reply #660
As mentioned two posts up, it is a problem with lyric providers not your component. It is not a problem related to your component or foobar2000.

It has been mentioned the last couple of weeks within the thread of the current version of the component. http://www.hydrogenaudio.org/forums/index....0338&st=175


[crashware] foo_uie_lyrics2

Reply #661
As mentioned two posts up, it is a problem with lyric providers not your component. It is not a problem related to your component or foobar2000.

It has been mentioned the last couple of weeks within the thread of the current version of the component. http://www.hydrogenaudio.org/forums/index....0338&st=175
Never even knew lyrics3 existed. Thanks, this clarified things up.

[crashware] foo_uie_lyrics2

Reply #662
As mentioned two posts up, it is a problem with lyric providers not your component. It is not a problem related to your component or foobar2000.

It has been mentioned the last couple of weeks within the thread of the current version of the component. http://www.hydrogenaudio.org/forums/index....0338&st=175
Never even knew lyrics3 existed. Thanks, this clarified things up.

Yeah.... Someone could have mentioned the to the people following this topic that someone picked up development...

[crashware] foo_uie_lyrics2

Reply #663
The google code project seems to be deleted, does anyone have the source code?


[crashware] foo_uie_lyrics2

Reply #665
See #602

 
SimplePortal 1.0.0 RC1 © 2008-2019