Skip to main content
Topic: Itunesencode/EAC using temp filenames? (Read 1688 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Itunesencode/EAC using temp filenames?

I've tried the iTunesencode program for ripping ALAC using EAC, but I'm having trouble with what actually appears in the iTunes library.

First I used this string
-e "Lossless Encoder" -a "%a" -l "%g" -t "%t" -g "%m" -y %y -n %n -i %s -o %d
which yielded a proper ALAC file in the itunes library, but the filename being referenced was a randomized temporary file, like STCD1156a.m4a, which was located in folder "\my music\unknown artist\unknown album".  I also had an identically sized file with proper filename "artist - track - name.m4a" in the proper "\my music\artist\album" folder.  The itunes library did not reference this file, and won't allow it to be added manually.

Next I tried the string
-e "Lossless Encoder" -a "%a" -l "%g" -t "%t" -g "%m" -y %y -n %n -i %s -o %d -d
adding the "-d" onto the end.  Now the temp filenamed file gets deleted from the HD and the library, but still, the properly named file won't go into the library when I try to add it.

Where am I going wrong?

Update:  The properly named file is apparently corrupt and has a file size 4k larger than the file with the temporary name which plays.  If I use EAC to make a WAV and then manually run the itunesencode command line, the resulting file isn't corrupted.  What might EAC be doing when it runs the command line that causes the temp file to be OK, but the renamed file to be corrupted?

Update 2:  Corrupted file problem solved.  Uncheck Add ID3 tag under Compression Options/External Compression.  If its checked, it corrupts the final file.
Limekiller

 
SimplePortal 1.0.0 RC1 © 2008-2019