Skip to main content
Topic: TAK Winamp Plugin: Alpha and beta releases (Read 4874 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

TAK Winamp Plugin: Alpha and beta releases

Content

This thread should be used to discuss alpha and beta releases of my Winamp playback plugin for files created by TAK, my new lossless audio compressor.

Some more info can be found in the Readme.html.

Please don't distribute this alpha version. Better wait for the final release!

Bug reports

Please try to provide as many details as possible about the conditions which created the error. And please keep the affected files. I may ask you for them.

Download

The current alpha can be downloaded from the Upload section:
TAK Winamp Plugin 0.0.3 Alpha

Features

This version of the input plugin is based upon the new decoder, which is part of the upcoming TAK SDK. It's error tolerance (when decoding damaged files) should be even better than that of the decoder in TAK 1.0 final. Features:

- Very low cpu usage. Depending on the compression preset my Pentium 3 with 866 MHz decodes at a rate of 60 to 80 times faster than real time...

- Ultra fast seeking. I am not able to notice any delay on my old Pentium 3 with 866 MHz.

- Maximum error tolerance. It should be possible to playback any file containing at least one intact block of about 2 seconds of audio data.

Some remarks:

- Limitations for seeking in damaged files: Currently the seektable has to be intact and no data should have been inserted into or removed from the audio part. Otherwise only sequential playback will be possible.

- Any damaged part of the audio data will be muted (replaced with silence). If only the last 2 seconds of a 60 minutes file are intact, the plugin will first output 3598 seconds of silence. If you want to remove damaged audio parts, decode the file with the TAK application and selcet the option "Skip errors".

- I tested the plugin with Winamp 2.91 and 5.32. When using v 5.32 with the default skin, seeking seemed to be delayed. I am not sure, but probably this only regards to the position indicator, the playback seems to start immediately. After switching to the classic skin, any delay was gone.

- Because of my very old sound card, i could not test 24-bit playback. Futhermore: Some visualization plugins don't support 24-bit data. It has to be converted to 16 bit before sending it to those plugins. This has not been implemented yet! It's very easy to do, but i don't want to include code, which i am not able to test. I will soon buy a better soundcard...

Thomas

 
SimplePortal 1.0.0 RC1 © 2008-2019