Skip to main content
Topic: iPod manager (Read 1642421 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: iPod manager

Reply #4100
I deleted the above mapping. Now I am back to the steps to reflect this on my iPod. I looked back to post 4075 - around there. It's easy to find "Load library". But, for me, I can never figure out how to access this playlist and right-click on everything and choose "Rewrite Database". I used "Facets" exclusively. Can someone explain this in a way that is useful to me? I NEVER see anything like "iPod View" or anything like that on my screen. And, is it"Rewrite Database" that I want and not "Update Metadata"?

Re: iPod manager

Reply #4101
add "Playlist tabs" and "playlist view" in to your layout.

File > Ipod > load library. you should see a new playlist showing all the music on your iPod.

From there you should be able to select all or individual tracks and rewrite database.
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Re: iPod manager

Reply #4102
add "Playlist tabs" and "playlist view" in to your layout.

File > Ipod > load library. you should see a new playlist showing all the music on your iPod.

From there you should be able to select all or individual tracks and rewrite database.
Here is what I did:
In my setup, at top left, below the File menu, is a drop-down list with just two items: Library and Playlist. It usually set to Library.
1. I changed this to playlist Everything looks the same. This is probably because I don't have any playlist other than the one that contains my entire library [default?].
2. From the File menu, I chose "New Playlist" or Ctrl-N. This seems to clear everything.
3. Now, File Menu, iPod, "Load Library". populates the playlist.
4. Now, File Menu, iPod, "Rewrite Database".
5. Eject
6. Go to the device, iPod, Music>Compilations and unfortunately, there is now nothing.
If U look back over my posts, U can see that I had one album appearing there before this action. Both of these albums in my library [media library on my hard drive] have the Compilation tag set to 1.  I deleted the mapping in iPod Manager, that was trying to set this tag. This is why I thought I need to do the "Load library" and "Rewrite Database"? Is there something else I need to do?

Re: iPod manager

Reply #4103
Sorry i messed up the previous steps

add "Playlist tabs" and "playlist view" in to your layout.

File > Ipod > load library. you should see a new playlist showing all the music on your iPod.

Make any changes to the metadata on the files in the iPod view playlist.

Select those changed files or all files and right click >  ipod > update metadata. This will update the database on the ipod as well.

You shouldn't actually need to use the rewrite database.


Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Re: iPod manager

Reply #4104
Sorry i messed up the previous steps

add "Playlist tabs" and "playlist view" in to your layout.

File > Ipod > load library. you should see a new playlist showing all the music on your iPod.

Make any changes to the metadata on the files in the iPod view playlist.

Select those changed files or all files and right click >  ipod > update metadata. This will update the database on the ipod as well.

You shouldn't actually need to use the rewrite database.
[I tried to do what you wrote above, but]
1. I could not figure out [in my setup] how to "add "Playlist tabs" and "playlist view" in to your layout."
2. This is why I listed all the steps I did.
3. How is this different? What I did compared to what you suggested?
4. Now, when I click on "Synchronize", usually I only have "Media Library" checked. But, after doing "New Playlist" multiple times, there are 9 additional different entries: "Playlist", "Playlist (2)", ... , "Playlist (3)". How do I remove all these entries?
Does this help you in helping me? Because, obviously, there is something I don't understand here, but I am trying... Remember, I don't use playlists and have relied on Facets all this time with Foobar. Anything I did in the past with a playlist was fumbling around and if it worked, it was probably from luck. Unfortunately, it seems as if I need to learn this in order to do these "Load library", "Update metadata", "Rewrite Database", etc. commands to work.
EDIT: Well, I found View>Playlist Manager allows the removal of all those "Playlist" entries in the iPod Synchronize dialog. Also, something in what I did resulted on their being no Compilations in device iPod>Music>Compilations whereas before there was one entry.
EDIT2: [As a test...] I added a non-functioned tag, "Debug", to both of those albums and a value, "Y". After "touching" these MP3s, the "Synchronize" will work, deleting what is on the iPod and replacing them with the updated MP3s. Unfortunately, even though these have the Compilation tag set to 1, on the device iPod, Music>Compilation is still empty.

Re: iPod manager

Reply #4105
If you have removed the compilation mapping (left it empty), then the component will look at whether the IPOD_COMPILATION field exists for those tracks. So you would need to set IPOD_COMPILATION to 1 or similar for those tracks, and then resync.

As for not being able to see the iPod contents after running Load library, if you post a screenshot of what you can see that might make things a bit clearer.
.

Re: iPod manager

Reply #4106
If you have removed the compilation mapping (left it empty), then the component will look at whether the IPOD_COMPILATION field exists for those tracks. So you would need to set IPOD_COMPILATION to 1 or similar for those tracks, and then resync.

As for not being able to see the iPod contents after running Load library, if you post a screenshot of what you can see that might make things a bit clearer.
First things first. I do have the COMPILATION tag set to 1 on all of those MP3s in my media library on my hard drive. Are you saying that the iPod does not look at this, but IPOD_COMPILATION instead? I definitely do NOT have this on any of those tracks.
EDIT: Yep. I added IPOD_COMPILATION tag to both of those albums setting it to 1 on each MP3. They now appear in the iPod under Music>Compilations. If I knew this, I could have saved myself a lot of trouble. So, going forward, I can always add this tag to any album I consider to be a compilation. As far as making changes to mappings and then trying to migrate those changes to the iPod, Whatever I did worked. When I deleted the mapping you quoted, it was reflected on the iPod. I listed everything I did in post 7102. Maybe the "New playlist" command is not needed. Maybe I just need some tweaking? I'll need to tweak some mapping to see if I can repeat what worked before.

Re: iPod manager

Reply #4107
The iPod does not look at any tags in the files (other than lyrics) – it looks in its database which this component maintains.

No, the component does not read from a field named COMPILATION in the component's default configuration. If you want to use that field, you need to set the compilation mapping to [%compilation%] .
.

Re: iPod manager

Reply #4108
The iPod does not look at any tags in the files (other than lyrics) – it looks in its database which this component maintains.

No, the component does not read from a field named COMPILATION in the component's default configuration. If you want to use that field, you need to set the compilation mapping to [%compilation%] .
So, if I change Compilation == %compilation% in the Database tab in iPod Manager and an MP3 has the compilation tag, it will be mapped? I just need to reflect this change in the iPod database? That's what I was trying to do, but need to do more cleanly.

Re: iPod manager

Reply #4109
Yes, you need to run File/iPod/Load library which should cause the iPod contents to appear in the playlist view. Then, select the relevant (or all) tracks in the playlist, right-click on them and select iPod/Update metadata.

If you can't see the iPod contents after running Load library, post a screenshot or a video of what happens.
.

Re: iPod manager

Reply #4110
Yes, you need to run File/iPod/Load library which should cause the iPod contents to appear in the playlist view. Then, select the relevant (or all) tracks in the playlist, right-click on them and select iPod/Update metadata.

If you can't see the iPod contents after running Load library, post a screenshot or a video of what happens.
One more point of confusion for me.  I referenced this, https://wiki.yuo.be/dop:config:database. When do you need to both "Update Metadata on iPod" and "Rewrite Database"? Or, is it one or the other?
EDIT": I just mapped the database COMPILATION to %compilation% (w/o the brackets []) as you mentioned above. After doing "Load library", I did both a "Update metadata" and "Rewrite database". Now, Music>Compilations on the iPod is empty again. So, something worked, but not as I expected?
EDIT2: I just removed the mapping. Now, Music>Compilations has the two albums that I tagged with IPOD_COMPILATION as before. What's wrong with the mapping? It seems as if I am getting the database update working?

Re: iPod manager

Reply #4111
You don't need to do both, just Update metadata should be enough.

I had another look at the code. It sets the compilation flag only if the mapping outputs a non-zero integer. The square brackets stop a question mark being output if the field does not exist, but that shouldn't make a difference

So, your experience would suggest that %compilation% did not output 1 for any of the tracks you ran Update metadata on. As an experiment, you could set the mapping to just 1 and see if everything moves to the compilation menu.
.

Re: iPod manager

Reply #4112
You don't need to do both, just Update metadata should be enough.

I had another look at the code. It sets the compilation flag only if the mapping outputs a non-zero integer. The square brackets stop a question mark being output if the field does not exist, but that shouldn't make a difference

So, your experience would suggest that %compilation% did not output 1 for any of the tracks you ran Update metadata on. As an experiment, you could set the mapping to just 1 and see if everything moves to the compilation menu.
1. Only the 2 albums I have mentioned where I added IPOD_COMPILATION == 1 are in Music>Compilations
2. "sets the compilation flag only if the mapping outputs a non-zero integer" If this is true, why would this mapping of %compilation% effectively remove the above 2 albums? IOW, why would it change anything?
3. I am just trying to wrap my head around this. If I set the mapping to 1, how do [can] I undo this?? If I change it back to NULL or 0, what will happen? Will the IPOD_COMPILATION == 1 take effect again?

Re: iPod manager

Reply #4113
0.7.1 beta has been released: http://yuo.be/ipod_manager

This will hopefully fix problems using some iPod shuffle 4G devices with the component and also adds support for the equivalent of on-the-go playlists on the iPod nano 7G.

At the moment it's marked as a beta version, but I'll remove that tag if no problems are reported.
.

Re: iPod manager

Reply #4114
Maybe this is a stupid question - but is it possible to add a playlist but without the album (where that track is from) being visible when you go to Music > Albums? So I want to have these separate. Maybe not very clear - but I have 'Album A', 'Album B' and 'Album C' in Albums, now I have a playlist with 1 song from 'Album D' and 1 song from 'Album E' - so I don't want 'Album D' and 'Album E' (with only 1 song) visible there.

Re: iPod manager

Reply #4115
First of all, thank you musicmusic for the great plugin. I am also really happy that you have started to work on your code once again :)

I have the problem, that the ratings that I give on the iPod are not transferred back to foobar. It worked for a while. Then, I started to use the SQLite plugin to be able to generate a playlist that only contains albums that are not completely rated or have an average rating greater 3. I then noticed that the tracks on the iPod did not reduce even as I rated some albums completely with the consequence that should not be on the iPod anymore. I do not know whether SQLite caused the problem.

End of the story is, that I tried with a normal playlist and have removed SQLite - the ratings are still not transferred back and are lost each time I synchronise. Should I completely restore the iPod? Do you have any other idea what I could try?

I have just updated to fb2k 1.4.2 and foo_dop 0.7.1 to test whether the problem is solved to no avail. Before I was running fb2k 1.4.0 and foo_dop 0.7.0. I am using Windows 10 64-bit.



Re: iPod manager

Reply #4118
I have found the issue. The sync of playback statistic data does not work if the music was synchronised only with the "main" playlist which has 23000 items. When I additionally put an album in its own playlist and sync with this playlist as well the data is synchronised. This works as I workaround for me, just have to find a way to chop the sync playlist into smaller ones.

Re: iPod manager

Reply #4119
Maybe this is a stupid question - but is it possible to add a playlist but without the album (where that track is from) being visible when you go to Music > Albums? So I want to have these separate. Maybe not very clear - but I have 'Album A', 'Album B' and 'Album C' in Albums, now I have a playlist with 1 song from 'Album D' and 1 song from 'Album E' - so I don't want 'Album D' and 'Album E' (with only 1 song) visible there.

I don't think this is possible.

Re: iPod manager

Reply #4120
I have found the issue. The sync of playback statistic data does not work if the music was synchronised only with the "main" playlist which has 23000 items. When I additionally put an album in its own playlist and sync with this playlist as well the data is synchronised. This works as I workaround for me, just have to find a way to chop the sync playlist into smaller ones.

Forget the above - I checked the difference between some files and it seems I need to re-sync the whole iPod. If I make a change to a file and it gets re-synced the rating sync works afterwards. Interestingly, when I update a single track in an album it appears at the end of the album view on the iPod, even though it might be the first track.

Re: iPod manager

Reply #4121
The component only tracks files in your local media library passively. In other words, it may lose track of what the local file on your computer corresponding to a file on the iPod is if the local file moves.

From a quick look, the logic looks more primitive than I remember. I thought it made an effort to track files even if they moved by using the modification date, file size and metadata, but as far as I can see that logic is limited to working out which files to sync. That will probably compound the problem as if the file is moved it may realise it doesn't need to be resynced, but then lose the link to the original file for playback statistics purposes.

Having said all of that, according to http://wiki.hydrogenaud.io/index.php?title=Foobar2000:Components/Playback_Statistics_v3.x_(foo_playcount) Playback Statistics uses metadata to track statistics, and metadata will always be available from the track on the iPod. If it is indeed using that, it would only fail if the fields mentioned had been edited locally.
.

Re: iPod manager

Reply #4122
Hi,
Got a bit of an album art mystery going on that I can't just figure out. I recall being able to change embedded album covers with no problems in the past, but now it seems impossible to do, with files on the iPod sticking to that cover they were first embedded with after adding to the iPod (last gen. 160GB Classic) At the moment I'm using foo_dop version 0.6.9.6 with Foobar2000 v1.3.9.

I don't know if this is relevant to the issue I'm having or not, but in the past I  used to have embedded 300x300 resolution album art in my music files, so those got added to the iPod along with the files without any additional work. I then switched to in-folder 1000x1000 covers titled "folder.jpg". Now these bigger non-embedded covers don't get added automatically anymore (and would have been way too big anyway), so I needed to start manually adding properly sized 300x300 artwork to the files after transferring to the iPod (tagging/attach pictures/front cover + ipod/update artwork). Everything worked just as it should.

However, recently I noticed it to be impossible to change from the album cover that was embedded first - the changes to the artwork will show up as expected in Foobar2000, but on the iPod it's the first embedded artwork that would get displayed, no matter what.
Example 1:
-Add album to iPod > embed album cover 1 > it shows up OK in Foobar2000 and on iPod
-change cover: remove artwork>update artwork>add album cover 2
-Foobar2000 shows album having album cover 2, but on iPod it still shows cover 1.
Example 2, the even more puzzling one:
-Have album on iPod with cover 1 embedded
-remove album from iPod > file/ipod/load library > confirm deletion
-eject iPod from PC >reconfirm deletion on iPod itself (even do a soft reset at this stage - hold menu+center button)
-connect to PC > re-add album > don't embed any cover > eject
-iPod shows album as having cover 1.

Edit: I don't recall fiddling with foo_dop's settings (not that there's much to mess up with anyway artwork-wise), though now I did go through them and noticed I had "add artwork to files sent to iPod" enabled, with "source" set to "folder", but even with that, none of my current 1000x1000 folder.jpg artwork has been added to the files I add to my iPod. I did try disabling "add artwork to files sent to iPod", but that only appeared to do exactly that, preventing embedded art from being sent to the iPod even when I specifically manually added them. Felt kind of odd...

As mentioned above, my iPod's a last gen. 160GB Classic running the latest available version 2.0.4 firmware. Hardware-wise there shouldn't also be anything wrong, the HDD showing healthy diagnostics readings of 2 retracts, 0 reallocs and 0 pending sectors.

Any idea what could be causing this and how could I get sorted out?
(please, if just possible, at first something other than a full factory resetting of iPod - I really would appreciate not having to go through the gruelling ordeal of manually re-adding album covers to 22707 songs worth of albums...)

Thanks!  :)

Re: iPod manager

Reply #4123
The first thing to understand is that iPod uses its own database of artwork and doesn't read embedded artwork directly from media files. The artwork in its database is resized to multiple resolutions appropriate to the screen size and various part of the device's UI where artwork is displayed. This component is what populates that database.

So, when a file is sent to the device, the component adds artwork to that database according to the settings in the components configuration. That can include the foobar2000 album art settings if the 'Additionally use foobar2000 built-in artwork reader' setting is enabled.

If the wrong cover is being displayed after sending a file to the iPod afresh, then that wrong cover must exist somewhere on your PC.

You can update the artwork of files already on the iPod by running File/iPod/Load library, right-clicking on the relevant tracks and selecting iPod/Update artwork. However, that will only work if the files on your PC have not moved. (If they have, I believe the command will just try to re-read embedded artwork from the track on the device.)
.

Re: iPod manager

Reply #4124
Oh, so that's it! Makes perfect sense. Thank you! 8)

I must have gotten a completely wrong idea of how foo_dop works with album covers from the days I used embedded art - the covers were there in the files to begin with and showed up on both Foobar and the iPod, so I assumed that was the way it rolled. And of course, whenever using my iPod I noticed an album cover that needed replacing, I updated the embedded art on the files on my PC at the same, and vice versa, so my wrong perception was always maintained! Silly me... ::) 

So... the embedded covers in all the files on the iPod are completely superfluous and can be removed to free up quite a lot of space?
(A bit out of topic I admit, but what's your take on this: instead of going through the process of removing the embedded artwork from the files on the iPod, should I just go ahead and do a full factory reset and readd my music? Just wondering if such removal of embedded covers would introduce quite a bit of fragmentation to files added after that process, with the embedded art now being gone.)

Just gave it a try by swapping the folder.jpg in-folder cover of an album to a different variant, then selecting iPod/update artwork, and bingo, it changed on the iPod! So everything seemsto be working perfectly fine. Thanks again!


P.s. So with foo_dop handling the transfer, resizing and iPod database operations for the artwork, I understand there is no way to change the artwork manually, and the process always works from what art there is on the album in Foobar's media library?
Also, Foobar doesn't seem to display the artwork as on the iPod itself in its album art panel, instead only showing embedde or in-folder art. I presume this is totally normal?

 
SimplePortal 1.0.0 RC1 © 2008-2019