Skip to main content
Topic: foo_looks v2.1 (Read 437730 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_looks v2.1

Reply #875
Guys where i can download other skins for foo_looks 2.1????

foo_looks v2.1

Reply #876
Quote
I just love foo_looks! You can do almost anything with it.  I kind of made it a replacement for the Toaster plugin. It shows up 5secs before song end, dissapears either automatically in 10 secs if I don't hover over it, or by clicking. I can also activate it manually by just moving mouse cursor to the corner of the screen. The info/albumart part of the window can be hidden/shown with one right-click. Still needs much work though, play controls and other stuff, better layout etc..


[a href="index.php?act=findpost&pid=345541"][{POST_SNAPBACK}][/a]

you've got to share that, it would be perfect for what I was wanting to do.  I'd take the time and figure it out myself but I've come down with a cold today.  This would be awesome in the meantime.

foo_looks v2.1

Reply #877
I've had foobar2000 for a while...just heard about foo_looks...installed 2.1 on foobar 0.8.3, and when I activate it, the main foobar window stays, and a smaller window with bright solid colors appears.  So, basically, the plugin isn't working for me....and it doesn't give me any errors.  If i try to download and install a different skin and use it, i get errors with those that usually say "can't find random.png".....any ideas?

foo_looks v2.1

Reply #878
Quote
installed 2.1 on foobar 0.8.3, and when I activate it, the main foobar window stays, and a smaller window with bright solid colors appears.
[a href="index.php?act=findpost&pid=365323"][{POST_SNAPBACK}][/a]

I get exactly the same problem... any help would be appreciated.

foo_looks v2.1

Reply #879
Quote
Hey there,
although I already used the search, I couldn't find a fix for this problem:

My foo_looks skin loses the always on top option every time foobar starts. I have to check always on top twice every startup until it finally stays on top of every window - very annoying. Does anyone know a workaround?

Xanis
[a href="index.php?act=findpost&pid=364669"][{POST_SNAPBACK}][/a]


Code: [Select]
//  upNorth show how to do it :) this is function for fix always on top bug

lua stayAOT
function onattach()
    look_aot(false)
    look_aot(true)
end
endlua

Very nice look !


I see some people still making looks. So i can do sth too. Next version can't wait longer  ....

:edit:
O my page with beta v. do not work too hmm....

foo_looks v2.1

Reply #880
Quote
Quote
installed 2.1 on foobar 0.8.3, and when I activate it, the main foobar window stays, and a smaller window with bright solid colors appears.
[a href="index.php?act=findpost&pid=365323"][{POST_SNAPBACK}][/a]

I get exactly the same problem... any help would be appreciated.
[a href="index.php?act=findpost&pid=365444"][{POST_SNAPBACK}][/a]


Maybe pressing F9 button help you. I guess tha you are using Style XP. You can use pathed uxtheme.dll (in system 32 folder) and load XP skins without program.

foo_looks v2.1

Reply #881
@Hadda

Thank you very much, but I'm afraid it's not working correctly. I used to keep foobar in the tray, so when it starts and shows up in the tray only, your fix is not working and foo_looks still hides. It only works when starting foobar showing its window ... damn. I don't want it to act as a program in the programs overview (alt-tab) and the taskbar (I know there is a plugin, but it doesn't hide it from alt-tab, does it?)

But anyway - thank you  .

foo_looks v2.1

Reply #882
@Xanis:
This bug is very streanch. In foo_looks it important what plugins (and plugins sequence) are instaled. I set AOT in one configuration and this code work to keep this. You can try to rename some plugins to change sequence (experiment on it).

More bugs that i know are:

1) In some sequence of plugins, look show title of song before, and cover art too (this can be fixed).

2) Mouse wheel don't work on first time.

And this AOT bug can be fixed too, but i do not really know how but only have some hinds.

foo_looks v2.1

Reply #883
Quote
This bug is very streanch. In foo_looks it important what plugins (and plugins sequence) are instaled.

Yes it appears to be due to a conflict with another plugin. I tried foo_looks 2.1 with the foobar2000 "lite" installer, and it worked fine. I'll try to narrow down which components are causing trouble.

Edit: I was able to add all components back into foobar without recreating the bug - must be a component order issue as you mentionned.
Thanks!

foo_looks v2.1

Reply #884
is foo_looks avaiable for foobat 0.9 RC?

foo_looks v2.1

Reply #885
Hi, I installed and reinstalled foo_looks as well as foobar 8.3 itself but it keeps crashing... I thought I read somewhere something about getting some "lua dlls" or something... really I have no idea why it is crashing.

What happens is this:

with "foo_looks.dll" in components, as well as the foo_looks tree in components

and interface set to "default"

it starts and draws both the main foobar 2000 standard interface, as well as a little tiny hovering window with album cover that was never there before - presumably something to do with the foo_looks interface even tho i haven't activated it yet.

so i go to the preferences tree which opens just fine
but as soon as I actually click on the "Looks" entry under the components portion of the tree, it crashes

any ideas?

foo_looks v2.1

Reply #886
Quote
is foo_looks avaiable for foobat 0.9 RC?
[a href="index.php?act=findpost&pid=370841"][{POST_SNAPBACK}][/a]


It's not and probably won't be. DanZ has vanished from the face of the earth and he never released any sources which makes the tweaking needed to get it working with 0.9 and recompiling impossible.

foo_looks v2.1

Reply #887
Does this mean I can't use FooPilot with foobar 0.9?

foo_looks v2.1

Reply #888
Quote
Does this mean I can't use FooPilot with foobar 0.9?
Yes.

Alessandro

foo_looks v2.1

Reply #889
Quote
Does this mean I can't use FooPilot with foobar 0.9?
Yes.

Alessandro


That's a very bad news    I hoped somebody has the sources to compile foo_looks with 0.9 SDK.

foo_looks v2.1

Reply #890
I'm really bummed.  I used FooPilot all the time.  Is there another plug-in that's similar?  Thanks. 

foo_looks v2.1

Reply #891
And this component seems to be dead too 

Is anybody interested to do a somponent which would enable something like a "winshade mode" for foobar2000. This is the last thing I'm missing in v0.9.

foo_looks v2.1

Reply #892
Sorry guys, i have a problem installing this component.
I receive this error:
Code: [Select]
Failed to load DLL: foo_looks.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.


Thx for the help!

Kwb
Sorry for my poor english!

foo_looks v2.1

Reply #893
What version of foobar are you trying to run it in?

It doesn't work in the latest 0.9 only in 0.8.3 downwards.

foo_looks v2.1

Reply #894
Uff, what a pity!
Will be this plugin compatible with the newest foobar?

Sorry for my poor english
Sorry for my poor english!

foo_looks v2.1

Reply #895
Alright, since this component has been out of development for a very long time I'll lock this thread now. In case anyone ever picks up development on it again then please simply open a new thread for discussion.

 
SimplePortal 1.0.0 RC1 © 2008-2019