Skip to main content
Topic: foo_input_usf - Hang on Convert (Read 502 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_input_usf - Hang on Convert

I remember seeing mentions of this plugin hanging a long time ago but nothing recently.

Josh on HCS recently ripped LEGO Racers, but it seems two of the tracks cause Kode's USF plugin to hang. I've attached them to this post for reference. I've tried both HLE and non-HLE mode, same result. You have to kill Foobar via Task Manager otherwise it says eating up CPU in the background even after the interface is closed.

Plugin and Foobar are both the latest version.


Re: foo_input_usf - Hang on Convert

Reply #1
Yes, that is correct, the USF library I use has no protection against the emulator hanging in a loop and not generating any audio. I have tried to insert hang protection, but it tripped on too many working rips.

.miniusf files are also useless without the .usflib they come with.

This is just a sign that the emulator needs a bit of work. If I replicate the playback settings used in the ripping coverage process used by the library, half of the existing rips from years ago will instead cause the player to hang instead of working most of the time. I could add a tag for this, but that calls for extension of the standard document for this emulated xSF format to include a new required tag.

SimplePortal 1.0.0 RC1 © 2008-2019