Skip to main content
Topic: foo_youtube (Read 211255 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_youtube

Reply #250
Quote
Ensure that you are using audio-only streams (ffmpeg required). There is nothing else that I can suggest.

Thanks, it works better now.

Oh and one more thing, I also started to watch video via your component. Could youtube video window stay same size whole time when I change it once? Everytime I start new clip it resizes to its native size.

foo_youtube

Reply #251
Quote
Ensure that you are using audio-only streams (ffmpeg required). There is nothing else that I can suggest.

Thanks, it works better now.

Oh and one more thing, I also started to watch video via your component. Could youtube video window stay same size whole time when I change it once? Everytime I start new clip it resizes to its native size.


Check ''Fix to current''.

foo_youtube

Reply #252
Feature Request: Soundcloud support



I don't know if you've considered it yet (I can't find this addressed in this topic) or if it's still feasible.
I used to queue up Soundcloud songs with foo_run and foo_scrap

foo_youtube

Reply #253
Thanks for help with windows size, its great now. Two more questions: why sometimes when I add a clip into my playlist and try to play it it says "forbidden 403" or "unsuported file format" (when using ffmpeg) it only happens in few clips. Also why when i change "clip title parsing rule" it always comes back to
Quote
(?:%artist% - )?%title%(?:\s+[\(\[].+?[\)\]]\s*)?
Often im listening to electronic music so i would like to have "somebody remix" in title but plug just skip s this.

foo_youtube

Reply #254
@onirwai
Component is already quite a big to mix it with other services and eventually it called foo_youtube. So no Soundcloud, Spotify or any other services or sites will be supported within this component.

why sometimes when I add a clip into my playlist and try to play it it says "forbidden 403" or "unsuported file format" (when using ffmpeg) it only happens in few clips.

Need more details, I can't say why 'sometimes some clips' don't work. Is it constantly happens on particular clips? Give then clips URLs (espetially for 'unsuported file format' when using ffmpeg). Which ffmpeg version are you using? If you changed some settings in Decoder tab then also provide them. When such problem happens also check Log tab in main component window, it already may have explanation for your case.

Also why when i change "clip title parsing rule" it always comes back to
Quote
(?:%artist% - )?%title%(?:\s+[\(\[].+?[\)\]]\s*)?
Often im listening to electronic music so i would like to have "somebody remix" in title but plug just skip s this.

It's a bug, noted. Currently clicking on OK does not apply settings if only this rule was changed. So as temporary solution also change some other setting in Decoder tab (Apply button should become active). Also note that regex currently is case-sensitive (will be also fixed).

foo_youtube

Reply #255
Hello and thanks for the plugin  About the 403 error it's back again? Cause i try to play this link https://www.youtube.com/watch?v=GrpHqu_8ihI and
Unable to open item for playback (Forbidden (403)):
"3dydfy://www.youtube.com/watch?v=GrpHqu_8ihI"

foo_youtube

Reply #256
Yep, it's back. Thanks for reporting, working on it.

 

foo_youtube

Reply #257
For all who has 403 error, check this build: foo_youtube_0.0.20_dev1
If all will be ok after few days will be release.

foo_youtube

Reply #258
Thank you, no more 403    but what it is happening with this particular error since it keep coming back?

foo_youtube

Reply #259
Awesome plugin! I was looking for something exactly like it.

foo_youtube

Reply #260
I was have 403 only in few tracks , now it's gone..
Thanks.

foo_youtube

Reply #261
New version:
foo_youtube_0.0.20

Changes:
- fixes for clip title parsing rule
- fix for 403 error

foo_youtube

Reply #262
Many thanks for the update

foo_youtube

Reply #263
Unfortunately the "Unable to open item for playback (Forbidden (403)" issue has returned for me again. I am using v0.0.20. Yesterday all tracks played fine. Today most tracks give the error. I hope you can fix it. Once again thanks for all your hard work on this plug-in which is much appreciated

foo_youtube

Reply #264
Yep.. unfortunately it's back again
Unable to open item for playback (3dydfy: Server error (code #403)):
"3dydfy://www.youtube.com/watch?v=SYM-RJwSGQ8"

foo_youtube

Reply #265
Ok, working on it. Btw, better to threat this as an attribute of this component: periodically it just stops to work because of changes on Youtube. So no need to thank but don't forget to notify.

foo_youtube

Reply #266
Ok, working on it. Btw, better to threat this as an attribute of this component: periodically it just stops to work because of changes on Youtube. So no need to thank but don't forget to notify.


It would be good, if we can send notify for error 403 trough component, or that component do this automaticaly(if number of errors 403 is high to analyze that URL's and send info)...

foo_youtube

Reply #267
Collecting something in background and sending automatically imho is not good. But centralize notifications in one place (so others will see that problem already known) and possibility for quick and simple notification (to decrease fixing time) is a good idea.

foo_youtube

Reply #268
New version:
foo_youtube_0.0.21

Changelog:
- no subtitles preloading at video opening. Instead of downloading all subtitles at opening now particular subtitle downloads at the time when it was selected
- possibility to use synced lyrics as video subtitles. Placed in Subtitles popup of video context menu. Uses synced lyrics from Lyric Show 3, works only if there used default search pattern and lyrics are saving to configuration folder. Becomes enabled only if appropriate lyrics exist in the folder (checks every time when video context menu shows)
- problem reporting through Help menu. For centralization of the reports and problem solving status. Known issues will be also shown there
- removed 'show menu item <...>' options from Advanced preferences

foo_youtube

Reply #269
Big thanks for the update

foo_youtube

Reply #270
Just to confirm that I have not had any 403s with version 0.0.21.

foo_youtube

Reply #271
Unable to open item for playback (DNS error : could not resolve "r18---sn-c0q7ln7k.googlevideo.com"):
"3dydfy://www.youtube.com/watch?fb2k_title=Jack%20in%20The%20Box&3dydfy_alt_length=144&fb2k_artist=Jessica%20Sutta&v=8ZYCoKUVvE8"

what this error mean?

foo_youtube

Reply #272
DNS error relates to Internet connection, not to Youtube or this component. I.e. probably you had some temporary problem with your Internet connection or it was on server side.

foo_youtube

Reply #273
DNS error relates to Internet connection, not to Youtube or this component. I.e. probably you had some temporary problem with your Internet connection or it was on server side.


thank's, problem is gone by itself after 10 min..

foo_youtube

Reply #274
This component is sick! 3dyd you great great man!
Just one thing, some videos don't start video playback I get this error.

Can't start playback
Loading a file: Unspecified error

Does it just not work with every video?

 
SimplePortal 1.0.0 RC1 © 2008-2019