Skip to main content
Topic: foobar2000 v1.3 beta feedback (Read 46355 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foobar2000 v1.3 beta feedback

1)

Playlist management is screwed up, "Load Playlist" doesn't work properly. It replaces the first two items with the name of the playlist file (ex: Test1.fpl) and rearranges the items in the playlist.





2)

If I add items manually they convert but when I drag&drop from the library it gives "Object not found" error. Even for the playback.

I just did re-add the library from scratch, all seems fine now.

False alarm, when foobar2000 is restarted the library is gone, all items are missing from playing or converting.

3)

Loading time goes from 0.00:44 to 0.00:33 (which is good). Memory usage is the same, ~46MB.

foobar2000 v1.3 beta feedback

Reply #1
"Also, selecting a large number of tracks and going to "properties" takes ages, as it indexes each file. This operation used to be near-instant."

Exactly. This is massively annoying.

I selected 176.000 files, instead of a few seconds it took 4m50s.

Memory usage is ~650MB until unselected, more than double than before.

The taskbar icon is green as if it was still processing something (maybe because foobar2000 nearly crashed before showing the properties dialogue).

It goes away after selecting another file and viewing its properties.

Memory usage after that is ~435MB, still a lot more than before.

This needs to be resolved, the main point of this update was to make foobar2000 more suitable for large databases, the opposite happened.

Also, the media library is still initializing, long after I started the program.

foobar2000 v1.3 beta feedback

Reply #2
Loading properties for the first time on 50,000 files takes about 5 seconds on my i3-3220 3.3GHz with 8GB of RAM. All of the tracks are on a 1TB WD Black Edition, one of the faster HD's when it came out. I don't have any lyrics, and less than half have any sort of comments tag.

The library searches I've tried are instantaneous. This seems faster than before, but I can't be sure because I recently upgraded my cpu, so I'm often surprised by how fast most operations seem nowadays.

I imagine it's worth mentioning if you have any autoplaylists, playlists,  or other library viewers, as well as how many, their size, etc. I use one playlist and no autoplaylists (I keep them listed in a WSH panel, and open them as needed). With entire library listed in a Facets panel, all selected, and Properties open, I'm using only 100MB of RAM.
That's so plausible, I can't believe it.

foobar2000 v1.3 beta feedback

Reply #3
I've noticed a big improvement in startup times for my portable install (went from 1.24 to 1.3). To follow DustMagnet:
Loading properties for the first time on 10,000 files takes about 1 second on my AMD FX-8120 with 8GB of RAM (foobar2000 is on Samsung SSD, tracks on Seagate 7200 HDD). It's noticeably snappier at startup with 3 large autoplaylists and also running Yirkha's foo_dynfil (doing some calcs -- don't know if that's benefited from recent changes).

Thanks Peter.

C.
PC = TAK + LossyWAV  ::  Portable = Opus (130)

foobar2000 v1.3 beta feedback

Reply #4
Playlist management is screwed up, "Load Playlist" doesn't work properly. It replaces the first two items with the name of the playlist file (ex: Test1.fpl) and rearranges the items in the playlist.
Fixed for the next version, thanks for reporting.

foobar2000 v1.3 beta feedback

Reply #5
Peter, possible bug (certainly a change in behaviour from previous versions):

Situation:

Drag and drop playlist tracks from one (v.1.3) installation of foobar2000 to another (in this case 1.2.9):

Previous behaviour:
The playlist track order used to be maintained across the different installations (say a portable to your main installation);

Since 1.3
Now the tracks get re-ordered, seemingly by %path%.

C.
PC = TAK + LossyWAV  ::  Portable = Opus (130)

foobar2000 v1.3 beta feedback

Reply #6
Peter, possible bug (certainly a change in behaviour from previous versions):

Situation:

Drag and drop playlist tracks from one (v.1.3) installation of foobar2000 to another (in this case 1.2.9):

Previous behaviour:
The playlist track order used to be maintained across the different installations (say a portable to your main installation);

Since 1.3
Now the tracks get re-ordered, seemingly by %path%.

C.
Thanks for the report - this is another symptom of the "load playlist" bug reported earlier. Already fixed.

foobar2000 v1.3 beta feedback

Reply #7
On my portable installation, the update doesn't work at all. It says that it does not have access to the files when I want to play one. The status of the library is "error". When I delete the library and add it again it works but only till the next start of Foobar2000. Then the same happens again.

foobar2000 v1.3 beta feedback

Reply #8
On my portable installation, the update doesn't work at all. It says that it does not have access to the files when I want to play one. The status of the library is "error". When I delete the library and add it again it works but only till the next start of Foobar2000. Then the same happens again.

Exactly like my 2nd point, it's the one of the most important features.

foobar2000 v1.3 beta feedback

Reply #9
And that's probably another symptom of the playlist load failure?

foobar2000 v1.3 beta feedback

Reply #10
Folder monitoring doesn't seem to work properly. I unpacked a few folders, both my automatic folders with a Path or with a search string still show the deleted archives, but don't show the upacked files.

This is a big issue, I hope this gets fixed soon.

foobar2000 v1.3 beta feedback

Reply #11
Can't edit my post, but monitoring seems to work, but takes ages (1 or 2 hours for ~800MB packed folders).

foobar2000 v1.3 beta feedback

Reply #12
The beta shows a message "Cannot write changes to the library (access denied)" every time I close it.

foobar2000 v1.3 beta feedback

Reply #13
lyrics seem to be broken. The field shows up in the properties panel with a content of ".". The track properties dialog (after F2) shows the content correctly.

foobar2000 v1.3 beta feedback

Reply #14
Upon opening the working set of foobar2000 1.2.9 is approx. 172k and pretty steady.
Upon opening the working set of foobar2000_v1.3_beta_1 starts at about 270k and grows to 400k within a few seconds.
The console has a very long list of items like
"Location not parsable: "\Zips\...", reason: Object not found"
apparently one per item on the disk where my portable install of foobar2000 exists.
Perhaps it's related to one of my library music folders being "..\" (since I install foobar2000 at the top of my music library.)

foobar2000 v1.3 beta feedback

Reply #15
When loading a playlist file (in this case a m3u) in v1.3 Beta so does it pop up at the bottom of fb2k playlist window and sometimes so doesn't the track number show even if they are available in the tags.


foobar2000 v1.3 beta feedback

Reply #16
Beta 2 will be out at the end of the week.

Various bugs (crashing, bad behavior of playlist loader, "object not found" spree when using relative paths in Media Library) will be corrected, thanks for the feedback.

The future of changed lyrics etc tag handling is yet to be determined. If this change bothers you, please stick with 1.2.9 until this is sorted out one way or another. Properties dialog opening causing reload of info from your whole library is indeed unacceptable.

foobar2000 v1.3 beta feedback

Reply #17
Nice. Please consider adding the COMMENT field to the database, or at least make it longer.
A lot of people (like me) use it to store the tracklist of mixes. It is now impossible to search for those tracks.

If you don't want to do that, add an option to make that possible for people like me (with the obvious consequences regarding memory/speed).

foobar2000 v1.3 beta feedback

Reply #18
I guess the correction covers this as well, but just wanted to inform, if not.

Media Library:
Path = ..\..\..\Opus
Status = Error!
Windows 10 Pro x64 // foobar2000 1.3.10

foobar2000 v1.3 beta feedback

Reply #19
The beta shows a message "Cannot write changes to the library (access denied)" every time I close it.

I'm not getting it on close, but I am getting it sporadically while foobar2000 is running. Clicking Retry usually works, but sometimes it comes back up two or three times.

Nothing is showing up in my console log about this, so I don't know if there's some kind of debugging I have turned off that would help.

foobar2000 v1.3 beta feedback

Reply #20
i just moved from 1.1.18 to 1.3 (was afraid of ffmpeg quality a little bit). "Generic performance optimizations, mainly affecting very large playlists and libraries." and "Playlist & Media Library search dialogs no longer block UI when performing lookups." motivated me to upgrade... and have to say that i'm disappointed. after start foobar is using my hdd like crazy for some noticible time, without any information in console of whats going on, and searching in music lib is not faster at all! however when i search there i noticed huge ram usage and program ui still freezes. can't see any improvements, but since its beta i will just be patient and hope for more polishing.
by the way, how do i remove ugly speaker icon next to volume control on status bar? keep up the good work and thanks for foobar in general!

foobar2000 v1.3 beta feedback

Reply #21
except for the start, foobar behaves exactly as in the post above
after starting, foobar uses 200mb ram. when searching, at least 9 times out of 10, ui freezes right after typing the first letter and if it doesn't freeze it lags
furthermore ram usage spikes to 320 mb and drops to 200 again as soon as the freeze/lag is over
funny thing, because yesterday it worked way better (better, however not 'good')

additionally, yesterday foobar crashed (not responding) for the first time in a long time. i actually can not recall when it did the last time.
this happend when i was moving files around. i forgot that 'move everthing in the source folder' was checked...foobar had to move 6+ gb...
unfortunately, i didn't send the crash report

foobar2000 v1.3 beta feedback

Reply #22
PAUSE doesn't work as expected.

Foobar 1.3b1 paused restarts itself after a certain amount of time (not always the same).

Problem never seen before.

Regards, Andrea


foobar2000 v1.3 beta feedback

Reply #24
PAUSE doesn't work as expected.

Foobar 1.3b1 paused restarts itself after a certain amount of time (not always the same).

Problem never seen before.

Regards, Andrea



I can verify this also.

 
SimplePortal 1.0.0 RC1 © 2008-2019