Hydrogenaudio Forums

Hosted Forums => foobar2000 => Support - (fb2k) => Topic started by: zivshosh on 2020-11-22 09:36:08

Title: foobar 1.6.2 can't play ape?
Post by: zivshosh on 2020-11-22 09:36:08
Greetings
foobar 1.6.2 is my only audio player
it used to play ape files
now it doesn't
it has monkey's audio decoder component
the error message I get is:
Unable to open item for playback (Unsupported file format)
what do I have to do to play ape files as I used to?
thank you
Title: Re: foobar 1.6.2 can't play ape?
Post by: zivshosh on 2020-11-22 09:47:20
(cont.)
but it does play ape thru a cue file
so what is missing in a folder of ape files that foobar cannot play?
thank you
Title: Re: foobar 1.6.2 can't play ape?
Post by: zivshosh on 2020-11-22 09:58:12
temporary solution: converted ape to flac
but it is odd why cue+ape is played and a folder of ape files foobar cannot play
Title: Re: foobar 1.6.2 can't play ape?
Post by: Case on 2020-11-22 11:23:08
I don't have good enough imagination to come up with a scenario to replicate this problem. But I can tell you that playing Monkey's Audio files without cue sheets work just fine with foobar2000 v1.6.2.

Care to try with a clean portable install with nothing but Monkey's Audio Decoder added as an extra? Or some extra info how to replicate the playback problem with clear-enough steps that I can follow them.
Title: Re: foobar 1.6.2 can't play ape?
Post by: zivshosh on 2020-11-26 09:34:50
I agree that it is hard to imagine. It never happened before and I'm using foobar2000 for years. Will try to find another example and attach if it is possible. maybe these ape files were corrupted
anyway foobar error message that this type is not supported was wrong since cue+ape is played without a problem and ape component is present and need no update.
Does ape file binary start with MAC?
Title: Re: foobar 1.6.2 can't play ape?
Post by: Porcus on 2020-11-26 10:46:28
Sharing a file here in the open might not be the best (both for legal and for technical reasons), but if you upload one of the offending file somewhere (like, Sendspace) and PM over a link?
Title: Re: foobar 1.6.2 can't play ape?
Post by: Rollin on 2020-11-26 14:17:12
Can you try this version of foo_input_monkey? https://foobar2000.org/components/view/foo_input_monkey/release/2.4
Title: Re: foobar 1.6.2 can't play ape?
Post by: kode54 on 2020-11-26 16:04:58
(The component lists an older version as the "current" version, because it somehow matters that decoding is slower now, even though it is likely less than 1% of a CPU core to decode in real time. Note that the speeds that are being compared are unlikely to have any effect unless you are converting to WAV files on an NVMe SSD, or running ego pumping benchmarks.)
SimplePortal 1.0.0 RC1 © 2008-2021