Hydrogenaudio Forums

Lossless Audio Compression => FLAC => Topic started by: Spymaster on 2020-02-24 20:08:39

Title: Marantz not reading FLAC track artists
Post by: Spymaster on 2020-02-24 20:08:39
I've been experiencing something very odd.

I rip my CDs to FLAC using dppoweramp and store them on a Synology NAS. I play them back using a variety of devices including Denon AV receiver, Marantz M-CR603 mini hi-fi and Synology's DS Audio app.

I collect mostly soundtrack (score) CDs. I normally tag the composer as the album artist and then tag each track with either that same composer, or the performer of a song.

When playing back on most devices, the panel displays track title and track artist correctly. However the Marantz has instead been showing the album artist against each track instead of the track artist. I tried every logical setting without success.

Tonight I stumbled on the solution by accident and it's bizarre. If I change the "Disc number" field from "1" to [blank] after I upload, suddenly the track artist displays correctly on the Marantz.  It works but its very time-consuming across 6000 albums!

Does anyone know why "disc number" might affect the "track artist" display like this? Is it unique to Marantz? I've emailed Marantz themselves but no reply yet.

Thanks!
Title: Re: Marantz not reading FLAC track artists
Post by: Roseval on 2020-02-24 21:09:32
I assume you are using UPnP/DLNA

Obvious something goes wrong in the communication  between server and client.
As all devices work properly except the Marantz, the latter does something silly.
Sometimes it can help to have a tag ALBUM ARTIST and ALBUMARTIST
Use any tool e.g. MP3Tag to inspect all the tags as written in the file, maybe something is doubled, misspelled , a delimiter, etc.  fooling the Marantz.
Title: Re: Marantz not reading FLAC track artists
Post by: Spymaster on 2020-02-25 21:05:14
I assume you are using UPnP/DLNA

Obvious something goes wrong in the communication  between server and client.
As all devices work properly except the Marantz, the latter does something silly.
Sometimes it can help to have a tag ALBUM ARTIST and ALBUMARTIST
Use any tool e.g. MP3Tag to inspect all the tags as written in the file, maybe something is doubled, misspelled , a delimiter, etc.  fooling the Marantz.


I downloaded and tried MP3tag. The tags look fine - nothing unusual at all.

The more I delve into this, the weirder it gets. If I remove the disc number when I rip, upload to the NAS, and play through the Marantz then it shows the "album artist" (incorrectly) against each track when it plays. If, once on the NAS, I change the disc number to "1", save it, then change back to blank, and save it again, then the Marantz plays back the "track artists" correctly,

Is anyone else streaming with Marantz equipment?
SimplePortal 1.0.0 RC1 © 2008-2020