CD-R and Audio Hardware => CD Hardware/Software => Topic started by: uselessladder on 2019-10-06 23:04:47

Title: CD ejects by itself while ripping or playing?
Post by: uselessladder on 2019-10-06 23:04:47
Today I encountered a strange problem while ripping a CD (Edgar Froese: The Virgin Years disc 3) with my LG AP70NS50 external drive in EAC secure mode. The first four tracks (out of 11) ripped uneventfully, but in the middle of the 5th track the CD suddenly ejected. On the second attempt the 5th thrack ripped, but the CD popped out on the 6th. I tried ripping with iTunes, to the same result. I eventually managed to rip the rest of the disc (in iTunes) but I had to re-insert it in the drive about 10 times. The resulting rip sounds fine but of course I can't be sure how accurate it is.
This has never happened to me before. It's especially strange because normally EAC locks the drive during extraction and it won't eject even if the button is pressed.
I tried simply playing the disc, and it ejects even on playback (but not always on the same place or the same track).
I ripped 3 other CDs afterwards and they worked as normal. The drive is barely a month old. The problem CD is brand new. Any idea what the cause could be? Is the disc defective?
Title: Re: CD ejects by itself while ripping or playing?
Post by: ajp9 on 2019-10-07 05:25:09
If you're on Windows 10, it could be AutoPlay. If that's the case try going to Devices > AutoPlay > External Drives, and set the drive to do nothing on insert. Certain releases of Win 10 have a bug that erroneously ejects.

Otherwise, it may be a driver issue.  It's not likely to be the drive as it's fairly new. And discs with errors aren't going to eject automatically unless you've told the software to eject when finished ripping—doesn't sound like that since it's happening across programs and during play.
SimplePortal 1.0.0 RC1 © 2008-2021