Hydrogenaudio Forums

Hosted Forums => foobar2000 => Support - (fb2k) => Topic started by: Le Croissant on 2019-01-23 14:15:58

Title: Album Display....bug?
Post by: Le Croissant on 2019-01-23 14:15:58
I'm not sure if this just happened or my foobar has always been doing this and I only just noticed it.
But the black selection bar seems to continue as a shadow over my album art and artist display (see included pictures)

I'd love to know how to fix this.
Title: Re: Album Display....bug?
Post by: Case on 2019-01-23 14:46:47
The bar isn't over the album art. Unfortunately the shadow bug comes from your monitor. You could probably remove it by reducing the contrast of the colors.
Title: Re: Album Display....bug?
Post by: Le Croissant on 2019-01-24 13:53:06
The bar isn't over the album art. Unfortunately the shadow bug comes from your monitor. You could probably remove it by reducing the contrast of the colors.
Changing the brightness/contrast of my screen does nothing to change the shadow.
But nevertheless I think you're correct. My monitor is an old POS, I'm looking at replacing it.
But if the bug is just my display why would it appear on the screenshots too?
Title: Re: Album Display....bug?
Post by: j7n on 2019-01-24 14:34:46
The black bar does not appear on the screenshot. Scroll the image off the screen or cover the left portion with a light rectangle, and the shadow will disappear.
Title: Re: Album Display....bug?
Post by: anamorphic on 2019-01-24 16:16:14
Changing the brightness/contrast of my screen does nothing to change the shadow.
I think Case meant changing contrast of foobar colors(?) - the black selection on light background, as a temporary fix.

Quote
But if the bug is just my display why would it appear on the screenshots too?
Uh, because you are looking at it on your monitor and your monitor has a shadow problem... (Put another way, you are taking a screenshot from before it reaches your monitor, but only seeing it after - the screenshot is clear, the screen is not). Maybe you have a mobile phone or other device to have a look at the screenshot on.

What type of monitor? The ol' CRT monitors could have many issues. Try a lower resolution and vertical refresh rate - 100Hz? I've seen LCDs have a shadow with certain (cheap) cables. What type of cable? Can you switch to digital - DVI / HDMI? Try the ol' unplug and plug it back in again (seriously) - tweak the plug contacts. It might save you some money. ;)

Cheers
Title: Re: Album Display....bug?
Post by: TheQwertiest on 2019-01-24 16:27:33
deleted, coz I can't read...
Title: Re: Album Display....bug?
Post by: Daeron on 2019-01-24 18:10:09
I'm guessing you are using VGA to connect said monitor. Ghosting issues are pretty common with those cables (and some older monitors). You can try wiggling it around (both the cable and the connectors) to hopefully reduce the effect. Look for bent cables primarily. If you see it changing, then you have the culprit identified.

You can also draw a black rectangle in paint (perhaps also fill the background with the same color as your panel) and see it bleed sideways just the same. Your screenshot has no such thing visible viewed on a good monitor, so it's your hardware, not foobar.

Some examples:
http://i34.tinypic.com/s2tfk1.jpg (http://i34.tinypic.com/s2tfk1.jpg)
https://linustechtips.com/main/uploads/monthly_2018_08/IMG_20180901_043746.jpg.9ed13f46e40e5abc62bf54402e486ad7.jpg (https://linustechtips.com/main/uploads/monthly_2018_08/IMG_20180901_043746.jpg.9ed13f46e40e5abc62bf54402e486ad7.jpg)
Title: Re: Album Display....bug?
Post by: j7n on 2019-01-25 07:28:33
If you have a two port video card, try plugging the VGA cable into the other connector through a DVI adapter. The output that is internally connected in the computer via a flat cable might be worse. Also try replacing the VGA cable. I had problems with ghosting echoes from the thin cable that was bundled with the monitor. I replaced it with another cable I had around from a projector, and solved the problem completely. But if the streaks are long, and extend through the entire album art area, I suspect the problem to be inside the display.
Title: Re: Album Display....bug?
Post by: Le Croissant on 2019-01-27 18:24:41
Wow, this post received way more comments than I expected LOL.

Since I asked the question I have noticed similar shadow glitches popping up on internet and other places.
So that confirms that my monitor is the issue. As I said, It's a piece of junk. I'll replace it once I get a little bit of cash.
SimplePortal 1.0.0 RC1 © 2008-2019