Hydrogenaudio Forums

Hosted Forums => foobar2000 => Support - (fb2k) => Topic started by: GCRaistlin on 2019-01-19 23:01:39

Title: Open... dialog goes mad
Post by: GCRaistlin on 2019-01-19 23:01:39
It'll take a lot of time and blinking until the list will be shown. If there are even more input plugins installed (try attached set) the list can't be shown at all.
Title: Re: Open... dialog goes mad
Post by: kode54 on 2019-01-21 04:23:12
Are you running Windows XP? The Windows Vista and higher file open dialogs have no problems with the literal hundreds of file types reported by foo_input_vgmstream. Although, if you like, I can try trimming it down to a single file type listing all of the literal hundreds of filename extensions as a single entry, without also including them in the name of the file type item.
Title: Re: Open... dialog goes mad
Post by: GCRaistlin on 2019-01-21 05:03:13
No I use Windows 8.1 x64.
Title: Re: Open... dialog goes mad
Post by: Case on 2019-01-21 06:49:22
kode54, the issue actually only affects newer OSes. Since GCRaistlin still doesn't know that bug reports require details I was forced to test the problem on several systems. Even on my super slow emulated Pentium II machine running XP the open dialog showed no issues. Windows 7 was fine too.

Peter has been made aware of the problem. I believe he can work around it without changing components, or at least I hope so.
Title: Re: Open... dialog goes mad
Post by: GCRaistlin on 2019-01-21 07:05:35
What further details can be provided here? I described all steps in the first post (except the OS being used).
Title: Re: Open... dialog goes mad
Post by: Case on 2019-01-21 07:11:10
Nothing anymore but had you said your OS in the first post you would have saved a lot of my time. I started testing with Windows XP and went up from there.
Title: Re: Open... dialog goes mad
Post by: kode54 on 2019-01-21 09:08:34
I only tested on Windows 10, without constraining the processor speed.
Title: Re: Open... dialog goes mad
Post by: TheQwertiest on 2019-01-21 09:32:17
@Case : your aggressiveness is uncalled for - @GCRaistlin provided enough details to start diagnosing the issue, he is not a QA tester nor there is a template for bug reports available here.
The bug might have been affecting all the OSes or might have even been a known bug for some component that he used for all he knows.
Title: Re: Open... dialog goes mad
Post by: Case on 2019-01-21 09:47:12
The support forum has a pinned post Support forum rules (https://hydrogenaud.io/index.php/topic,67779.0.html) that states everything one needs to mention when reporting problems. It gets very frustrating when majority of problem reports don't mention a single helpful extra detail and one has to either specifically request for details or try his luck in reproducing the error.

He had posted another problem report just a day before where I spent quite some time verifying. I had to create albums with CUE sheets and tested various foobar2000 versions only to come back to report that I can't reproduce his problem.

If you search my post history I think majority of them consists of posts asking for more details. It gets tiresome after a while when people this day should know better.
Title: Re: Open... dialog goes mad
Post by: TheQwertiest on 2019-01-21 10:00:05
> It gets tiresome after a while...
It sure does =)

> ... people this day should know better.
Haha, only in our dreams... IMO, the only way to get full info (or at least more than usual) is to have a must-fill bug report template (like in GitHub issues), but I'm not sure if it's possible to implement it in forum engine.
Title: Re: Open... dialog goes mad
Post by: Peter on 2019-01-21 12:30:09
Workaround added for version 1.4.2 final. Thanks for reporting.
SimplePortal 1.0.0 RC1 © 2008-2019