Hydrogenaudio Forums

CD-R and Audio Hardware => CUETools => Topic started by: JediSQL on 2018-12-29 05:51:00

Title: Exception: no opencl platforms found
Post by: JediSQL on 2018-12-29 05:51:00
I thought I would give the FLACCL encoder in CUETools 2.1.6 a try since I have a half-decent, semi-modern NVidia GeForce GT 730. When I do, though, I get this message:

Exception: no opencl platforms found

I checked the Windows 10 (1803) "Driver File Details" for my GT 730, and it lists ...\OpenCL.dll and ...\OpenCL64.dll drivers.
They are both version 2.0.4.0 from Khronos Group.

Any suggestions?
Title: Re: Exception: no opencl platforms found
Post by: Case on 2018-12-29 09:16:43
At least Windows 10 upgrades reinstall graphics drivers in a way that OpenCL isn't recognized. Easiest fix is to download the latest drivers from https://www.nvidia.com/Download/index.aspx?lang=en-us (https://www.nvidia.com/Download/index.aspx?lang=en-us) and install them.
Title: Re: Exception: no opencl platforms found
Post by: JediSQL on 2018-12-31 01:36:23
Case,

Thank you. Manual driver install got it. It is even actually faster. FLACCL encodes faster at level 8 than the cuetools encoder at level 6 :)). I don't know how many times I have gone to the trouble to get something like this to work, and it ends up not making a difference :o.

For the WAV file I chose for comparing, cuetools took ~15 seconds, and FLACCL took ~12 seconds. That is ~23% faster 8) (or, ~20% less time).
SimplePortal 1.0.0 RC1 © 2008-2019