Hydrogenaudio Forums

CD-R and Audio Hardware => Audio Hardware => Topic started by: riverlethe on 2018-04-05 15:00:03

Title: “Vintage” amps
Post by: riverlethe on 2018-04-05 15:00:03
I found a 30-year old Kenwood KM-207 in a vinyl shop. Is there anything I should be concerned about other than leaking caps?
Title: Re: “Vintage” amps
Post by: antz on 2018-04-05 16:20:29
Noisy switches, noisy pots (volume, balance etc) and possibly leaking caps. Until recently I had a "vintage" amp, a 35 year-old Technics, that I replaced mainly because the pots & switches were noisy and unreliable. Replacing the old parts would have been uneconomic, even if they could have been obtained (which is doubtful). Pity because it worked perfectly from an electronics point of view. Check everything works as expected before parting with your money!
Title: Re: “Vintage” amps
Post by: Artie on 2018-04-09 15:30:18
Noisy switches, noisy pots (volume, balance etc) . . .

It seems like a shame to discard a piece of equipment that you like, when a good going over with Deoxit may have brought it back to life. I guess it depends on the severity of the scratchiness and noise.
Title: Re: “Vintage” amps
Post by: antz on 2018-04-09 23:39:05
Noisy switches, noisy pots (volume, balance etc) . . .

It seems like a shame to discard a piece of equipment that you like, when a good going over with Deoxit may have brought it back to life. I guess it depends on the severity of the scratchiness and noise.
I agree and I tried that approach. Several times in its life I dismantled the selector switches and pots and cleaned them. Sadly the results only lasted so long and eventually they were too far gone for redemption. Replacement switches for an amp that old would have been unlikely.
Title: Re: “Vintage” amps
Post by: Artie on 2018-04-10 15:36:19
I have an old Pioneer SX-434 with that same condition. Cute little receiver, but it's pots have given up the ghost.
Title: Re: “Vintage” amps
Post by: Arnold B. Krueger on 2018-04-10 15:51:14
I have an old Pioneer SX-434 with that same condition. Cute little receiver, but it's pots have given up the ghost.

Pots are potentially replaceable, especially if they are connected with point-to-point wiring.

I have found suitable replacements on eBay, at least as NOS

Selector Switches are tougher.

I just finished replacing the power switch on a Marantz 2230. It took some machine work and finagling to get a visibly correct replacement.
Title: Re: “Vintage” amps
Post by: Artie on 2018-04-10 16:34:05
Unfortunately, these are soldered right to the board. Of course, I could replace them and use p-to-p wiring. The hard part is that they're sandwiched between two boards, and it's difficult to find the 4-terminal volume pots that have the "Loudness" taps.
Title: Re: “Vintage” amps
Post by: riverlethe on 2018-04-11 16:07:03
Fortunately, this amp only has a power switch, A/B selectors and a meter scale switch that are rarely used. The power meters remind me of K.I.T.T. from Knight Rider.
Title: Re: “Vintage” amps
Post by: Artie on 2018-04-12 00:56:42
It's funny. It didn't "click" in my head about what you had until you mentioned those LED front panel meters.  :))

I checked my "shed", and I have the KM-992, which has virtually identical specs, and almost the same cosmetics. The KM-207 was built from 88 - 89, and my KM-992, from 91 - 92. I'm sure they're essentially the same amp. They're both 150 Wrms/ch at .03% THD. Amazing frequency response: 5 hz - 200 khz, +0db -3db.

Mine sounds great. Yours, (should you buy it), should also. One word of caution: the A/B speaker switch connects the speakers in series. Almost all of the KM series of Kenwood amps did that. I'd stick to one pair of speakers and try to avoid "disco" SPL's.

Enjoy.
Artie
Title: Re: “Vintage” amps
Post by: riverlethe on 2018-04-15 14:41:43
I ended up returning this amp to the vinyl shop where I found it. It was shutting itself off during the Ride of the Rohirrim driving my SVS Prime towers.
Title: Re: “Vintage” amps
Post by: Arnold B. Krueger on 2018-04-17 12:43:16
I ended up returning this amp to the vinyl shop where I found it. It was shutting itself off during the Ride of the Rohirrim driving my SVS Prime towers.

Probably cut out on when a thermal sensor tripped. This is one reason to have a powered subwoofer.
Title: Re: “Vintage” amps
Post by: riverlethe on 2018-04-19 00:41:01
I ended up returning this amp to the vinyl shop where I found it. It was shutting itself off during the Ride of the Rohirrim driving my SVS Prime towers.

Probably cut out on when a thermal sensor tripped. This is one reason to have a powered subwoofer.

I actually did have them crossed over at 40Hz, though Audyssey wanted to run them full range. It’s also attempting a +8dB boost for a null at 175Hz, so that might have something to do with it.

Did they use anything like CPU thermal paste on those heat sinks? Could it have deteriorated?

Edit: Isn’t most of the sub-bass content sent to the LFE channel in films anyway?
SimplePortal 1.0.0 RC1 © 2008-2018