Hydrogenaudio Forums

Digital Audio/Video => Movie/Multichannel audio => Topic started by: hkphooey on 2017-09-06 18:44:17

Title: iOS not correctly mapping multichannel audio files unless "no channel layout"
Post by: hkphooey on 2017-09-06 18:44:17
iOS not correctly mapping multichannel audio files unless "no channel layout", for example:
=============================================================
Does map correctly:
=============================================================
afinfo "6_Channel_ID_10sec_NoLayout.wav"
File:           6_Channel_ID_10sec_NoLayout.wav
File type ID:   WAVE
Num Tracks:     1
----
Data format:     6 ch,  44100 Hz, 'lpcm' (0x0000000C) 16-bit little-endian signed integer
                no channel layout.
=============================================================
Does NOT map correctly:
=============================================================
afinfo "6_Channel_ID_10sec.wav"
File:           6_Channel_ID_10sec.wav
File type ID:   WAVE
Num Tracks:     1
----
Data format:     6 ch,  44100 Hz, 'lpcm' (0x0000000C) 16-bit little-endian signed integer
Channel layout: 5.1 (L R C LFE Ls Rs)
=============================================================
When either of these input .wav files are encoded to AAC using afconvert, the output .m4a will always have channel layout assigned, and will not map correctly.
How to encode files to AAC (or modify the Packet Table Header?) to produce multichannel AAC files that will report "no channel layout" to afinfo, and therefore presumably map correctly?
Thanks!
SimplePortal 1.0.0 RC1 © 2008-2020