Hydrogenaudio Forums

Lossy Audio Compression => AAC => AAC - Tech => Topic started by: Incuriousity on 2015-11-16 19:25:21

Title: Some problem on qaac 2.55
Post by: Incuriousity on 2015-11-16 19:25:21
I encode some of my song to aac using latest qaac 2.55 and I copied it to android. But android won't recognize it bitrate. Android just put 0 in the kbps. But song that I encode using qaac doesn't have this problem. So is something wrong with qaac 2.55?
Title: Some problem on qaac 2.55
Post by: lvqcl on 2015-11-16 21:45:00
https://sites.google.com/site/qaacpage/news (https://sites.google.com/site/qaacpage/news)
Quote
[qaac] release 2.51
posted Jun 28, 2015, 6:44 AM by nu 774

Always write zero into avgBitrate field in esds decConfigDescriptor to be spec compliant. Was writing actual average bitrate before (this was automatically done by libmp4v2). The spec says that in case of VBR, is should be zero.
Title: Some problem on qaac 2.55
Post by: Fairy on 2015-11-17 10:31:04
Is there a switch to turn it back on? I think there are people who like to see the actual bitrate...
Title: Some problem on qaac 2.55
Post by: Incuriousity on 2015-11-17 12:14:14
Is there a switch to turn it back on? I think there are people who like to see the actual bitrate...

Use old version of qaac. I use qaac 2.49 to see the actual bitrate
Title: Some problem on qaac 2.55
Post by: nu774 on 2015-11-17 15:03:33
Is there a switch to turn it back on? I think there are people who like to see the actual bitrate...

By creating non-compliant files? Why qaac has to take care of non-compliant softwares, instead of fixing them?
Since the spec clearly says that the avgBitrate field shall be zero in case of VBR stream, a player that shows the bitrate of the file is responsible to take care of it. And actually, the average bitrate can easily be computed from stream size and duration (elementary school level arithmetic).

As far as I can see, softwares such as fb2k, winamp, quicktime player, and poweramp correctly show bitrate of the files encoded by qaac 2.51 or later.
SimplePortal 1.0.0 RC1 © 2008-2019