Hydrogenaudio Forums

Hosted Forums => foobar2000 => Support - (fb2k) => Topic started by: eahm on 2014-01-18 23:36:11

Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-18 23:36:11
Not every encoder gives me this, FLAC, TAK, WMA lsl for example, ALAC and WavPack convert fine. The first three convert few songs then they go back to 0.00x then few other songs then 0.00x again. I've tried dBpoweramp and EZ CD Extractor and they are quick and never slow down with the same number or processes (8).

I use Case's flac.exe build, I've tested RareWare's flac.exe ICL 13.0 and that goes back to 0.00x even quicker than Case's.

I saw this issue before but never know if they solved it. Just wanted to know if anyone else has problems.

edit:
The processor is an i7-2700k.

edit2:
Title: not ripping but converting. Sorry, can a mod please change the title to "foobar2000 converting speed 0.00x"?
Title: foobar2000 conversion speed 0.00x
Post by: marc2003 on 2014-01-18 23:55:13
nvm, just seen your edit2. damn misleading thread title.... 
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-19 00:11:00
Stupid test I just ran, converting straight to the primary drive (SSD) and it doesn't slow down, almost every FLAC/TAK goes stable around 800x and WMA lsl ~450x. It seems the data drive (secondary) isn't fast enough for the converter which seems crazy since it's one of the latest Seagate. Done, replacing both data and backup drives ASAP.

Is there a way to tell foobar2000 to optimize the encoder based on the speed of the drive? It seems EZ CD Extractor never passes around 470-500x converting FLAC. foobar2000 always tries the top speed then it has to slow down because it's too fast.
Title: foobar2000 conversion speed 0.00x
Post by: marc2003 on 2014-01-19 00:34:15
i have no idea what you mean by optimise the encoder? all it's doing is spawning command line encoders and waiting for them to finish. i suppose you could request that it intelligently handles the number of processes it spawns but you can already do this manually. file>preferences>advanced>tools>converter>thread count. maybe 4 or 6 would work better?
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-19 01:18:17
Even with one thread it goes down to 0.00x, after around 15 files. That's what's strange about it.
Title: foobar2000 conversion speed 0.00x
Post by: marc2003 on 2014-01-19 02:32:03
well if a single thread conks out then something is very wrong. you haven't tinkered with any of the other settings in the advanced preferences? perhaps you could setup a new portable foobar install to test with as that will have everything reset to default.

i'm running a dual core myself and have had a quad core in the past and they've always ran at full speed, even when converting hundreds of tracks. i don't have a SSD either.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-19 02:38:19
I am always trying with a portable version. The only file I have saved is foo_converter.dll.cfg and the encoder folder (for the version I am trying not the one I use personally).

I will test right now with a new portable copy, no foo_converter.dll.cfg and new flac.exe.

edit:
It went down to 0.00x after 32 files, it stays there for few seconds then stars again.

flac.exe from Case after 32 files.
flax.exe 64-bit from RareWares after 48 files. After it restarted it only converted 10.

Converting to the external drive it barely creates 10 files before it stops.

I've never noticed this before because I use ALAC. Testing an older version of FLAC, 1.2.1b.

Update: 1.2.1b did like 20 files before it stopped.

Downloading TAudioConverter since I can test it with the same flac.exe (or takc.exe).

Update: same issue, TAC stopped after around 20 files.

OS is 8.1 64-bit.

Even ALAC is doing it, this is not a foobar2000 nor an encoder issue. This is the OS or the Hard Drive.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-19 04:24:38
Just tested ~200 files on a server with 16 threads. It did slow down a little every tot number of files, it went to ~250-300x then back up right away.

It goes down, now I have to see why it stops, I don't remember it did in the past. I've converted 30000 files few months ago (from FLAC to ALAC) but I don't remember if I had 7 or 8, few things have changed even on my system lately. 8.1 was a fresh install not an upgrade.

The system SSD drive is this one http://www.corsair.com/force-series-3-90gb...hard-drive.html (http://www.corsair.com/force-series-3-90gb-sata-3-6gbps-solid-state-hard-drive.html) and the data drive is this: http://www.newegg.com/Product/Product.aspx...N82E16822148834 (http://www.newegg.com/Product/Product.aspx?Item=N82E16822148834)
Title: foobar2000 conversion speed 0.00x
Post by: washu on 2014-01-19 16:21:21
Things to check/try

- What kind of controller do you have the data drive connected to?  What mode is it in (IDE/AHCI/RAID)?

- Check the drive in device manager and make sure that it is in better performance mode and not quick removal mode.  Make sure write caching is turned on. 

- If you have any third party anti-virus or "security" software installed, UNINSTALL it.  Disabling is not good enough.

- Use the disk tab in resource monitor to see if anything besides the encoder and foobar are accessing the files.  Also check if the response time for the files is high.

- Check the drive with the Seagate testing tool (seatools).


It's not related to your issue, but your SSD is not a good one.  While it is not as bad as an OCZ, it is still near the top of crappy sandforce SSDs.  Make sure you take frequent backups.



Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-19 17:09:23
washu, thank you, I'll go try these settings right now.

I am just mad that Fry's Electronics managed to sell me something I didn't want: Seagate. I've always bought WD and always had a weird feeling about this one, hearing clicking since the first day and Seagate said they can do that, I hate it.
For the SSD I don't really care, it was just a test, my first SSD. It's fast and everything and the next time I'll get a better one, Samsung and Intel right?

I don't have any antivirus (Windows Defender service is disabled as well), never had one installed in my life and the OS is clean, processes are ok. Nothing or almost nothing is installed, I only use portable apps, I make them that way if they don't originally come portable.

The backup is ok as well, the SSD don't have any data or any data that needs to be backed up, not even on %appdata% since I don't use any installed software. Everything is on D (Seagate) and everything is being copied on a WD backup drive every time the "important" folders are modified.

I own two IT companies, one is just iOS development but the other one is support for companies and IT management. While I don't care or know much anymore about hardware (reason why they sold me these two piece of s**t parts), I mostly do networking, management and backup. My data is ultra safe, the PC can burn down today for what I care.

edit:
Writing cache is enable on both drives. Isn't Better Performance/Quick Removal just for USB drives?
Title: foobar2000 conversion speed 0.00x
Post by: washu on 2014-01-19 17:35:31
Many drives auto-park their heads now for power reasons, so clicking alone is not a sign of a failing drive.  Clicking plus performance problems certainly can be a bad sign.

The response time in Resource monitor is going to be what you should watch.  If it goes high on your files then you know Windows is waiting on something in the I/O system.  Most likely the drive, but it could be the controller, cable or even the driver.

Better performance/Quick Removal can appear on internal drives in some cases.  On some systems you can configure internal SATA ports as eSATA. 

For consumer SSDs I go Samsung > Good Marvell (ex, Crucial M series) > Intel > everyone else > OCZ.  Intel's current consumer SSDs use Sandforce controllers.  They are by far the best Sandforce drives on the market, but they are still Sandforce.  I lost a lot of respect for Intel when they did that.
Title: foobar2000 conversion speed 0.00x
Post by: ChronoSphere on 2014-01-19 17:50:29
I don't have any antivirus, never had one installed in my life and the OS is clean, processes are ok.
If you don't install any antivirus on win8.1, you will have windows defender running. Windows defender on win8.x is actually Microsoft Security Essentials. I don't remember it slowing down local processes that much, but the reason I ditched it was exactly because it was starting to slow down my file access noticeably.

Try converting with task manager open, sorted by CPU/descending. And see if .. mseng.exe, i think it was called, starts eating your CPU suddenly. Or just disable the windows defender service in the services.

edit: just an example of how experiences differ: I'm totally mad at WD for failing me twice. And my current one is a WD BLack which is noticeably slower than any Seagate/Hitachi I previously owned. And they are all in good health even now
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-19 18:07:22
ChronoSphere, thanks for reminding about Defender, I forgot to say it's one of the first services I disable, post updated.

Didn't WD buy Hitachi (HD division)? I've never liked Seagate but I wanted to give it a try since they make such good drives for servers. Anyway, it's all about experience and brands don't mean much, I guess I have a brand placebo for WD

Just to show you I clean I keep my stuff:

Programs: http://i.imgur.com/0CANFIx.png (http://i.imgur.com/0CANFIx.png) (Logitech and Adobe Reader are even a plus I am testing now for a customer)

Desktop: http://i.imgur.com/RoTCwU3.png (http://i.imgur.com/RoTCwU3.png)

edit:
washu, I'd rather have a green "fast enough" drive than an always on super fast one. Which one would you suggest I get next? it must be 3-4TB. Thanks.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-19 21:43:56
Programs cleaned, updated: http://i.imgur.com/IIE4A9m.png (http://i.imgur.com/IIE4A9m.png) (it doesn't really matter but you know...OCD?)

Testing how many files I have to add for the buffer to add up and lock slow down the converter.

We got ahead with other discussions and I forgot to remind that only converting straight with flac.exe, takc.exe etc. it slows down to 0.00x

EZ CD Extractor does full speed and never locks. I will test dBpoweramp again ASAP.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-20 02:55:26
Just an update on the software selection since I ran few more tests, EZ CD Extractor and dBpoweramp slow down to 0x as well.

Let me say it again, this is not a foobar2000 problem, it's a hard drive issue ...99%, 1% the OS.
Title: foobar2000 conversion speed 0.00x
Post by: ChronoSphere on 2014-01-20 11:47:40
Have you tried running Seatools (http://www.seagate.com/support/downloads/seatools/) (DOS version) and do an extensive test? It sounds like a defective drive.
Title: foobar2000 conversion speed 0.00x
Post by: 2tec on 2014-01-20 13:32:15
I'd rather have a green "fast enough" drive than an always on super fast one. Which one would you suggest I get next? it must be 3-4TB. Thanks.

For reliability, perhaps WD RE (enterprise) drives (http://www.wdc.com/en/products/products.aspx?id=580)?
Title: foobar2000 conversion speed 0.00x
Post by: nu774 on 2014-01-20 14:22:24
I can reproduce your "issue" if I turn off the write cache on my external HDD drive (connected via USB 2.0).
In my drive, when write cache is disabled (and it seems to be disabled by default on USB external drives), closing large files takes considerably long time (seems  waiting/blocking until cached data is completely flushed to the drive).
If this is the case, you can change the cache policy from the drive property.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-20 16:04:32
Have you tried running Seatools (http://www.seagate.com/support/downloads/seatools/) (DOS version) and do an extensive test? It sounds like a defective drive.
Too much time, the Windows version of the software said the drive is perfectly fine. I think the PC is "too fast" for this drive.

I'd rather have a green "fast enough" drive than an always on super fast one. Which one would you suggest I get next? it must be 3-4TB. Thanks.
For reliability, perhaps WD RE (enterprise) drives (http://www.wdc.com/en/products/products.aspx?id=580)?
Too much for my personal use, I sold few WD VelociRaptors to a few customers and they are amazing but again, too much for a my personal desktop. I'd rather get more backup drives.

I can reproduce your "issue" if I turn off the write cache on my external HDD drive (connected via USB 2.0).
In my drive, when write cache is disabled (and it seems to be disabled by default on USB external drives), closing large files takes considerably long time (seems  waiting/blocking until cached data is completely flushed to the drive).
If this is the case, you can change the cache policy from the drive property.
The writing cache is already enabled, I don't see any other option. I will test a WD Green, let's see if one of them is fast enough since it's one of the best quality/reliability/price.
Title: foobar2000 conversion speed 0.00x
Post by: marc2003 on 2014-01-20 16:43:02
I think the PC is "too fast" for this drive.


you really think you're that special? what drivel. the job won't stop. it will just run as fast as your drive can manage. i even tested encoding an album to my crappy old USB stick which barely supports write speeds of 5MB/s. the job ran at 38x realtime according to the foobar console.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-20 16:59:21
you really think you're that special? what drivel. the job won't stop. it will just run as fast as your drive can manage. i even tested encoding an album to my crappy old USB stick which barely supports write speeds of 5MB/s. the job ran at 38x realtime according to the foobar console.

Thanks for testing.
Title: foobar2000 conversion speed 0.00x
Post by: EpicForever on 2014-01-20 19:12:51
I haven't read whole topic.
My experience: when conversion with foobar slows down with any drive it means it is dying or at least it works under controller with shitty driver/BIOS. That was the case on my older mobo, where Silicon Image have problems with one version of BIOS or driver for it's SiI3512 controller and that was the case when I run SATA drive under ITA8712F PATA controller through SATA->PATA adaptor. This SATA->PATA adaptor was really shitty.
Other time it was very shitty 32GB USB 3.0 flash drive which was quite quick when writing single file on it, but had serious problems with parallel access to files which was always causing lags in explorer, foobar and sometimes even in firefox. Biggest problem always occurred when 3 conversion temp files needed to be renamed. Then there was 3 mins lasting lag. Flash drive was inaccessible, explorer wasn't responding, conversion speed was 0.00x. After less than a half year this flash has died. I just written some data on it, removed from PC and put into laptop and... nothing happened. Flash was dead already.
So my advice is to check what is going on with the drive that is destination for converted files. There is nothing like "too fast computer for hard drive".
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-20 19:31:04
I haven't read whole topic.
My experience: when conversion with foobar slows down with any drive it means it is dying or at least it works under controller with shitty driver/BIOS. That was the case on my older mobo, where Silicon Image have problems with one version of BIOS or driver for it's SiI3512 controller and that was the case when I run SATA drive under ITA8712F PATA controller through SATA->PATA adaptor. This SATA->PATA adaptor was really shitty.
Other time it was very shitty 32GB USB 3.0 flash drive which was quite quick when writing single file on it, but had serious problems with parallel access to files which was always causing lags in explorer, foobar and sometimes even in firefox. Biggest problem always occurred when 3 conversion temp files needed to be renamed. Then there was 3 mins lasting lag. Flash drive was inaccessible, explorer wasn't responding, conversion speed was 0.00x. After less than a half year this flash has died. I just written some data on it, removed from PC and put into laptop and... nothing happened. Flash was dead already.
So my advice is to check what is going on with the drive that is destination for converted files. There is nothing like "too fast computer for hard drive".

Agree, even washu asked about the controller but I don't remember really, I have to double check in the bios. The mobo is a ASUS P8H77-M PRO, nothing crazy.  With "too fast" I was referring to the caching or buffering of the drive, since English is my 3rd language it was the easiest way to express it
Title: foobar2000 conversion speed 0.00x
Post by: washu on 2014-01-20 19:43:05
Agree, even washu asked about the controller but I don't remember really, I have to double check in the bios. The mobo is a ASUS P8H77-M PRO, nothing crazy.  With "too fast" I was referring to the caching or buffering of the drive, since English is my 3rd language it was the easiest way to express it


That MB only has an extra controller for the eSATA ports and I am going to assume you are not using them in this case.  Besides, as far as cheap extra controllers go the Marvell one isn't that bad.

What mode do you have the Intel controller in?  It should be in AHCI mode.  It's on page 3-18 of the online english manual.  However, if it is not in AHCI, don't change it as your system may no longer boot. 

If it is in RAID mode, check the drive configuration using the Intel Rapid Storage Technology program.  You could have the drive in RAID mode with the caching turned off, which is separate from the setting in device manager.

If all that checks out the drive is probably just dying.  That particular model is quite fast for a consumer drive when working properly, much faster than a WD Green.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-20 19:55:32
That MB only has an extra controller for the eSATA ports and I am going to assume you are not using them in this case.  Besides, as far as cheap extra controllers go the Marvell one isn't that bad.
USB 3 for the external WD Green as backup only.

Quote
What mode do you have the Intel controller in?  It should be in AHCI mode.  It's on page 3-18 of the online english manual.  However, if it is not in AHCI, don't change it as your system may no longer boot.
It is probably in AHCI and yes, I am aware I can't change it

edit:
I cannot believe this, SATA mode is IDE in the BIOS. I guess I have to change it to AHCI, reload, and do more test.

Quote
If it is in RAID mode, check the drive configuration using the Intel Rapid Storage Technology program.  You could have the drive in RAID mode with the caching turned off, which is separate from the setting in device manager.
I'll check this.
Again, it's in IDE mode.

Quote
If all that checks out the drive is probably just dying.  That particular model is quite fast for a consumer drive when working properly, much faster than a WD Green.
Good to know, I'll check better before getting a new one. I've never had any issue with the WD Green that's why I particularly like them, the last one I had though was on a much older still quad core processor.
Title: foobar2000 conversion speed 0.00x
Post by: Brazil2 on 2014-01-20 20:05:44
WD Green

http://www.ngohq.com/news/19805-critical-d...green-hdds.html (http://www.ngohq.com/news/19805-critical-design-flaw-found-in-wd-caviar-green-hdds.html)
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-20 20:23:47
Ok, it's AHCI now and write chaching is enabled.
Let's do some more testing.

update:
Same problem, I wasn't really expecting any speed improvement.

http://www.ngohq.com/news/19805-critical-d...green-hdds.html (http://www.ngohq.com/news/19805-critical-design-flaw-found-in-wd-caviar-green-hdds.html)

Thanks for the link, very useful!
Title: foobar2000 conversion speed 0.00x
Post by: JamesHunt on 2014-01-20 20:48:24
@eahm

I'm having the same problem with my new Intel build. Issues appear with WD Green 20EARX drive. I used WDIDLE tool soon after flawn was found in certain WD hard drives.

I have checked all the things mentioned in this thread, SMART, if caching is on, what's the mode (ACHI) etc, but so far I haven't been able to track down what exactly is the problem.

I'm using Windows 7 Pro and I'm starting to wonder if issue is somehow related to bug that caused disk write speeds to drop dramatically in Windows Vista and in certain cases Windows 7.

It's a long shot really, but I don't have much options left to consider.

My motherboard is Asus H87-Pro (rev 2).
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-20 21:01:29
JamesHunt, it's a pain, I don't even convert much but you know, I want to make my money worth when I buy something. I am sure one day I'll change my system and I'll go back to FLAC and converting 30000 files like this...I can't even watch, I guess I'll do it overnight
I don't even want to spend more than the basic reliable enough drive since I don't use the PC much more than a storage machine.

If it can help you in any way, I just swapped the SATA Barracuda with the SATA WD Green (that I use for backup) and it slows down even earlier, ~10-15 files (the Barracuda ~20-50). I really think the processor is too fast for these basic drives, we should try with a WD RE or a Raptor etc.
Title: foobar2000 conversion speed 0.00x
Post by: washu on 2014-01-21 00:16:09
If it can help you in any way, I just swapped the SATA Barracuda with the SATA WD Green (that I use for backup) and it slows down even earlier, ~10-15 files (the Barracuda ~20-50). I really think the processor is too fast for these basic drives, we should try with a WD RE or a Raptor etc.

Sorry, but there is something seriously wrong with your computer. 

I just tried converting over 150 files to FLAC on an ST3000DM001 (the 3TB version of your drive) and it never dropped down close to 0.00x.  I also tried a 3TB WD Green which is on a crappy ASMedia controller with the same result.  My PC is faster than yours, the idea that the drive is too slow for a processor is just crazy.  A raptor or RE drive is not significantly faster and in many cases would be slower.  Your Seagate drive is equal in transfer rate to the best raptors which is what would matter when doing a single thread conversion, which you mentioned is a problem.  Even when I did an 8 thread conversion the drives did slow down, but not anywhere close to 0.00x. 

Did you use different SATA cables when you swapped drives?  Tried different SATA ports?
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-21 01:32:02
I'll try a different cable and a different port tonight.

washu, what processor do you have?

update:
Changed cable and port from SATA 3Gbps to SATA 6Gbps and it doesn't seem to slow down (no shit?), at least never to 0, it goes down a little. For some reason it was plugged in with the other port, probably because I've replaced the WD Green and forgot to change the cable and port.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-21 02:37:23
I've managed to slow it down to 0 with EZ CD Extractor, it was actually frozen for longer than before right now. Didn't slow down yet with foobar2000, the one I use anyway.
Title: foobar2000 conversion speed 0.00x
Post by: washu on 2014-01-21 14:03:32
You may have a cable issue.  Try using the good 6Gbps cable in a 3Gbps port.

Just a shot in the dark, but what power supply do you have?

I'm running an i7-4770K @ 4.6 GHz.  Except for the few who can clock it even higher, it's pretty much the fastest single thread conversion speed you can get. 

Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-21 14:20:57
The cable I'm using now is brand new from the ASUS box, 6Gbps cable. What benefit would I have plugging a 6Gbps drive in a 3Gbps port, buffering, caching?

I'll try later anyway.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-21 15:22:57
it's pretty much the fastest single thread conversion speed you can get.

The fastest? It's the #30 in this list: http://www.cpubenchmark.net/cpu_list.php (http://www.cpubenchmark.net/cpu_list.php)
Title: foobar2000 conversion speed 0.00x
Post by: washu on 2014-01-21 16:28:47
The fastest? It's the #30 in this list: http://www.cpubenchmark.net/cpu_list.php (http://www.cpubenchmark.net/cpu_list.php)

Notice I said "single thread".  Passmark uses all cores.  The top CPU on the list (Xeon E5-2697) has twelve cores, of course it will easily beat a 4 core CPU in a multi-threaded test.  However, it is only 2.7 GHz and a generation behind.  Per core it only gets a passmark score of 1594.  A 4770K gets a per core speed of 2582 and that is at stock speeds which mine is not.

I specifically tested a single thread to duplicate what you claimed to have done and eliminate disk seeking as a possible bottleneck.  A 4770K running a single thread will write data to the drive faster than your 2700K doing the same unless you have a crazy high overclock, which is ruled out by your motherboard.  That shows that the drive itself is not "too slow" as you had claimed as I never dropped even close to 0.00x.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-21 17:22:43
Perfect, good explanation. I used to know a lot about hardware and stay behind companies that make new products but I got lost while ago and didn't care nor need to update.

Thanks for your time, your time testing and your knowledge.

Still need to finish my first job then I'll get back and test that cable.
Title: foobar2000 conversion speed 0.00x
Post by: ChronoSphere on 2014-01-21 22:13:14
Have you tried running Seatools (http://www.seagate.com/support/downloads/seatools/) (DOS version) and do an extensive test? It sounds like a defective drive.

Too much time, the Windows version of the software said the drive is perfectly fine. I think the PC is "too fast" for this drive.
Hence why I suggested to run the DOS one. Last time I tested it, the functionality wasn't identical. Also, short test won't do, it won't catch your slowdown issue because it happens after some time, not immediately. It's up to you though.
Title: foobar2000 conversion speed 0.00x
Post by: EpicForever on 2014-01-22 18:55:56
Guys. I have 2x WD Greens on AMD 990FX with AMD PhII 1100T. With foobar I only use one of them. In the past I used the other one, results were mostly the same. Currently I can run 6 threads of wav-> flac conversion without problems - WD30EZRX is source of WAVs and destination of FLACs. That is 13 access operation at the same time (including playback in the background). Speed is like 120 - 180x with occasional drops to 50 (for less than 5 sec.).  But occasionally playback and animations (musical spectrum and peak/VU meter) start stuttering. And after some time (half a minute or sometimes nearly 1 minute) it goes away. When I try to make bigger load on this HDD (copying large amounts of files in explorer) I also sometimes have problems with playback (stuttering). My conclusion (done in other thread on this forum) is that WD Green drives are just relatively slow storage drives. Economic, ideal for just storing large amounts of data, but they aren't best performing drives. My drives had always quickly disabled Idle 3 mode (yes - disabled, not postponed to 5 mins) so it doesn't have impact on the drives in my case. Bear with it - WD Greens are worth their price. Never try to install any OS on them.
But anyway - in your case eahm I will suspect that some setting in BIOS is still wrong... Or it is just the problem with hardware - more likely chipset (like specific incompatibility) but maybe with HDD.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-22 19:16:08
I've tried the 6Gbps cable in the 3Gbps port and of course it's worse. It's working well right now but I still don't like it and since I've had a bad feeling from the first day I bought this drive I just ordered an ST3000DM001.

I'll update when I configure the new one, I will use this one as a second USB backup.
Title: foobar2000 conversion speed 0.00x
Post by: eahm on 2014-01-23 19:02:29
Just got the drive, it's copying the data right now. Newegg is insane, delivered the next day with free 4-5 business days shipping.
Title: foobar2000 conversion speed 0.00x
Post by: stevray80 on 2014-01-24 12:09:55
Things to check/try

- What kind of controller do you have the data drive connected to?  What mode is it in (IDE/AHCI/RAID)?

- Check the drive in device manager and make sure that it is in better performance mode and not quick removal mode.  Make sure write caching is turned on. 

- If you have any third party anti-virus or "security" software installed, UNINSTALL it.  Disabling is not good enough.

- Use the disk tab in resource monitor to see if anything besides the encoder and foobar are accessing the files.  Also check if the response time for the files is high.

- Check the drive with the Seagate testing tool (seatools).


It's not related to your issue, but your SSD is not a good one.  While it is not as bad as an OCZ, it is still near the top of crappy sandforce SSDs.  Make sure you take frequent backups.


SF crappy?? SandForce controllers embedded within any SSD really work flawlessly. Only thing i guess you will need to take care is to keep the controller firmware up to date & also SSD manufacturer firmware up to date as well. If this is taken care of, then trust me SandForce based controllers perform really well & can be really fast. i own one Samsung, and SF based -  Intel,OCZ, and V300.... haven't found any issues with other than that, OCZ needs to be updated the firmware.
Title: foobar2000 conversion speed 0.00x
Post by: 2tec on 2014-01-24 15:06:11
SF crappy?? SandForce controllers embedded within any SSD really work flawlessly.

As a byproduct, data that cannot readily be compressed (for example random data, encrypted files or partitions, compressed files, or many common audio and video file formats) is slower to write. ~ http://en.wikipedia.org/wiki/SandForce#Technology (http://en.wikipedia.org/wiki/SandForce#Technology)

In 2012, SandForce SF-2000-based drives were discovered to only include AES-128 encryption instead of the advertised AES-256 encryption. It was speculated the lower grade encryption was used to qualify for US ITAR licences which are precluded for products featuring certain levels of encryption heading for a selected list of US-ambivalent or actively unfriendly countries. ~ http://en.wikipedia.org/wiki/SandForce#Issues (http://en.wikipedia.org/wiki/SandForce#Issues)

It never hurts to investigate just a little ....
SimplePortal 1.0.0 RC1 © 2008-2020