Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: [bug report] Fb2k, Unable to open item for playback (Tag not found): (Read 624 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[bug report] Fb2k, Unable to open item for playback (Tag not found):

I just noticed today when I went to play some Sega Genesis music files .vgm and .gym
for the following games:
as edited tagged game names
  • Shining in the Darkness
  • Shining Force 1:  The Legacy of Great Intention
  • Shining Force 2:  Ancient Sealing
I am testing using Foobar2000_v1.6.8_beta 03
will downgrade to beta 02 if I can...

I get the following error..
sample provided..
Quote
Unable to open item for playback (Tag not found):
"C:\JoeMusic\mSegaGenesisGYM\Shining in the Darkness\01 - Welcome to Storm.vgm"

Files attached,
 list of files with error messages..
and sample of music files... if permitted if not will remove..

Peter can you fix it? or is it now an component issue too in that case Kode54....  foo_gep
please and thx.

ps:
if you have any more questions please ask.

EDIT1:
 I just noticed I could not edit those files tags..
if i changed anything for .vgm or .gym for those games...
it would not apply.. and the [apply] button and [ok] button were not working..

EDIT2:
foobar2000_v1.6.8_beta 02 = same issue, tag not found...
will try beta 01 next

EDIT3:
ok even beta 01 of v1.6.8 didn't work..
but downgrading back to v1.6.7 from a RAR backup worked..

tag edited .vgm .gym files are playing again...

Re: [bug report] Fb2k, Unable to open item for playback (Tag not found):

Reply #1
VGM support is somewhat broken in foo_gep. Please disable the vgm extension and use foo_input_vgm instead.

 

Re: [bug report] Fb2k, Unable to open item for playback (Tag not found):

Reply #2
VGM support is somewhat broken in foo_gep. Please disable the vgm extension and use foo_input_vgm instead.
I tried  foo_input_vgm but it seems way more complicated to setup and config so I disabled it for now...

is there anyway you can fix foo_gep?

Re: [bug report] Fb2k, Unable to open item for playback (Tag not found):

Reply #3
@Peter  any chance you can fix it? foo_gep's .vgm and .gym has worked for me for decades or so since I first discovered
Foobar2000...

thx @kode54 but setting up the settings for foo_vgm is a bit too complicated... sry..

Re: [bug report] Fb2k, Unable to open item for playback (Tag not found):

Reply #4
Confirmed, thanks for reporting.

Cause was that updated APE tag reader would refuse to read APE tag blobs with nothing before the tag, after working around another issue. Fixed for beta 6.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: [bug report] Fb2k, Unable to open item for playback (Tag not found):

Reply #5
Confirmed, thanks for reporting.

Cause was that updated APE tag reader would refuse to read APE tag blobs with nothing before the tag, after working around another issue. Fixed for beta 6.
wow Peter your great! ty so much for a fix!