Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Weird metadata editing issue (Read 180 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Weird metadata editing issue

foobar2000 v1.6.7
Win 10 Pro 64bit (v21H1; OS Build 19043.1165)

Hey there,

Brief issue description: fb2k won't allow metadata editing in certain audio files, displaying a message "One file could not be updated: Unsupported format or corrupted file". This issue seems specific to fb2k (other audio software is fine).

Audio source files: 3x digital album releases purchased from boomkat.com (all wav 24bit).

In particular:
Track #9 in a specific release (artist SND; album "travelog") would not show any metadata in fb2k and as such appeared unsorted. I tried amending the metadata, but upon hitting apply, fb2k was stating "One file could not be updated: Unsupported format or corrupted file" and wouldn't allow any changes.

Other than that, the track plays back normally in fb2k, like the rest of the release. All other tracks in the release would allow for metadata editing. This issue is present in a few more files from the other digital releases.

It appears to be specific to fb2k because Reaper DAW (v6.36) succeeds in changing the problematic file's metadata; after doing so, the metadata can be edited from fb2k as well.

Having contacted Boomkat's support team, they confirmed that they've tried on various other players ("Quicktime, VLC, Vox and Foobar"), and the issue is specific to fb2k.

I imagine the problematic files contain audio chunks that are unrecognised or formatted differently to what fb2k expects.

Hoping this helps

ST

Re: Weird metadata editing issue

Reply #1
Frequently occurring issue: Is it .wav, or is it an .aiff that someone has renamed to a .wav? VLC plays such files, fb2k does not.

Three ways to check:
* Play it in VLC, hit and click Ctrl-j
* Make a copy, rename it to .aiff at the end. Does fb2k like it?
* ffmpeg ... but then you probably would have known how to check already?

Also, you are typically much better off using a lossless codec like FLAC or WavPack; smaller files, more tag-friendly, and error robust. (With some odd wav formats, WavPack might preserve more metadata.)
High Voltage socket-nose-avatar

 
SimplePortal 1.0.0 RC1 © 2008-2021