Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_youtube (Read 310815 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foo_youtube

Reply #1425
meemosafaji, playback should not stop.A warning window should pop up(which can be disabled in the advanced settings)and switch to the next track while continuing to play.It is advisable to use the latest versions of ALL components involved in the process of playing videos from YouTube, and it is desirable to get an API key.
YouTube Music

Re: foo_youtube

Reply #1426
meemosafaji, playback should not stop.A warning window should pop up(which can be disabled in the advanced settings)and switch to the next track while continuing to play.It is advisable to use the latest versions of ALL components involved in the process of playing videos from YouTube, and it is desirable to get an API key.
i didnt say that my playback stops, just my game because the warning pops out the game but now that u said that i can turn off the warning on advanced settings i get it thx, i already had the newer version and api key
the cat in the stalls want to drink milk but hes stuck in the fence with two dogs with grande porte

Re: foo_youtube

Reply #1427
https://pastebin.com/H3kZWKAD

Been having some crashes, sometimes when adding a link and sometimes when fb2k starts playing after being some hours paused/stopped. Can someone help me figure out what might be causing this issue?

Re: foo_youtube

Reply #1428
Does it works on YouTube Music?

Re: foo_youtube

Reply #1429
Does it works on YouTube Music?
Do you read the documentation or the info of the things you ask for? It's like the third question which clearly indicates you don't read anything...

Quote
This component adds possibility to play Youtube, Vimeo and Dailymotion clips directly by their URL.

Other features: channels support (Youtube, Dailymotion), search on Youtube within the program, clip thumbnail as album art, clip subtitles as lyrics, multitrack album from the single clip, video playback.
More clear than that... foobar is a music player, and this is a plugin to play music from youtube. What's the doubt? XD

Re: foo_youtube

Reply #1430
When I use the Add Titles function (File > YouTube Source > Add titles...), I get 25 results per line instead of one. Is this something that can be changed in the settings?

Re: foo_youtube

Reply #1431
When selecting 'Add titles...', a window opens to type in the requested title. At the bottom of this window you find settings for the search such as 'Limit'. Click here and look for 'Limit' in the preferences window which is opening. Select 'Limit' in the preferences window and type in the number of titles you want to get listed.

Re: foo_youtube

Reply #1432
How managed LAV Filters can be configured?  According to this: "And there is no way to display settings UI for local filter. I.e. even when local filter is used, settings UI anyway comes from the filter registered in the system." managed LAV filters eventually pointless, because not configurable unless it is installed on the system too!? No video in "popup" just the 2 lines "LAV Splitter:" and "LAV Video:". And check for updates always says newer version 0.75.1 is available on the server. Please enlighten me.

Re: foo_youtube

Reply #1433
OK, managed LAV Filters use the default settings (no way to configure it). But why video is not playing is spite of in the "Found" column appears "yes"? Status:
Code: [Select]
youtube-dl (none)
libcurl (internal):
libcurl/7.68.0 Schannel zlib/1.2.11 brotli/1.0.7 nghttp2/1.40.0
VSFilter (none)
ffmpeg (LAV Filters):
lavf 58.76.100, lavc 58.134.100, lavu 56.70.100, lavr 4.0.0
madVR (system):
not found
LAV Filters (managed):
Splitter:
LAV Filters (managed): Video:
So, if a new "user" (like me) installs this promising component for the first time, and sets LAV Filters to managed, after download (an restart) get this state, that cannot play video. :( As expected, the same state with using external. So it seems nobody (want to) use this component with managed or external LAV Filters on this globe except me.

Re: foo_youtube

Reply #1434
This is how it looks on another (my) globe:
Code: [Select]
libcurl (internal):
libcurl/7.68.0 Schannel zlib/1.2.11 brotli/1.0.7 nghttp2/1.40.0
ffmpeg (LAV Filters):
lavf 58.76.100, lavc 58.134.100, lavu 56.70.100, lavr 4.0.0
LAV Filters (managed):
Splitter 0.75.1, Video 0.75.1
madVR (system):
0.92.17
youtube-dl (managed):
2021.6.6
VSFilter (none)
What happens if you right-click on LAV-Filters->Check for updates?

Re: foo_youtube

Reply #1435
This is how it looks on another (my) globe:
Thanks for the reply, please tell me, how can I reproduce that? Your foobar is v1.6.6 and foo_youtube is v3.7.2?
What happens if you right-click on LAV-Filters->Check for updates?
As I wrote, always says "Newer version 0.75.1 is available on the server Download it?"
AppData\Roaming\foobar2000\foo_youtube\managed\94974E25-6AA2-418D-927D-41093087A6D2\ contains the files as intended(?) (hashlist.sha1).
And in spite of the above and "Found: yes", in Status:
Code: [Select]
LAV Filters (managed): Splitter: *empty* and LAV Filters (managed): Video: *empty*
but in contradiction:
Code: [Select]
ffmpeg (LAV Filters): lavf 58.76.100, lavc 58.134.100, lavu 56.70.100, lavr 4.0.0
And all is the same if I try with External. Absolutely don't understand what might be the difference between our systems that results in this degenerate behavior on my side.

Re: foo_youtube

Reply #1436
Im am on fb1.6.7b16 portable and foo_youtube 3.7.2. I have the same files in the same managed folder as shown from your side.
I would try a clean portable install and see if it works there.
Sorry for not being too helpful...

Re: foo_youtube

Reply #1437
The culprit was Comodo IS.

Re: foo_youtube

Reply #1438
Went over 2000 songs and found some videos I could not play.

403 Broken songs
www.youtube.com/watch?v=bOHxtOLfvIo
www.youtube.com/watch?v=LYU-8IFcDPw
www.youtube.com/watch?v=xd14cBeAfU4
www.youtube.com/watch?v=EZjevnnkA20
www.youtube.com/watch?v=oj4pqS8AiLM
www.youtube.com/watch?v=Ec729nmajwc
www.youtube.com/watch?v=d-7qLfP1S_g
www.youtube.com/watch?v=XdT5OsOnUW8
www.youtube.com/watch?v=CS9OO0S5w2k

Inappropriate or offensive to some audiences
(On YouTube, you get a button I need to press "I understand and wish to proceed)
https://prnt.sc/1c8qaml
www.youtube.com/watch?v=rxujAPhxlo0
www.youtube.com/watch?v=ptzzU7jFQwo

Is there any setting I can do, to get these youtube to work?
Is there some setting/tweek I can do to fix this?

Re: foo_youtube

Reply #1439
Nice selection!
I can't play the three age restricted tracks (Kurran & The Wolfnotes, Disturbed, FFDP), but I can not play them as well directly in youtube, I get asked for an age veriication.
All other tracks play well.
fb1.6.7.b16, foo_youtube 3.7.2, youtube-dl 2021.6.6, Prefer youtube-dl over internal analyzer checked

Re: foo_youtube

Reply #1440
To get past the age restriction, you need to enable persistent cookie storage, and borrow the YouTube login cookie from your browser, more info here. As for the 403 error, the videos seem to play normally here. Try clearing your analysis cache and playing the videos again, I've found that doing that seems to fix the issue when it happens as of now.

Re: foo_youtube

Reply #1441
To get past the age restriction, you need to enable persistent cookie storage, and borrow the YouTube login cookie from your browser, more info here. As for the 403 error, the videos seem to play normally here. Try clearing your analysis cache and playing the videos again, I've found that doing that seems to fix the issue when it happens as of now.

*1* "YouTube login cookie"
Did that several months ago. But since I get the agree restriction even if I go to YouTube. Normally, is there a way for me to verify my YouTube account age, and that's the issue ?

*2* 403 error and "clearing your analysis cache"
Sure... if I only know how?

Re: foo_youtube

Reply #1442
*1* "YouTube login cookie"
Did that several months ago. But since I get the agree restriction even if I go to YouTube. Normally, is there a way for me to verify my YouTube account age, and that's the issue ?
While there's no way to verify your age in the component, you may need to perform the process again, I remember hearing somewhere that the YouTube cookie will sometimes expire after a while.
*2* 403 error and "clearing your analysis cache"
Sure... if I only know how?
Go to view>Youtube Source>Analysis Cache, right click and select wipe cache.

Re: foo_youtube

Reply #1443
Hello, does anyone know how to config to stream 256k aac?
I have subscribed to youtube premium and use persistent cookie storage but still shows only 128k aac and opus stream

Re: foo_youtube

Reply #1444
AAC or Opus can be selected here:
X
As far as I know, a YouTube Premium subscription does not affect the quality of content.Or does it affect?
YouTube Music

Re: foo_youtube

Reply #1445
Thanks for your reply,
Premium users have a higher quality stream to 256k aac https://support.google.com/youtubemusic/answer/9076559
when using web it shows like this
X
I tried change format settings but it does not even show in cache list.
I don't know if it's possible but hope this plugin get it worked.

AAC or Opus can be selected here:
[attach type=image]21031[/attach]
As far as I know, a YouTube Premium subscription does not affect the quality of content.Or does it affect?
AAC or Opus can be selected here:
[attach type=image]21031[/attach]
As far as I know, a YouTube Premium subscription does not affect the quality of content.Or does it affect?

Re: foo_youtube

Reply #1446
I also show no higher than 128 kbps.
Most likely, these are the features of the component YouTube Source. Providing credentials from YouTube Premium is a dubious occupation  8)
YouTube Music

Re: foo_youtube

Reply #1447
I am having major issues with adding tags to larger (>1000 tracks) playlists of youtube links, even with 'very clean' foobar config (fb 1.6.7, foo_yt 3.7.2 only, portable): Usually fb crashes without report, in rare occations when a report is generated, it points to foo_youtube and input_entry::g_open_for_info_write (see attached). Any suggestion on how to solve this issue?

Re: foo_youtube

Reply #1448
This plugin combined with an RSS subscription display feed would make an amazing combo. You could replace Youtube all together.
Just a suggestion for the coders out there.
Hhhmmmm Croissants.....

Re: foo_youtube

Reply #1449
The Youtube Source component has stopped working.The video slows down a lot and freezes.Does everyone have it, or just me?
YouTube Music