Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Upsampling Issue (Read 764 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Upsampling Issue

My Foobar 64bit setup:

▪️ Upsampling with PGGB-RT (speed, 192khz, optimal shaping, volume hijack: disabled)
⬇️
▪️ Using some DSP with 32bit VST plugins (plugins 2x internal oversampling ON/OFF doesn't matter) (even  VST DSP ON/OFF doesn't matter)
⬇️
▪️ Converting PCM to DSD using SACD DSD processor and ASIO+DSD foo Out at 100ms device buffer.

⚠️ The issue is Foobar dropping/skipping a large part of track at playback start. But when I click the track manually it playing without any issue.
Please help.

Re: Upsampling Issue

Reply #1
Do you have the same issue if you remove "Upsampling with PGGB-RT (speed, 192khz, optimal shaping, volume hijack: disabled)" from your playback chain?
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Re: Upsampling Issue

Reply #2
Do you have the same issue if you remove "Upsampling with PGGB-RT (speed, 192khz, optimal shaping, volume hijack: disabled)" from your playback chain?

Nope. VST DSP+ SACD DSD working fine when there is no PGGB.

Re: Upsampling Issue

Reply #3
Is there any improvement if you increase the output device buffer to 1000ms or 2000ms?
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Re: Upsampling Issue

Reply #4
Is there any improvement if you increase the output device buffer to 1000ms or 2000ms?

Working (manual click every individual track) device buffer for the audio chain: 100ms to 200ms

More than 200ms leads to glitch playback.

Re: Upsampling Issue

Reply #5
If you have Preferences > Playback > Output > 'Enable smooth seeking...' on, try switching off. I've had skipping issues playing DSD with that on (maybe not related)

Re: Upsampling Issue

Reply #6
If you have Preferences > Playback > Output > 'Enable smooth seeking...' on, try switching off. I've had skipping issues playing DSD with that on (maybe not related)

It was switched off from the beginning.

 

Re: Upsampling Issue

Reply #7
The point of PGGB-RT is to upsample to your DAC native resolution and ensure best possible theoretical quality. Your upsampling makes DSPs require more CPU power to do their processing. And then you waste all the previous hard work by converting the PCM to DSD. I don't see what the idea here is.

Anyway, I know the SACD decoder component contains weird hacks and doesn't exactly do what components are expected to do. The author likes to interfere with internal operations of foobar core and detect undocumented conditions to change operation parameters. As a result things break. I can't seem to find sources for the DSD processor or the ASIO+DSD output so I can't check if they do the same. But based on what you describe happening, it very much sounds like they do. Otherwise you should not lose parts of the sound coming from input.