Skip to main content

Topic: Huge Delays when changing equalizer settings (Read 274 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • dekatch
  • [*]
Huge Delays when changing equalizer settings
Hi

ran into trouble the other day. tried to fix issues by even re-installing windows 10 x64 pro latest release.

but the problem still persist.

i got various equalizer settings. starting from -10 db on all levels, trhough +10db on all levels and various settings in between. for a few weeks now i discovered, that changes to my equalizer settings are not recognized immediately by either windows or foobar. and i am talking about a vanilla fb2k install and integrated 18 band equalizer

i willingly provide any further information about the system and it installs. but right now its a pretty recent set up windows 10 latest version build 1709, latest foobar and pretty decent hardware overall.

if this one is of interest and you need any additional information, just ask i will provide

  • Rollin
  • [*][*][*][*]
Re: Huge Delays when changing equalizer settings
Reply #1
Delay depends on output buffer length. File>Preferences>Playback>Output

  • dekatch
  • [*]
Re: Huge Delays when changing equalizer settings
Reply #2
Delay depends on output buffer length. File>Preferences>Playback>Output

straight on. you got me there. i have a vulnerable hard drive in my system. it's an older samsung which tends to go to sleep pretty often. i set buffer lenght to maximum to prevent pauses in playback. i fixed them by setting buffer length to 30.000ms but yea i reverted the settings to 0ms and all equalizer settings were recognized immediately.

i only have the latest new tracks on that samsung drive so ill have a workaround for it and this one afterall isnt an issue at all then. thanks for the reply!!

issue is fixed. thanks again rollin!

  • Shinsekai
  • [*][*]
Re: Huge Delays when changing equalizer settings
Reply #3
There is an option to prevent Hard disk sleeping on Preferences > Advanced > Playback.
Set the buffer to 1000 ms, no less...
| TAK pMax | QAAC ~ 192 kbps |

  • EpicForever
  • [*][*][*][*][*]
Re: Huge Delays when changing equalizer settings
Reply #4
There is also option in your Operating System, to disable power saving for hard disks...

  • darkflame23
  • [*][*][*]
Re: Huge Delays when changing equalizer settings
Reply #5
What's with the self-imposed 1000ms limit? I've been trying out a few different settings today, and setting to 0ms definitely looks best/goes best with the music on the beat detection presets with Shpeck and Milkdrop, with no audio drop-outs or glitches. At 1000ms, there always feels like there's a lag between the audio and the visuals.

  • dekatch
  • [*]
Re: Huge Delays when changing equalizer settings
Reply #6
shinsekai and epicforever, i am afraid, that this samsung disk is also dying. did all hardware test i could get my hands on. every harddrisk drive check result in as the samsung drive is healthy.

tried to disable sleep, altered the APM settings with crystaldiskinfo, but the drive keeps to occasiounally go to sleep. i dont mind the drive going to sleep, but the drive spinning down during playback really is not a good sign afterall. i suspect that the headers are somehow malfunctioning. however, tried really everything i can think off this drive has to go... dunno. its just another harddrive :P

  • EpicForever
  • [*][*][*][*][*]
Re: Huge Delays when changing equalizer settings
Reply #7
I don't know what exactly model of Samsung HDD you have, but maybe it is some specific series, like Western Digital's WD Green, which require changing firmware settings right after purchase, as WD set head parking at most restrictive level, so within a minute drive parks heads hundred of times... All depends on fact if it acts like this since the first time it was installed or if it started working like this after some time, or after some specific event, like installation of new OS. Depending on this factor, this maybe normal, abnormal or just OS-dependent behavior.