Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: issue with foobar2000 not updating the playlistview/library (Read 720 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

issue with foobar2000 not updating the playlistview/library

Foobar2000 2.1.5 32bit

I've noticed a bit of an issue with foobar2000 not noticing changes in the library despite having used right-click > File Operations > Delete File.

I am cleaning out duplicates from different collections, and let fb2k move files from one folder to another with the intent to overwrite the existing tracks. However, due to some differences in character encoding (typographic quotes versus normal quotes), some tracks ended up creating a copy. So, I used the above mentioned method to delete the ones that should have gotten overwritten during the move. The playlist looked like it got updated, but when I then executed True Peak Scanner, it complained that some objects couldn't be found. Same error when I tried reloading tags from the files. Yet the playlist showed only those tracks that should be there.

After I changed to a different album in the album list and back to the album I just cleaned, to my surprise all of the files I had just deleted, showed up again in the playlist. A quick check in Explorer showed they were indeed no longer present, so the delete action did in fact delete those files I wanted removed. I tried Edit > Remove Dead Items, no change, I tried shift-Library > Rescan folders, no change. I tried True Peak Scanner again, and this time fb2k crashed. Report sent in...

I also have noticed similar symptoms of fb2k not detecting external changes in the library. Repeated use of shift-Library > Rescan folders sometimes results in changes being detected, other times I could only get it to detect changes by switching to another album and back again... yet the above mentioned issue may have made it look like this worked but changes not actually updated in the library file.

This has prompted me to revert back to using 1.6.17, with all of the hassles of downgrading components that require 2.x

Re: issue with foobar2000 not updating the playlistview/library

Reply #1
Those library issues sound weird. There was a bug in 2.x series that could cause folder watcher to not see modifications if there were too many of them in a short time window, but it was fixed months ago.

I think I found your crash log. Crash seems to be caused by foo_multisource, which unfortunately happens a lot. Files seem to be on Z: drive, is that perhaps a NAS? I know those devices have had bugs in the past and file change notifications have not worked all that well on them.

Re: issue with foobar2000 not updating the playlistview/library

Reply #2
I think I found your crash log. Crash seems to be caused by foo_multisource, which unfortunately happens a lot. Files seem to be on Z: drive, is that perhaps a NAS? I know those devices have had bugs in the past and file change notifications have not worked all that well on them.
Thanks for the pointer to foo_multisource, but sadly that's no longer an issue. The drive wasn't a NAS, but it looks like the problem was caused by hardware about to fail as the drive died on me yesterday. I lost my whole music collection and a lot of other stuff, most of which can't be replaced. 

Re: issue with foobar2000 not updating the playlistview/library

Reply #3
Update: It definitely was caused by the HD about to fail. I luckily had some albums moved to a different drive a few days before and any changes I'm making to the file-names/directory structure, be it inside foobar2000 or outside through regular Explorer, immediately get detected.