Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_input_tak (Read 218757 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_input_tak

Reply #225
FLACCL#0.4-268mb-#8
: 899.467x realtime
Total:
  Decoded length: 2:58:15.040
  Opening time: 0:00.129
  Decoding time: 0:23.571
  Speed (x realtime): 907.480

FlaCuda#.91-268mb-#8
: 825.152x realtime
Total:
  Decoded length: 2:58:15.040
  Opening time: 0:00.122
  Decoding time: 0:25.706
  Speed (x realtime): 832.105

libFLAC 1.3.0-269mb-#8
: 917.412x realtime
Total:
  Decoded length: 2:58:15.040
  Opening time: 0:00.145
  Decoding time: 0:23.092
  Speed (x realtime): 926.303

TAK 2.3.0-260mb-p2
: 839.335x realtime
Total:
  Decoded length: 2:58:15.040
  Opening time: 0:00.180
  Decoding time: 0:25.219
  Speed (x realtime): 848.178

TAK 2.3.0-264mb-p1
: 944.209x realtime
Total:
  Decoded length: 2:58:15.040
  Opening time: 0:00.167
  Decoding time: 0:22.403
  Speed (x realtime): 954.774

TAK 2.3.0-269mb-p0
: 990.978x realtime
Total:
  Decoded length: 2:58:15.040
  Opening time: 0:00.165
  Decoding time: 0:21.337
  Speed (x realtime): 1002.504

This version is faster and smaller than any FLAC Encoders。


Re: foo_input_tak

Reply #227
My own idiocy got to me, not stashing the modified TAK SDK header and library in the repository, where they should be. I have updated the component to list it in the Decoders page for version 1.4 beta and newer, while it will still work on 1.3.

Re: foo_input_tak

Reply #228
This plugin have been updated in terms of functionality?

Re: foo_input_tak

Reply #229
Only that it now shows up in 1.4's input listing as a decoder, rather than being lumped into the unnamed legacy decoders listing.

Re: foo_input_tak

Reply #230
Version 0.4.9 (on foobar2000 1.5 beta 16 and 17) crashes when using the converter tool. The old 0.4.4 (2010-01-09) version from http://foosion.foobar2000.org/components/ worked just fine when transcoding.

Code: [Select]
Illegal operation:
Code: C0000005h, flags: 00000000h, address: 69F53CB2h
Access violation, operation: read, address: 00000070h

Call path:
converter_process::threadfunc=>input_entry::g_open_for_decoding

Code bytes (69F53CB2h):
69F53C72h:  FF 50 04 85 F6 74 07 8B 06 8B CE FF 50 04 8B 4F
69F53C82h:  20 85 C9 74 04 8B 01 FF 10 89 77 20 85 F6 74 07
69F53C92h:  8B 06 8B CE FF 50 04 8B 7F 04 85 F6 74 12 8B 06
69F53CA2h:  8B CE FF 50 04 85 F6 74 07 8B 06 8B CE FF 50 04
69F53CB2h:  8B 4F 70 85 C9 74 04 8B 01 FF 10 89 77 70 85 F6
69F53CC2h:  74 12 8B 06 8B CE FF 10 8B 06 8B CE FF 10 8B 06
69F53CD2h:  8B CE FF 10 8B 4D 08 85 C9 74 04 8B 01 FF 10 5F
69F53CE2h:  5E 5D C2 04 00 CC CC CC CC CC CC CC CC CC 55 8B

Stack (0A23EE2Ch):
0A23EE0Ch:  778DADEE 00000000 00000000 00000098
0A23EE1Ch:  68623600 0A23EE3C 7692A9F6 69F53CB2
0A23EE2Ch:  68623600 11BA5C28 0A23EE48 69F53090
0A23EE3Ch:  16E50950 11BA5C28 11BA5C28 0A23EE80
0A23EE4Ch:  69F5293E 16E50950 2E16148C 68623600
0A23EE5Ch:  69F6E050 00000000 778DADEE 00000000
0A23EE6Ch:  00000000 0000002C 0A23EEEC 69F645F8
0A23EE7Ch:  00000002 0A23EEF8 008FF60C 0A23EF94
0A23EE8Ch:  11BA5C28 17160200 03AD2308 16E50950
0A23EE9Ch:  16E50A7C 0A23F078 00000008 00000000
0A23EEACh:  01470000 0A23F078 77926D02 17210D78
0A23EEBCh:  01470000 FFFFFFFF 00000000 00000064
0A23EECCh:  00000000 115809C8 000000D4 00000064
0A23EEDCh:  00000000 115809C8 69F6E050 008FF28A
0A23EEECh:  0A23EFAC 00922B05 0000000A 0A23EFB8
0A23EEFCh:  008FFC20 0A23EF94 68623600 17160200
0A23EF0Ch:  03AD2308 16E50950 16E50A7C 68623600
0A23EF1Ch:  0A23F0E4 03AD2308 7692E58B 01470000
0A23EF2Ch:  00000000 17210D78 0A23EF44 7692E558
0A23EF3Ch:  17210D78 00000000 0A23EF50 0090C2EE

Registers:
EAX: 00000015, EBX: 00000000, ECX: 16E50950, EDX: 68623600
ESI: 16E50950, EDI: 00000000, EBP: 0A23EE34, ESP: 0A23EE2C

Crash location:
Module: foo_input_tak
Offset: 3CB2h

[...]

Re: foo_input_tak

Reply #231
I don't like advertising, but you could give the alternative TAK decoder a try. It was created because I too faced crashing with the existing decoder.

Re: foo_input_tak

Reply #232
Yep, I've been using your version for a while now and it works fine. I stumbled upon it when searching for old foo_input_tak versions between 0.4.4 and 0.4.9, too see which one crashes the converter tool.



Re: foo_input_tak

Reply #235
Hi, I encounter a problem on foo_upnp 0.99.49 and foo_input_tak 0.5.1 / 0.5
when I use such bubbleupnp/foobar2000 mobile on my phone, these combination will crash,
but foo_input_tak 0.4.9 play the music well.
use foobar2000 v1.6.2/v1.4.8 on win10 20H2(19042.685)

How I produce this failure:
1. install foobar v1.6.2
2. install foo_upnp 0.99.49
3. use bubbleupnp play flac, work.
4. install foo_input_tak 0.5.1
5. use bubbleupnp play tak, crash.

link is foobar failure report, not sure if is useful.

if need more info, please let me know. Thanks.

Re: foo_input_tak

Reply #236
Sorry for the slow response. There had been so many new posts that this had fallen off from the foobar forum's front page.

The crash log alone wasn't helpful but I found similar crashes from the crash database. At least in the sample crash I debugged the decoder is given a null pointer to read data from. That is obviously not allowed. I just released a new version where invalid data is rejected.

Re: foo_input_tak

Reply #237
Many thanks to the developer for the contributions.

Unfortunately, I also encountered the same problem as katy50306 mentioned.
When use UPnP/DLNA components to stream TAK file audio to mobile software like bubbleupnp or nplayer, foobar2000 will instantly crash.
How I produce this failure:
1. install foobar2000. version: 1.6.4 latest.
2. install UPnP/DLNA Renderer, Server, Control Point component. version: 0.99.49 latest.
3. install TAK Decoder component. version: 0.5.2 latest
4. Use bubbleupnp/nplayer/foobar2000 mobile (all latest version) stream TAK file audio, foobar2000 on PC will instantly crash.

However, there is no error in playing the TAK file in the foobar2000 PC side.
Besides, the developer has also released version 0.52 in response to the issue, but still haven't solved the problem.
Therefore, it is not clear whether the cause of the problem is from the TAK component or UPnP/DLNA component.
If the developer needs more log files to check the reasons, please contact me too.

Re: foo_input_tak

Reply #238
Thanks, I managed to replicate the crash. Fixed version uploaded.

Re: foo_input_tak

Reply #239
Good! This problem has been successfully solved in version 0.53.
Thanks again to the developer!

 
SimplePortal 1.0.0 RC1 © 2008-2021