HydrogenAudio

Lossless Audio Compression => WavPack => Topic started by: Arnold B. Krueger on 2009-06-10 12:32:33

Title: Cool edit pro 2.1 wavepack 4.42 hi bitrates broken
Post by: Arnold B. Krueger on 2009-06-10 12:32:33
I have a bunch of .wv files that I just downloaded from HA.

I'm trying to open them in CEP 2.1 using the latest-greatest wavepack filter I just downloaded from the wavepack web site (readme says it is version 2.9).

The 44/16 files open well:  (e.g. eig.wv)

The higher sample rate files open as white noise:  (e.g. Mangione02.wv, lovely1.wv, etc.)

Doesn't matter whether I drag and drop them or open them with the file open menu.
Title: Cool edit pro 2.1 wavepack 4.42 hi bitrates broken
Post by: bryant on 2009-06-10 13:16:31
Hi Arnie.

The problem is that those are very old WavPack encodings (2003!) and back then WavPack files retained the RIFF header from the original WAV file at the beginning of the file. This caused some programs (like CEP in some cases) to interpret the file as a WAV file before even allowing the WavPack plugin to have a shot at it. I tried these with CE2000 and it worked, but unfortunately I don’t have my PC with Audition anymore. I do remember that there were workarounds for this, but the only one I can think of now (at 5am) is to temporarily move the wavepcm.flt file in CEP's program file folder somewhere so that it won’t be used.

Alternatively, you can drop the files into the wvunpack.exe program to convert them into WAVs, which will work fine with CEP. Or convert them with Foobar2000.

Sorry you’re having trouble...WavPack is just supposed to work! 

Title: Cool edit pro 2.1 wavepack 4.42 hi bitrates broken
Post by: Arnold B. Krueger on 2009-06-10 14:25:14
Hi Arnie.

The problem is that those are very old WavPack encodings (2003!) and back then WavPack files retained the RIFF header from the original WAV file at the beginning of the file. This caused some programs (like CEP in some cases) to interpret the file as a WAV file before even allowing the WavPack plugin to have a shot at it. I tried these with CE2000 and it worked, but unfortunately I don’t have my PC with Audition anymore. I do remember that there were workarounds for this, but the only one I can think of now (at 5am) is to temporarily move the wavepcm.flt file in CEP's program file folder somewhere so that it won’t be used.

Alternatively, you can drop the files into the wvunpack.exe program to convert them into WAVs, which will work fine with CEP. Or convert them with Foobar2000.

Sorry you’re having trouble...WavPack is just supposed to work! 


Well the wvunpack option worked for me, so that is that.  The ability to just drop files on it is very neat.

Thanks for the quick response.
SimplePortal 1.0.0 RC1 © 2008-2021