HydrogenAudio

Hosted Forums => foobar2000 => 3rd Party Plugins - (fb2k) => Topic started by: mgoodgood on 2003-06-01 14:51:42

Title: foo_delete not working with v0.667
Post by: mgoodgood on 2003-06-01 14:51:42
hmm..  when i tried the plugins it said wrong version of sdk used to compile the plugin
so.. any fix?

help would be much appreciated 
Title: foo_delete not working with v0.667
Post by: Heaven17 on 2003-06-01 15:23:38
Works fine here... 

are you sure you have the latest version?
Title: foo_delete not working with v0.667
Post by: nexus on 2003-06-01 16:33:48
not working with 0.667 here too.
Title: foo_delete not working with v0.667
Post by: L.King on 2003-06-01 19:51:06
Curious George's 0.6x compile doesn't load on Win95 because SHFileOperationW is missing in shell32.dll

messer's original dll loads fine with the foobar version it was compiled for (0.5x)
Title: foo_delete not working with v0.667
Post by: mgoodgood on 2003-06-02 08:33:58
hmm.. actually i'm using window xp...
Title: foo_delete not working with v0.667
Post by: Heaven17 on 2003-06-02 09:41:03
Weird.

I'm using Win2K (SP3), FB2K v0.667 Unicode version (filesize 119296 bytes, modified 31/05/2003 11:27), foo_delete.dll (filesize 15360 bytes, modified 23/04/2003 21:17).

Everything works fine, no problems, no error messages...nothing unusual at all.
Title: foo_delete not working with v0.667
Post by: Curi0us_George on 2003-06-02 09:50:56
You've got the version written/compiled by Messer.  His version doesn't work with anything newer than some 0.6 beta build.

I modified and recompiled it to work with 0.6b14 (I think it was b14) and newer.

http://gelaed.com/resources/cplusplus/foo_delete.zip (http://gelaed.com/resources/cplusplus/foo_delete.zip)

If you don't already have msvcr70.dll, you'll need it.
http://gelaed.com/resources/cplusplus/msvcr70.zip (http://gelaed.com/resources/cplusplus/msvcr70.zip)
Title: foo_delete not working with v0.667
Post by: Simonite on 2003-06-02 21:20:50
I'm still having no joy with your latest version.

It says 'error while erasing file Continue?'
Title: foo_delete not working with v0.667
Post by: mgoodgood on 2003-06-03 06:02:05
Gee.. works like a charm.. Thanks!! 
Title: foo_delete not working with v0.667
Post by: Curi0us_George on 2003-06-03 13:26:29
Quote
I'm still having no joy with your latest version.

It says 'error while erasing file Continue?'

Sounds like you've got a dead entry (or entries) in the database.

mgoodgood, you're welcome.
Title: foo_delete not working with v0.667
Post by: themesb on 2003-06-20 18:44:00
Hmmm... the new version has actually BROKEN functionality on my v.667.  When I do a delete or recycle a file, about 1/2 of the time, FB2K simply crashes. I can't pin down why that happens only 1/2 of the time, but all of the files I delete are valid and whatnot.
Title: foo_delete not working with v0.667
Post by: Curi0us_George on 2003-06-20 20:10:25
Hmm.  I haven't done work on any of my plugins in a while.  But I'll try to look into it this weekend.

Please post any information.  e.g. crashing on delete or recycle?
Title: foo_delete not working with v0.667
Post by: themesb on 2003-06-22 20:43:01
Alright, here's my foo_delete activity from yesterday:

delete 13 mp3s at once, no crash 
delete 1 mp3 , no crash 
recycle 16 mp3s at once, crash
recycle 1 mp3, crash
delete 14 mp3s at once, crash
delete 1 flac, crash
recycle 1 flac, crash

reboot

recycle 16 mp3s, crash
recycle 1 mp3, no crash 
recycle 1 mp3, crash
delete 2 mp3, crash

After each crash, the deleted/recycled entries appear again in the playlist when I restart FB2K, but the files have actually been successfully recycled/deleted, because clearing the dead entries gets rid of their playlist entries. I hope this info is useful - I posted each incident because I can't really find much of a pattern. I could also start giving you stack traces, if that would help...
Title: foo_delete not working with v0.667
Post by: themesb on 2003-06-23 07:39:41
Hmm... I seem to be able to recycle/delete all I want when my playlist is relatively small (~100 files) rather than large (~1600). A cache/memory issue, perhaps?
Title: foo_delete not working with v0.667
Post by: Curi0us_George on 2003-06-26 05:42:44
Ugh.  I think I see the problem.  I'm not doing any work on my plugins tonight, though. I'll try to get it working soon.

Tell me, does it only seem to crash when you're not playing anything?  I think I added this bug when I added support for deleting the currently playing song.
Title: foo_delete not working with v0.667
Post by: themesb on 2003-06-26 06:29:41
Bingo, you're right, I can recycle/delete with impunity if a track's playing, but it crashes if I'm not playing anything. I guess that's the pattern I missed.
SimplePortal 1.0.0 RC1 © 2008-2021