Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Library Tree (Read 70138 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: Library Tree

Reply #25
All users of Library Tree 1.3.9.2 should ensure that the 'Chakra' script engine is used (requires IE9 or later) - select in the JScript panel configuration window  (shift + right click). The script will not run properly with the JScript engine.

Re: Library Tree

Reply #26
New Version: Library Tree 1.4

Requirement: JScript Panel 2.1.0+

Use the 'Chakra' script engine if possible (requires IE9 or later) - its faster with this script. Set in the JScript panel configuration window (shift + right click).

Re: Library Tree

Reply #27
New Version: Library Tree 1.401

Requirement as above

Re: Library Tree

Reply #28
New Version: Library Tree 1.4.0.2

Requirement as reply #48.

Re: Library Tree

Reply #29
New Version: Library Tree 1.4.0.3

This is maintenance update to fix compatibility with JScript Panel 2.2.0+. There are no new features.

Requirement as reply #48.





Re: Library Tree

Reply #34
New Version: Library Tree 2.1.1

Requirements are as above.

Please post discussion here.


Re: Library Tree

Reply #36
New Version for JScript Panel: Library Tree 1.4.0.4

REQUIREMENT: JScript Panel 2.3.1+
This is a maintenance update intended for users who wish to continue using a JScript Panel version. There are no new features compared with earlier 1.4.x.x versions. It's recommended that you use the latest Spider Monkey Panel version if at all possible, e.g. it has a newer feature set and is more actively developed.

CHANGELOG

Compatibility fix for JScript panel 2.3.x series

Please post discussion here.


Re: Library Tree

Reply #38
New Version: Library Tree

REQUIREMENTS:
Spider Monkey Panel 1.4.1+
IE8 or later
FontAwesome

Please post discussion here

INSTALLATION

IMPORTANT: If updating from v2.1.3, and you wish to retain settings, export panel properties before installing the new version. Import them after installation.

This version has to be installed as a package.
1) Add a spider monkey panel to foobar2000.
1) Right click the spider monkey panel while pressing the windows key + shift. Choose configure panel.
2) On the script tab choose package.
3) Click the import button and import the library tree package.

Troubleshooting
Please note that the package manager is a new feature of spider monkey panel. If you experience issues with the spider monkey panel installer follow the guide in the spoiler here. If you wish to do a manual install as in the guide, just change the master folder to {E85C9EF0-778B-46DD-AF20-F4BE831360DD}

Re: Library Tree

Reply #39
^ moved to correct location in main discussion thread

Re: Library Tree

Reply #40
New Version: Library Tree v2.2.0

REQUIREMENTS:
Spider Monkey Panel 1.5.0+
IE8 or later
FontAwesome

Please post discussion here

INSTALLATION

This version has to be installed as a package.

If UPDATING consider exporting panel properties to back-up settings (right click the panel while pressing the windows key + shift)
    - REQUIRED if updating from v2.1.3 or earlier & you wish to retain panel settings. Import them after installation.
    - OPTIONAL if updating a package, as settings should automatically be retained. Recommended as good practice, if you've done significant customization, in case the unexpected happens.

New install or update:
1) Add a spider monkey panel to foobar2000 if required
2) Close any instances of windows explorer using foobar2000 folders or subfolders
3) Right click the spider monkey panel while pressing the windows key + shift
4) Choose configure panel
5) On the script tab ensure package is selected
6) Open package manager if it doesn't open automatically
7) Import the package