Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Embedded Youtube video doesn't play. (Read 479 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Embedded Youtube video doesn't play.

Reply #1
For me the video doesn't play on firefox, thumbnail displays, minimise button works, the youtube link works so it doesn't matter much IMO.

Re: Embedded Youtube video doesn't play.

Reply #2
Thanks. As a Firefox user I started to get sensitive when something doesn't work and it seems that everyone is using Chrome / Chromium browsers. Something like this:
https://hydrogenaud.io/index.php/topic,122626.msg1012483.html#msg1012483

However it turns out that no one can play the videos regardless of browsers and OSes. I was even thinking about getting a Linux Live USB and check if it works or not.

IIRC embedded videos played without issue before, so probably an issue on the forum software.

Re: Embedded Youtube video doesn't play.

Reply #3
From web developer tools says, in firefox:
Code: [Select]
Content Security Policy: The page’s settings blocked the loading of a resource at https://www.youtube-nocookie.com/embed/sciD9c1Y8Xk?rel=0 (“default-src”).
in chromium:
Code: [Select]
Refused to frame 'https://www.youtube-nocookie.com/' because it violates the following Content Security Policy directive: "default-src 'self' www.google.com www.gstatic.com". Note that 'frame-src' was not explicitly set, so 'default-src' is used as a fallback.

Re: Embedded Youtube video doesn't play.

Reply #4
I think Youtube has stopped live streaming off their site.

You have to click on the YouTube link in the top left.
"The lack of money is the root of all evil." - Mark Twain

 

Re: Embedded Youtube video doesn't play.

Reply #5
I think Youtube has stopped live streaming off their site.
It works on other sites.
I'm not a web developer but as I understand the error message I posted earlier, this is the forum software that doesn't allow the browser to load javascript from youtube.