Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: 'Failed to load ripper module' (Read 1613 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

'Failed to load ripper module'

Hi there.

I am trying to compile CUETools for my own use with the latest changes made to the source code, however I have had a persistent problem regarding CUERipper.

According to the photo below, there is an error loading a CUERipper module. Why does it happen? According to the instructions, I use all the resources required to compile the program... In Visual Studio 2017, selecting 'Any CPU' under 'Solution Platforms', I compile CUETools, CUERipper and BluTools.

Thanks in advance.

Re: 'Failed to load ripper module'

Reply #3
Thanks for those info, very usefull ideed. This thread is bookmarked.

Thank you very much! I'm going to try this out and at a suitable time I will leave the information of my experience here, for future consultation.

I'm a big fan of your work, CUERipper is incredibly simple and effective. CUETools is a must. Thank you so much for sharing such a high quality program.

Re: 'Failed to load ripper module'

Reply #4
I must be making a mistake at some point.

Using TortoiseGit, I downloaded the latest source code in a local repository on my computer, opened Visual Studio 2017 with all available updates, and compiled only CUETools, CUERipper and BluTools, although there are other build options, as shown in the image I attached below.

Finished the compilations, I went to the subdirectory "CUETools" and executed the file "collect_files.bat" that exists there.

Inside the "bin" subdirectory, I opened the "Release" directory and there are two directories where the executables are found: "CUETools_2.1.9" and "net47".

In both places, when opening CUERipper, the same problem previously reported occurred. Please what am I doing wrong?

Re: 'Failed to load ripper module'

Reply #5
Have you tried: Build - Build Solution (Ctrl+Shift+B)?

Re: 'Failed to load ripper module'

Reply #6
Have you tried: Build - Build Solution (Ctrl+Shift+B)?
OK, in this way it works!

Apparently everything is in perfect order. If I don't bother again here, it's because the problem is definitely solved.

Thank you very much for the support!

Re: 'Failed to load ripper module'

Reply #7
Well... unfortunately, I've got this error...

I've tried a lot of things, but I don't know what to do anymore...

Re: 'Failed to load ripper module'

Reply #8
MACLib is a plugin dll. In order to build it, you need to switch the platform from "Any CPU" to "x64" and/or "Win32" and build the solution again.