Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Gapless broken on Android (Read 559 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Gapless broken on Android

I've been using Foobar2000 mobile on Android for a few years, since Google Play Music was withdrawn. Proper gapless support has always been very important to me, and it has always worked flawlessly. However, in the last week or so I've noticed it seems to be broken.

My files are all in m4a format, encoded using the Apple iTunes AAC encoder by Foobar2000 on Windows, mostly from CDs ripped to FLAC. They are stored on an SD card in my phone. The files aren't the problem because there are thousands of them, some years old, and they all used to play fine without gaps. My phone is a Moto G73 5G running Android 14. I've tried turning on, and turning off, all battery saving optimisations, using OpenSL audio output, listening via several different Bluetooth devices, or wired headphones, or the phone's speaker, and disabling the Dolby Atmos app. None of it makes any difference and I can't think of anything else. There is a short half-second gap between tracks – but if you then immediately rewind to the end of the previous track to try to repeat it, the gap disappears. But then it's back for the next track, and if you leave an album to play through, the gaps are always there. It seems to make no difference if the app is foregrounded or backgrounded. I don't know if the issue was introduced by the update to Android 14, or by the recent Foobar2000 app update, or something else, and I'm at a loss how to fix it.

Can anyone help? Are others seeing the same issue? Many thanks.

 

Re: Gapless broken on Android

Reply #1
If I open the console, I see the message "Playback interrupted, source is stalling..." is logged between each line showing "Opening track for playback" followed by the location on the SD card. Also, turning on or off the option to use read-ahead for playing local files in the advanced options doesn't seem to help.