Skip to main content
Recent Posts
1
Opus / Re: How to encode TRUEHD 5.1 to Opus 5.1 using opusenc?
Last post by Luke M -
If you want to encode opus directly from ffmpeg, not using opusenc, you have to use some weird options because the defaults are broken.

Code: [Select]
ffmpeg -i input.mkv -af aformat=channel_layouts="7.1|5.1|stereo" -mapping_family 1 -vcodec copy -scodec copy -acodec libopus -map 0 output.mkv

Without the channel_layouts stuff, ffmpeg will fail with an error. Without the mapping_family option, ffmpeg will disable channel coupling and LFE optimization.

The default bitrate is 96k for stereo, 320k for 5.1, and 416k for 7.1. There's no way to change this in a sensible way (e.g. per channel); if you set a bitrate it will apply the same rate to stereo, 5.1, 7.1, etc.
2
Uploads - (fb2k) / Re: A new resampler DSP for foobar2000
Last post by seventhstar -
Hola! What is the best configuration for the SoX resampler and the Smart Dither in foobar2000 for downsampling (24/96 to 16/48) and upsampling (16/44.1 to 16/48)? I'm not interested in speed, I'm interested in the maximum configuration. Thanks.

SoX default settings:
Quality: Best
Passband: 95%
Allow aliasing/imaging: No
Phase Response: 50% (linear)

Smart Dither default settings:
Target bith depth: 16 bps
Amount of dither in bits: 1.0 bits
High-pass filter the dither noise: Yes
3
Opus / Re: Why doesn't opusenc have a quality setting?
Last post by moisesmcardona -
The only thing hard coded into the encoder and decoder is the resampling quality, which is set at 5. I have made custom builds with this number changed to 10. I don't think the developers will change this behavior soon as they think that 5 is enough, but still internally at the code, it can go up to 10.
4
Support - (fb2k) / Re: How about the "Library files could not be written" dialog ?
Last post by wcs13 -
Thanks Case. Here's the log file.
I've cleared it up a bit from some apps (antivirus, firefox, rainmeter, etc.).
You'll easily find all the foobar stuff and the reported errors.

Having checked several times today, I need to add that in fact the error is not systematic. Actually I thought it was, because maybe it tends to happen "all the time" or "most of the time" when foobar has been running for at least some minutes (usually I leave it running for hours). But just starting foobar and quitting it after a few seconds seems to trigger the error less often.

I don't know what more to add. Feel free to ask for more tests of course.
5
General Audio / Re: Headphones amplifier
Last post by DVDdoug -
Is there something wrong with the existing headphone output?   It's easier to make a recommendation if we know what problem you're trying to solve.

If the headphones are not loud enough or if you've got an "impedance problem" any headphone amp with line-inputs can be plugged into the existing headphone output (with the appropriate cable-adapters).  

Or, you can plug into the "tape outputs"  or "recording outputs" if your receiver has them, but these are not volume-controlled so you won't be able to use the receivers remote control for volume.   (Bass & treble, EQ, or other controls/adjustments will also be bypassed.)  

I don't have a recommendation for you but I'd recommend that you don't spend a lot of money (unless you have lots of extra money and you don't care).    The actual electronics for a good headphone amp are cheap & easy so you're mostly paying for the power supply, case, controls, connectors, marketing, etc. 

8
General Audio / Re: fb2k's foo_hdcd not as good as hdcd.exe?
Last post by Porcus -
Sheesh. I only did that to prevent false positives, which are a dime a dozen when it comes to the HDCD format.
There probably were, when foo_hdcd reacted to single-channel flags. That bug was fixed some three years ago?

Doubling volume 10 seconds into the the track is an audibly BIG error. According to https://hydrogenaud.io/index.php/topic,79427.msg836348.html#msg836348 , a HDCD decoder should need no more than 200 milliseconds to switch on. According to https://hydrogenaud.io/index.php/topic,30999.msg778685.html#msg778685 , it would work less-than-perfect for the first 145 ms into a cut+paste ...

If you don't like it, I can just make it always process, and never auto detect

If I can suggest something, let it respond to the <HDCD> tag as follows:
"ALWAYS": switch HDCD on at the beginning of the track
"YES": mimic a HDCD DAC as close as practically possible.
"RESET xxxx": switch HDCD off and ignore the first xxxx ms. That fixes wrong track transitions. Likely most useful for scanning.
"NO": ignore HDCD (= never process this track) upon playback - but invoke when scanning.
"NEVER": ignore HDCD upon playback and upon scanning, like today's "NO".


The "ideal" thing to do (cf. quotes by Charles Hansen above) would be to check the pregap. But that requires foo_hdcd to utilize the previous track, given the common practice of appending pregaps, and that maybe isn't straightforward unless fb2k plays two consecutive tracks from the same album.
But if the user scans an entire album and finds that tracks N-1 and N are both HDCD, then the ALWAYS would handle that.
10
3rd Party Plugins - (fb2k) / Re: External Tags
Last post by Case -
Version 1.0.18 up with the new search function moved to its own thread. Also fixed a bug with reading back ReplayGain info from non-subsong enabled external APE tags.
SimplePortal 1.0.0 RC1 © 2008-2018