Skip to main content

Topic: Facets Not Splitting Multivalue Fields All of a Sudden?! (Read 1034 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • fb2kman
  • [*]
Facets Not Splitting Multivalue Fields All of a Sudden?!
Been using Facets + FB2K for about 5 years with no problem splitting multi-value fields. Just added a couple of new MP3s to the library with multiple values in the <MOOD> field and all of sudden they're not being split up? It's even stranger because older MP3s with multivalue fields are being split up no problem?! Here are some pics

Multiple Values Separated by Semicolon


Facets Syntax setup for multivalue field splitting with %<field>% as mentioned on the Wiki


Other Info
- Using foobar 1.3.17 (portable installation on a folder on my SD card)

Any help is much appreciated!

  • Daeron
  • [*][*][*][*][*]
Re: Facets Not Splitting Multivalue Fields All of a Sudden?!
Reply #1
I would suspect they are written by another program in a different format than what foobar uses. Have you tried rewriting them with foobar (change one character, rewrite, change back, rewrite)?

  • fb2kman
  • [*]
Re: Facets Not Splitting Multivalue Fields All of a Sudden?!
Reply #2
Just tried that, no luck  :(

Also tried Right Click Properties -> Tools -> Remove Tags. Then I refilled the fields, but still showing up with multiple values.


  • lvqcl
  • [*][*][*][*][*]
  • Developer
Re: Facets Not Splitting Multivalue Fields All of a Sudden?!
Reply #3
Advanced preferences: Display -> Properties Dialog -> Multivalue fields.  Add MOOD field there.
Then either: remove all MOOD tags and re-add them, or: file properties -> right click on MOOD line -> Split values...

  • fb2kman
  • [*]
Re: Facets Not Splitting Multivalue Fields All of a Sudden?!
Reply #4
Advanced preferences: Display -> Properties Dialog -> Multivalue fields.  Add MOOD field there.
Then either: remove all MOOD tags and re-add them, or: file properties -> right click on MOOD line -> Split values...


AYYYYYY This worked!

The MOOD Field somehow got removed from the Multivalue fields in Advanced Preferences. Thank you so much!!!