Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_ui_columns 0.3.6.5 Album Art Error: Location not parsable: ". (Read 2274 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_ui_columns 0.3.6.5 Album Art Error: Location not parsable: ".

I'm trying to set up some custom artwork sources with the Columns UI to get seemless integration with the Album Art Downloader. I added a simple script for the path ("C:\User\Xzyx987X\Music\#Artwork\[%album%]\") and put a piece of test artwork in the folder, but whenever I try to load a song from the album, I get the following error:

Location not parsable: "C:\Users\Xzyx987X\Music\Artwork\Please Mr.Lostman\Front.jpg", reason: Unsupported file format

I assume there's nothing wrong with my path script since the path it found to the file is correct, but no matter what I do it refuses to load the artwork. I tried moving the path, using png instead of jpg, etc, etc, but nothing works. Anyone know what I'm doing wrong?

foo_ui_columns 0.3.6.5 Album Art Error: Location not parsable: ".

Reply #1
Location not parsable: "C:\Users\Xzyx987X\Music\Artwork\Please Mr.Lostman\Front.jpg", reason: Unsupported file format

That's not an error, it's only a message from the autowatch function of Media Library that tells that it's not a playable file.

But anyway it's useful because it provides the exact path to the file while you set this path:
C:\User\Xzyx987X\Music\#Artwork\[%album%]\

Unless you typed wrong in the post, I think the problem is the # character.

By the way, I suggest you to move the last \ inside the square brackets, otherwise for files wth no album tag it will result in two consecutive \

foo_ui_columns 0.3.6.5 Album Art Error: Location not parsable: ".

Reply #2
Actually I did type it wrong. That was something I changed when I was experimenting with different paths to make it work. I also typed "User" instead of "Users". Right now though, it is set to "C:\Users\Xzyx987X\Music\Artwork\[%album%]\", and I'm absolutely sure the folder is correct, but it still won't display the artwork in that folder for songs that match the album. It quit spitting out errors though, which I assume is because the library already knows about the files. But still, the artwork isn't displayed. Oh, I will take your advice on moving the "\" though.

foo_ui_columns 0.3.6.5 Album Art Error: Location not parsable: ".

Reply #3
Aha, I found the problem. as it turn out "[%album%]" was just plain wrong and uneeded in this context. Some examples I saw lead me to believe "[]" was used to indicate a variable in a literal string, but as it turns out it just plain wasn't needed, and it works fine without it. Sigh, I really wish foobar's scripting was better documented.

 

 
SimplePortal 1.0.0 RC1 © 2008-2021