Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: corrupted m4a/aac file - moov not found (Read 7637 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

corrupted m4a/aac file - moov not found


first, i hope this is the right subforum...if not, please move it where ever this thread belongs problem is this: i got a .m4a file and judging from the file size i guess it contains an .aac
foobar won't play this file...or open the property dialog for it...or verify it's matter what, foobar tells me 'moov not found'
musicbrainz and mp3tag do the same
however, vlc plays the file fine and so does wmp, which makes me giggle
i dunno if this is of importance, but renaming the file to .aac results in the fact no application would even look at it, i.e. nothing happens if i try to open it or drag'n'drop it, except for still plays the file fine, which makes me giggle even more

so, what to do with this file? it obviously is damaged yet fully to get it played in the cool music players?
if more input from my side is needed, i'm happy to provide it

corrupted m4a/aac file - moov not found

Reply #2
You could also try ffmpeg:

ffmpeg -i infile.m4a -acodec copy outfile.aac

corrupted m4a/aac file - moov not found

Reply #3
i didn't understand vlc's interface...i was able to hit the record button but didn't find any settings nor the output directory
then i tried ffmpeg and the resulting .aac showed the same behavior as the original .m4a
finally, i feed the .m4a to xmedia recode which told me it was actually an, problem solved

thx for your help

corrupted m4a/aac file - moov not found

Reply #4
It is always assumed that AAC audio is contained in MP4/M4A containers, but this isn't always true:

Almost any kind of data can be embedded in MPEG-4 Part 14 files through private streams. A separate hint track is used to include streaming information in the file. The registered codecs for MPEG-4 Part 12-based files are published on the website of MP4 Registration authority (,[22] but most of them are not widely supported by MP4 players. The widely supported codecs and additional data streams are:[citation needed]

    Video: MPEG-4 Part 10 (H.264) and MPEG-4 Part 2

    Other compression formats are less used: MPEG-2 and MPEG-1

    Audio: Advanced Audio Coding

    Also MPEG-4 Part 3 audio objects, such as Audio Lossless Coding (ALS), Scalable Lossless Coding (SLS), MP3, MPEG-1 Audio Layer II (MP2), MPEG-1 Audio Layer I (MP1), CELP, HVXC (speech), TwinVQ, Text To Speech Interface (TTSI) and Structured Audio Orchestra Language (SAOL)
    Other compression formats are less used: Apple Lossless

    Subtitles: MPEG-4 Timed Text (also known as 3GPP Timed Text).

    Nero Digital uses DVD Video subtitles in MP4 files


So MP3 audio can be used in a M4A container. I don't think just renaming it to MP3 would help unless it really was a MP3 file.
ffmpeg -i infile.m4a -acodec copy outfile.mp3

corrupted m4a/aac file - moov not found

Reply #5
thx for the clarification as i was somehow under the impression that audio-only .m4a either contains .aac or .alac

and honestly, i don't know what file it initially was...i indeed just renamed it to .mp3 and it now plays fine in foobar...also tagging it is possible
furthermore, when verifing its integrity with foobar i am told everything's fine, i.e. no problem found

corrupted m4a/aac file - moov not found

Reply #6
All signs point to it being a MP3 that was just renamed to have the wrong file-extension. Presumably programs like VLC and WMP are less strict about extension having to match content then foobar2000 is, i.e. they will try to detect the actual format, rather than throwing an error as soon as it doesn’t match expectations from the extension.

SimplePortal 1.0.0 RC1 © 2008-2021