Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Recent Posts
1
Support - (fb2k) / Re: My foobar has been crashing for the past few months.
Last post by ProTofik -
I presume 'Ryzen 7 3700X' foo_dsp_std+12CD0h crashes on the tracker are yours.

No, I have not reported my issue anywhere officially yet. However, I also have Ryzen R7 3700X and my sampling rate is also set to 192000Hz.

Unfortunately nobody else has similar crashes; everybody runs the same code, so it might be somehow tied to your machine.

Well I have and that other person with R7 3700X & 192000Hz who raised it on the tracker seems to be experiencing the same issue. Perhaps a very rare bug?

Edit: I've found the crash log: https://pastebin.com/NQnGwCCy

Judging from the dates on crash files in my profile, crashing started in February this year. That is also when I changed my DAC from NwAvGuy ODAC that I had for 5 years, to Topping DX3 (connected via optical cable). I've had had R7 3700X since its release date and haven't had this issue before.
2
Support - (fb2k) / Re: My foobar has been crashing for the past few months.
Last post by Peter -
I presume 'Ryzen 7 3700X' foo_dsp_std+12CD0h crashes on the tracker are yours.
Technically speaking, it's SSRC resampler implicitly used to upsample audio, to 192000Hz as requested by your audio device.
Unfortunately nobody else has similar crashes; everybody runs the same code, so it might be somehow tied to your machine.

I recommend putting another resampler (anything else than SSRC) at the end of your DSP chain, configured to output sample rate of 192000Hz, this will suppress the code that crashes for you.
3
General - (fb2k) / Re: ReplayGain Newbie
Last post by cresco -
Thanks for your help and advice @garym  and @Apesbrain

It does seem I was looking at this the wrong way round. It is not that my SACD rips are quieter, (@garym indicates the example is near the RG target), rather that the CD rips are louder (loudness wars era?).

I have now written tags to the rip I made 8 years ago from the CD layer of the exact same media disc shown in my original post. It used to play back much louder that the recent SACD layer rip. Now that I have added RG tags they both play back at the same level. Below is a screenshot of the CD layer RG values.

I will over time add RG tags to my whole library starting with a subset of folders to check I am getting what I expect. I do want to preserve any relative changes in level from track to track within an album which may be present for artistic reasons. So I assume I need "Album gain" scanning to achieve this.
6
3rd Party Plugins - (fb2k) / Re: foo_youtube
Last post by Wolfbane -
I have a problem, and its 3 "programs" and something is causing a "problem", so not 100% if its related to this plugin or any of the other programs, or even windows 10 itself.

But Ill try and explain as short as possible, even if its going to be long.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

So Streaming with "OBS Studio" using "FooBar" to stream the music, and capturing the "FooBar YouTube plugin" with "OBS"

So I capture "FooBar" window. (Foobar Youtube video plugin)
For some reason, OBS finds the correct window, and without any "cropping" or "edit transform" it does not capture the entire windows.
It did capture entire window and everything worked one 1hour earlier. So something "happened"...

When I stream I set my desktop resolution to 1920x1080 with 100% scale .
But when I do not stream I set my resolution to with 125% scale (windows 10) ( https://prnt.sc/130ubjv )

What I think "happened" ?
So I streamed, have all programs up and running, close down some programs, change resolution to 3440x1440 and scale to 125% settings
Then I notice I dint close all programs and close them without thinking about it.
Then I remember I needed to make a small change to the layout of my stream in OBS, change back to 1920x1080 with 100% scale.
open up all programs, but now I notice that several things are not right size and things are not captured correctly by OBS.
do some editing fixes most things, but the biggest issue is can not capture the entire video/youtube window any longer.
And if I would guess it seems like around 25% of the windows is missing, without any cropping. So I guess its the scale thing is screwing things up.

Here is a screenshot.
https://prnt.sc/130xi09
To explain it, OBS Studion in the background, with my layout.
Bottom right corner is the "Original source" (FooBar YouTube) I want to capture. its a separate window above OBS in this picture.
Top left is the "Windows Capture", but as you can clearly see, what is captures its a lot less, looks to be around 25% missing.

So some program or windows itself remembered the size of the window when it was closed, dint take "scale" into concideration, and when I opened the program it dint recheck the "scale" I assume, and therefor its somehow "screwed"

So once again, not sure if its this plugin that has potential issues with windows scale. Or OBS, or Windows, or FooBar...

Any ideas who is the villan in this case ?
8
3rd Party Plugins - (fb2k) / Re: foo_uie_lyrics3
Last post by sveakul -
I tried just now and it does seem to "hang" on the Minilyrics source and never find anything, before proceeding to the next.  And yes, a couple of days ago this did not happen.  I only search for non-synced lyrics, but even so Minilyrics would often return results.  Changes at the website?
10
3rd Party Plugins - (fb2k) / Re: foo_uie_lyrics3
Last post by Paaufo -
Guys, is anyone else having problems with "Multi DB: Minilyrics"?

It was working fine a couple of days ago (tons of results), but now it takes forever and I don't get a single result from that source. I also use: Musixmatch, QQ, AZ and Songlyrics and they seem to be working fine (but much less results than what Minilyrics used to return).

I'm using: foo_multisource 0.42 (SSE2), foo_uie_lyrics3 0.5 and Foobar v1.6.5.

EDIT: I just installed foo_uie_lyrics3_minilyrics 0.9.2 to see if it helped, but the same thing happened: no results from Minil. and the search took longer than usual.
SimplePortal 1.0.0 RC1 © 2008-2021