Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: LAME won't run under EAC (Read 4171 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

LAME won't run under EAC

I can't get LAME to run under EAC as it just rips to .wav. I don't understand what I am doing wrong.

I am using EAC 1 beta3, LAME 3.99.3 on Windows 7 64bit, I've tried both 32 and 64bit versions of LAME.




LAME won't run under EAC

Reply #1
More information is needed before anyone can even guess anything: how you have configured EAC, what your command-line is, etc.

LAME won't run under EAC

Reply #2
My command line is:

  -V 0 %source% %dest%

I also sometimes get this error:



Followed by this:




LAME won't run under EAC

Reply #3
Look more closely at the error message in your first screenshot. Based upon the presence of additional options therein besides those, including those that make no sense (-b320, which will defeat the point of using VBR) or that are redundant (%source% and %dest% are being inserted as-is rather than translated into their corresponding filenames), it appears that you are not invoking LAME as a user-defined encoder. You should be.

LAME won't run under EAC

Reply #4
Ah thanks, I don't get the error anymore.

Though it's still just leaving me with the .wav file.

LAME won't run under EAC

Reply #5
It may help if you upload a screenshot of your settings, in the vein of the one next to the Knowledgebase section I linked.

LAME won't run under EAC

Reply #6
Like this?:



Also the "test encoder" seems to check out fine.


LAME won't run under EAC

Reply #8
yea, I tried both.

LAME won't run under EAC

Reply #9
I'm having a similar problem.
Win7 64bit
EAC 1.3 Beta 3
lame: D:\temp\mp3_encode>lame --version
LAME 32bits version 3.99.3 (http://lame.sf.net)

The 32bit version I can get to run from command line. The 64bit version seems to mess up the file names from command line.
That is why I used the 32bit version of lame in EAC.

Compressor test:
Used command line:
C:\Program Files (x86)\lame3.99.3\lame.exe -V2 "etmp7!2-2.wav" "etmp7!2-2.mp3"

Compressor output:
Could not find "etmp7!2-2.wav etmp7!2-2.mp3".
Can't init infile 'etmp7!2-2.wav etmp7!2-2.mp3'

Return Code 4294967295

the  in the filename is not a copy paste error it is wat EAC dumps. This is what happens during a real encode as well.
Any ideas anyone?

 
SimplePortal 1.0.0 RC1 © 2008-2021