Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: CUETools DB (Read 225938 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: CUETools DB

Reply #226
Looking back at it, I would have wished for the CUETools DB to also hold enough cuesheet information to update my rips with index marks. I miss some of those in my collection, which was ripped in 2008 with dBpoweramp.

Not holding my breath though.
High Voltage socket-nose-avatar

Re: CUETools DB

Reply #227
Index marks are messy. Their detection is optional and not 100% reliable. We could still try to collect that information, but i'd rather not claim to have a feature that doesn't actually work that good. One of the obstacles would probably be that EAC doesn't pass this information to plugins.
CUETools 2.1.6

Re: CUETools DB

Reply #228
Sure - but after all, CTDB is all about user-generated data with lots of errors ;-)
(The obstacle you mention could be significant, if there is no way to load the cuesheet it generates.)
High Voltage socket-nose-avatar

Re: CUETools DB

Reply #229
I've been having intermittent connection problems with CTDB lately, for example, now. Getting either timeouts or "CTDB: database access error: There is an error in XML document (1, 1)"

Did anyone else notice anything?

Re: CUETools DB

Reply #230
Thanks for letting me know. The server was acting weird. I've rebooted it.
CUETools 2.1.6

Re: CUETools DB

Reply #231
Actually i've just completed the long overdue server upgrade.  Old one wasn't able to keep up with the load anymore. Let me know if i've broken anything in the process.
CUETools 2.1.6

Re: CUETools DB

Reply #232
Seems to be working just fine for the moment - thanks for maintaining/upgrading it!

Re: CUETools DB

Reply #233
Yes, thanks so much for such a great service.  Currently working fine with EAC.

Re: CUETools DB

Reply #234
Gregory Chudov asked to be notified of any oddities following the server upgrade.  I've seen a CueRipper problem that started since the upgrade with some track titles which contain apostrophes or ampersands.  They are being displayed and stored (both in filenames and tag data) as "'" and "&" respectively.   It doesn't happen on every CD - only some.   The rips where I've seen the problem are as follows:
John Barry – The Best of John Barry  TOCID: 2fYUnO_Hzpp1IIUwe5HRV2X9fuo-  ripped 2002 Jan 15th
The Tornados – Telstar                      TOCID: oLWEIQ8dFwJgkCIb_tdl22Iv2.Y-       ripped 2240 Jan 15th
The Spotnicks – 18 Greatest Hits       TOCID: aXQPrKCgZ8NxjJOC9r8Rojf60Z8-    ripped 2301  Jan 15th
The Ventures - Eight Classic Albums  (4 CD set)
                                                           TOCID: _DeWrDqWlZucSUP2vC.1clOodq4-  ripped 1400  Jan 17th
                                                           TOCID: PsZefuprLlzBUsXuAXDCZTYi8Ls-      ripped 1410  Jan 17th
                                                           TOCID: 1r7.tzEWSTuNKp1CNDVvsNfbDiw-  ripped 1438  Jan 17th
                                                           TOCID: spTw0sQAgUKT1Im7Y_eU6iPOMVI- ripped 1448 Jan 17th

(All times UK time - GMT).

Discussed this issue with a friend who is an experienced CueToools/CueRipper user and he could not recall seeing any examples of the problem.  He took things a stage further and wrote a program to scan his music server and look for the issue in track titles in all the .cue files.  He found none.  He sent me his program and I scanned all my music and there were no examples of this problem on rips done before Sunday Jan 15th.
To check it was not a PC specific issue, I loaded the CueTools suite onto my wife's laptop and tried the same discs there - same result.
Not all rips performed since the upgrade have been effected.  The two discs in Eric Clapton's "Blues" 2-CD set both have titles containing apostrophes but they ripped OK.

Additional info:  I use CueRipper version 2.1.6 running under Windows 7 Pro on a Dell Optiplex.  Also on HP laptop with Windows 10.
 

Re: CUETools DB

Reply #235
Hmm, confirmed, tag data from Musicbrainz(?) comes back with & now. Occurred with TOCID: E2Y_RX.NHuc_k_yPjdtpYeiBgNo-

Re: CUETools DB

Reply #236
I also confirm Twangsters problem report. Just ripped Well Respected Kinks (image rip to flac). Track 8 is listed as "Don't You Fret" and thats how it appears in the .cue. I've also never seen this problem before in some 5 years of using CueTools.

TOCID: wUWpygSKsY0K8wyJGsER2tFFUTQ-
data came from MusicBrainz, the only match returned in the metadata dropdown

Querying the CT database directly with http://db.cuetools.net/?tocid=wUWpygSKsY0K8wyJGsER2tFFUTQ- shows the proper apostrophe in the listing.

Clicking on the CTDB entry downloads the xml file and that shows the ' as would be expected

Clicking on the MusicBrainz entry shows Track 8 with the proper apostrophe

CueTools v2.16, Windows 10 Pro


Re: CUETools DB

Reply #237
An update on my previous post:

I neglected to include the TOCIDS for the 2 CDs from the Eric Clapton "Blues" set which did not have the problem.  They are;
Disc 1      TOCID: yUXrhevhgFw9onbQ9SZwaoJH66A-
Disc 2      TOCID: uZ1uhW8ulqFneDJAwUst3WrxddY-

I've also discovered an interesting situation with another 2-CD set which might help with diagnosis of the problem:
Mark Knopfler – “The Ragpicker’s Dream”
Disc 1       TOCID: Z848KNXtvH8wfhBd33JMrj45v2w-
Disc 2       TOCID: 53dJ8rfqwb14RWrepMNIfvHvTW0-

With disc 1,  CueRipper offers three metadata options in the dropdown (all MusicBrainz) for US, British(GB) and German(DE) pressings.  Selecting the US or the GB options results in the ' problem (in this case in the album title as well as in one track title).  But selecting the DE option gives the correct display of the apostrophes.

Similar situation with disc 2:   two options offered - US and DE.   US option gives the problem, DE option is OK .

I used the disc 1 TOCID to access the cuetools database directly (as per plugs13amp's post) and, via that route, all three MusicBrainz options display the apostrophes correctly.

Just to be clear, the problem is not confined only to rips where MusicBrainz is the metadata source.  For the CDs listed in my previous posts, the Tornados disc showed the problem with both MusicBrainz and freedb, the Spotnicks with freedb (only option offered), the Ventures with both freedb and Discogs (no MusicBrainz option offered) and the John Barry with MusicBrainz (only option offered).

Re: CUETools DB

Reply #238
This seems to be an encoding/codepage issue, which would explain why the German one works fine for you - it's not the same as your locale, so the apostrophe doesn't  get detected (and escaped) as such.

Re: CUETools DB

Reply #239
I don't see that it can be an encoding/codepage issue as, although the the metadata relates to a CD pressing manufactured in Germany (and sold in the UK), the metadata itself is not German.  Also, for another Mark Knopfler CD - "Kill To Get Crimson" - the metadata for the German pressing does have the ' issue.

I've just found another real oddball.  Joe Bonamassa - "You & Me",  TOCID: 6Xr7qE6SYV77A4mFl4d5o25gcKA-
The album title has the & problem but apostrophes in the titles for tracks 5 and 6 display correctly.

Re: CUETools DB

Reply #240
I don't see that it can be an encoding/codepage issue as, although the the metadata relates to a CD pressing manufactured in Germany (and sold in the UK), the metadata itself is not German.  Also, for another Mark Knopfler CD - "Kill To Get Crimson" - the metadata for the German pressing does have the ' issue.
How do you know they all use the same codepage? Submissions from a PC set to  English locale could happen in pure ANSI, while submissions from a PC set to German do not (because it has some characters not in basic ANSI codepage).

To a human, an apostrophe looks the same no matter which codepage it is encoded as, but internally the code might differ. So if the code matches an apostrophe that would have to be escaped to not break xml, we end up with ', for the other, we just see '

Though this:
Quote
I've just found another real oddball.  Joe Bonamassa - "You & Me",  TOCID: 6Xr7qE6SYV77A4mFl4d5o25gcKA-
The album title has the & problem but apostrophes in the titles for tracks 5 and 6 display correctly.
invalidates my theory, I guess.

Re: CUETools DB

Reply #241
The issue of different codepages doesn't apply as CueRipper doesn't query all the different CD databases. It queries the CueTools database (as defined in the options page) with the TOCID. The CT database returns a single XML file which contains all the metadata that fills CueRipper's metadata dropdown, and all the fields (tracks, title, year, barcode, etc) that change with your selection. You can see this by manually querying the database here
http://db.cuetools.net/?tocid=Z848KNXtvH8wfhBd33JMrj45v2w-
then clicking on the CTDB Id on the right. Then on the resulting page click the CTDB link on the left (beside the little CD image with the red cross). This XML document has no DTD and hence no "encoding=" statement, so no codepage or UTFn coding is specified. The XML document shows the ' comes from the CT database server and is visible because despite being a declared "predefined entity" along with < > & and " it is not recognised as such by most web browsers and xml parsers. This includes IE, Edge, Chrome, and the parser inside CueRipper. If you patch one of the XML files in Cuetools/MetadataCache to include any of the other entities, insert the appropriate CD and select the local data (green jigsaw piece) you can see your edits are translated properly. It is recommended that ' is not used because of this. It would be difficult to tell if the XML contains any of the other four entities as your web browser would translate them and you would never see the &nnnn; format. See section 3.1 of the XML Wiki at https://en.wikipedia.org/wiki/XML 

Incidentally, Twangster was mistaken in his observation that the Joe Bonnamassa album has both & and real apostrophies (byte value x'27') - the apostrophies are actually "close single quotes", byte value x'92'. Thats also true of The Ragpicker's Dream in the above example and quite a few others. An easy mistake to make as in many fonts they look identical. It also appears that Chrome doesn't translate the & either, I haven't checked other browsers.

Since this all started after Gregory Chudov upgraded the server, I suspect this is nothing more than he's missed a configuration setting in the webserver or possibly the underlying php server, to not translate the "predefined entities" into their &nnnn; format, and hopefully he can fix it quite quickly.


Re: CUETools DB

Reply #242
Hi there,

Metadata retrieved (if any) in EAC using CUETools DB Metadata Plugin (v2.1.6 in my case) are still not in sync with MusicBrainz DB :-(
MB informations retrieved using CTDB plugin seem to be taken from a very old copy (cache?) of MB database (or an older MB database?).
I only retrieve information of releases added to MusicBrainz (or modified ) more than 1 year ago.
Newer additions/edits are not retrieved.

Maybe a MusicBrainz software update…

I know that this issue was detected few months ago. What is the current CUETools project status for this point?

Thanks in advance.

Re: CUETools DB

Reply #243
I only retrieve information of releases added to MusicBrainz (or modified ) more than 1 year ago.
I fixed Musicbrainz sync last month, so i find it hard to believe.
Is there any particular CD you have problems with?
CUETools 2.1.6

Re: CUETools DB

Reply #244
I fixed Musicbrainz sync last month, so i find it hard to believe.
Is there any particular CD you have problems with?

I'm pleased to read you made great efforts to fix the MB sync issue  ;)  Thank you very much.

I've just noticed that few of the CDs that I added few months ago are now correctly retrieved. Thank you for this, and sorry for "complaining".  :-[

However, I still have problems with some other CDs (that are not retrieved)  :(

I added this CD 3 days ago (it is correctly retrieved from MB by foobar2000, not using EAC 1.3 with CTDB EAC Plugin 2.1.6):
http://musicbrainz.org/release/170fa072-4d08-4667-a09c-6ccf67934b2e
https://musicbrainz.org/cdtoc/attach?toc=1%2021%20229876%20150%2011475%2022950%2027225%2043650%2054750%2063675%2076125%2088575%2094800%20107025%20126900%20132150%20149700%20159675%20166500%20172500%20185775%20193050%20198375%20210300

This one was added to MB on 2016-11-12 (not by myself):
https://musicbrainz.org/release/278f09e7-4ad0-4f24-b371-e0ba82e955dc
https://musicbrainz.org/cdtoc/attach?toc=1%2018%20344214%20150%205093%2022443%2040358%2064203%2081718%20101156%20120306%20156426%20170571%20189736%20211213%20231648%20251973%20269088%20290853%20309636%20334053

Another one (added 2016-07-31):
https://musicbrainz.org/release/34374725-2727-43e8-b665-fbc2e28abfa3

EDIT: I have the same problem using CTDB EAC Plugin v1.2.5 (with different drives). However, CUERipper correctly retrieves the metadata. Strange. An EAC issue? Did you also fix the CTDB plugin the same way?

Thanks  ;)

Re: CUETools DB

Reply #245
Thanks, i'll take a look.
CUETools 2.1.6


Re: CUETools DB

Reply #247
Well, apparently the database produces correct results for those discs (for example, http://db.cue.tools/lookup2.php?version=3&ctdb=0&fuzzy=0&metadata=default&toc=0:4943:22293:40208:64053:81568:101006:120156:156276:170421:189586:211063:231498:251823:268938:290703:309486:333903:344064). If the plugin rejects those results, i can't figure out the reason. Will test it in more detail this weekend.
CUETools 2.1.6

Re: CUETools DB

Reply #248
Ooow. I'm sorry but I was wrong. My apologies!

Everything is OK now. All MB metadata are indeed retrieved in EAC.
I wasn't intelligent enough to notice that the plugin automatically applies metadata and closes its windows when there's only 1 result. Since I disabled the cover search, I was not able guess that the metadata was not CD-TEXT but MB's data. Maybe keeping the result windows open for 1 results (and 0) would cause less confusion?

Sorry for all this confusion.

I confirm that I also get HTML codes instead of Unicode characters from MB:
& → &
' → '

…

Thanks again


 
SimplePortal 1.0.0 RC1 © 2008-2021