Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Layout Editing Mode - I can't add more UI Elements? (Read 3883 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Layout Editing Mode - I can't add more UI Elements?

Hi,

Here is my current gui:



I'm trying to add a Library Search or Quicksearch from http://www.foobar2000.org/components/view/foo_quicksearch

but when I try to add them using the Layout Editing Mode, I can't seem to be able to add more UI Elements ?!? it only allows me to replace the existing ones, as if it was limited to this number of elements. There's clearly space for more.

I can only use Replace element, and then I lose my Waveform bar or the whole Playlist.

What am I doing wrong?


Thanks!

 

Layout Editing Mode - I can't add more UI Elements?

Reply #1
you need to replace with a splitter (top/bottom or left/right). when you do this, you now have 2 spaces. you can then add more splitters into each blank space so you end up with exponentially more panels if you need them. there is also a tabs option should you want that instead.

remember to use cut/copy if you want to put existing panels on the clipboard before replacing. you can then paste them into the blank spaces generated by adding those splitters. it might be worth playing with the scratchbox (view>layout) for a few minutes. when it clicks for you, you'll realise how ridiculously easy it is.

Layout Editing Mode - I can't add more UI Elements?

Reply #2
Thanks for the reply. Just found out how to use them

 
SimplePortal 1.0.0 RC1 © 2008-2021