HydrogenAudio

Hosted Forums => foobar2000 => Support - (fb2k) => Topic started by: spase on 2003-03-18 14:20:52

Title: Playlist Search is broken...
Post by: spase on 2003-03-18 14:20:52
when i use tab or $char(9) repeatedly in my display list string, it break the playlist search feature.
Title: Playlist Search is broken...
Post by: greatmagi on 2003-03-18 17:30:01
Yeah I noticed this and posted it a few days ago...

http://www.hydrogenaudio.org/forums/index....ST&f=29&t=7549& (http://www.hydrogenaudio.org/forums/index.php?act=ST&f=29&t=7549&)
Title: Playlist Search is broken...
Post by: greatmagi on 2003-03-23 01:14:31
Here's a workaround...

Since search only searches the first column, you can add all the fields you want to be searched, but make them invisible.  If you're using columns with $char(9), it won't affect the relative width of the column.

Here's what I did...

Code: [Select]
//playlist bg color normally and selection color when selected makes it invisible
$puts(INVIS,FFE4CA|808080)


then make the columns...ex. the first column only shows the artist in the playlist, but search will search and show artist - title (album).

Code: [Select]
$num(%_playlist_number%,4)
808080|FFFFFF| $caps2(%artist%) $get(INVIS) - %title% '('%album%')'$repeat($char(9),3)
808080|FFFFFF| $if(%title%,$caps2(%title%),%_filename%)$repeat($char(9),3)
808080|FFFFFF| $caps2(%album%)$repeat($char(9),3)
808080|FFFFFF| $if(%date%,$num(%date%,4),$get(INVIS)'0000') 808080|FFFFFF| $if(%tracknumber%,$num(%tracknumber%,2),$get(INVIS)'00') 808080|FFFFFF| [%genre%]$repeat($char(9),2)
808080|FFFFFF|$if($greater($len(%_length%),4),%_length%,$get(INVIS)'0'%_length%)
SimplePortal 1.0.0 RC1 © 2008-2021