HydrogenAudio

Lossy Audio Compression => MP3 => MP3 - General => Topic started by: deadmuse on 2006-03-19 09:54:34

Title: EAC settings to manage VBR quality
Post by: deadmuse on 2006-03-19 09:54:34
Hello,

I've read all the posts I can find on this subject but my question still remains. I am using EAC and external LAME mp3 encoder and everything is fine except one thing: I can't find a way to choose the quality combination I want.

The internal use of LAME encoder at 320 bitrate only allows constant. So I used the external encoder (also LAME encoder, recently downloaded) and it gives me limited options for the bitrate. I can do 320 CBR or I can only go up to 192 for VBR.

What I want is 320 VBR. I've tried everything I can think of but my knowledge is limited. I could really use some help as I have been trying to encode my collection of 800 CDs for quite some time and I just cannot figure out how to make this combination work in EAC.

Up till now, I have been ripping WAVs with EAC then using CDex to encode them into MP3s which gives me control of every MP3 quality setting option. The problem with this method is I can't get CDex to insert ID3 tags, so every track shows up as "unkown" on my MP3 player. I would prefer to use EAC for the whole thing so I can get the ID3 tags as well as 320 VBR high quality MP3s.

Thanks for reading.
Title: EAC settings to manage VBR quality
Post by: Synthetic Soul on 2006-03-19 10:15:39
Check the wiki page (http://wiki.hydrogenaudio.org/index.php?title=LAME).

There is a screenshot there, to show you how the dialogue should be set up.  Basic upshot: Parameter passing scheme: "User Defined Encoder", and a command line something like:

-V0 --vbr-new --ta "%a" --tt "%t" --tg "%m" --tl "%g" --ty "%y" --tn "%n" %s %d

-V0 is the best VBR setting you can get, and will produce files with an average bitrate between 220 and 260kbps.  It will use 320kbps where required.

All this is in the article.

Edit: From your post I can only assume that you were using the parameter passing scheme of "LAME MP3 Encoder" in conjunction with the bitrate dropdown.  The settings above do not make use of the dropdown (again, it's in the article, IIRC).  This allows you the greatest flexibility, as you are using the command line interface directly.
Title: EAC settings to manage VBR quality
Post by: deadmuse on 2006-03-19 11:35:22
Synthetic Soul,

Thanks so much for your help. I figured out what all those codes are for the command line which was the main hurdle I had before. I even managed to get 1 CD perfectly ripped and encoded but the next one didn't work.

I read the wiki and made sure all my setting match. I click on the MP3 button in EAC and everything starts well enough. I even get a mesage it's using the external codec to encode, but now the results are that I get only the ripped WAV file, no MP3.

I've simplified the command line to a bare minimum in case that's the problem, but even then I still get no MP3 output even though it says it's encoding. I searched my entire system but it's not to be found anywhere.

I've been fighting with this for over an hour trying every variation without luck. The only thing that works is if I return to the internal encoder and choose 320 CBR. Any ideas?

Here's a screenshot of my settings. I can't find the error.

(http://www207.pair.com/anish/eac.jpg)

(http://www207.pair.com/anish/eac2.jpg)
Title: EAC settings to manage VBR quality
Post by: haregoo on 2006-03-19 12:06:30
You should read List of recommended LAME settings (http://www.hydrogenaudio.org/forums/index.php?showtopic=28124), before posting topics in MP3 - General.
It is an essential guide for starter and answer your questions.
Title: EAC settings to manage VBR quality
Post by: Synthetic Soul on 2006-03-19 13:08:11
The minimum command line would be:

-V0 --vbr-new %s %d

The %s and %d are required, to tell LAME the input (%s) and output (%d) files.

The LAME DLL tab will bear no relevance if you have "Use external program for compression" checked.
Title: EAC settings to manage VBR quality
Post by: deadmuse on 2006-03-19 14:43:35
Thanks once again, Synthetic Soul. And thank you Haregoo for the link. I did read that as well as numerous other posts, but I did not understand the details of it until Synthetic Soul pointed out what was required and what was irrelevant in my approach.

I did my best to figure it out through reading, but after 3 hours, I was still stuck. Now everything is working thanks to the kind advice. All the information on the FAQs was just at the edge of my grasp, but the explanations here gave me the final push I couldn't have done by myself. Thank you!
Title: Re: EAC settings to manage VBR quality
Post by: slowburner on 2020-12-30 19:03:09
Hello,

I've read all the posts I can find on this subject but my question still remains. I added Lame in User Defined Encoder. How do I set up the V0 correctly?
Should I put V0 --preset extreme %s %d in the command-line?
What bitrate should I set up? Is is a sort of everage bit rate? Is there any difference if I put 128 or 192?

Thank you!
Title: Re: EAC settings to manage VBR quality
Post by: korth on 2020-12-30 19:31:14
You replied to a thread over 14 years old. EAC's placeholder settings have changed.
See https://wiki.hydrogenaud.io/index.php?title=EAC_and_Lame
"Bit rate" and "High/Low quality" settings are disabled with 'User Defined Encoder' without special placeholders in the 'Additional command-line options' (examples in the article linked above).
-V 0 and --preset extreme mean the same thing. You use one or the other, not both.
SimplePortal 1.0.0 RC1 © 2008-2021