Skip to main content

Topic: Bug in WavPack 4.70.0 (Read 3809 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
Bug in WavPack 4.70.0
Hi!

I couldn't find a bug tracker, so I'm posting the bug report here (as this is the "official" forum, I suppose the developers are reading this).

Version 4.70.0 of wvgain contains a bug that has been detected by the Mayhem software and has been reported to the Debian bug tracker:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=716478

The Mayhem test case can be generalized: The executable wvgain crashes with segmentation fault whenever given an invalid filename and the "-n" option. The reason is a call to WavpackCloseFile(..) on a NULL pointer as file handle, if the file couldn't be opened. I'm proposing the bug fix that I've already posted on the Debian bug tracker (URL given above).

Cheers,
Martin

Bug in WavPack 4.70.0
Reply #1

  • bryant
  • [*][*][*][*][*]
  • Developer (Donating)
Bug in WavPack 4.70.0
Reply #2
Hi Martin,

Thanks for the patch; I'll get it in right away! 

There actually is an issue tracker in the GitHub repo, but I don't think anyone has used it; I need to make it clearer that WavPack is now hosted there.

Cheers,
David

Bug in WavPack 4.70.0
Reply #3
Oh, if I had known that, I'd have sent a pull request directly...

  • DARcode
  • [*][*][*][*][*]
  • Members (Donating)
Bug in WavPack 4.70.0
Reply #4
Patched WvGain in the pipeline  ?
WavPack 5.1.0 -b384hx6cmv / qaac 2.64 -V 100

  • bryant
  • [*][*][*][*][*]
  • Developer (Donating)
Bug in WavPack 4.70.0
Reply #5
Patch has been applied in Git. Thanks again!