Skip to main content
Topic: foobar2000 streaming problem (Read 789 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foobar2000 streaming problem

I have been using foobar2000 for a few years and play FLAC and WAV files which are either 16bit or 24bit and anything up to and including 192kHz.

Bluetooth streaming from my laptop, (permanently located on my desk and attached to my BT Smart Hub router by ethernet), to either my apt-x enabled hi-fi amp or a Sony bluetooth speaker has never been a problem. Both of those devices are about 30 metres away and the walls in my house are very old and very thick.

On my desk I use USB attached Bowers & Wilkins speakers. Again, never had any problems.

Two weeks ago I bought a Yamaha WXAD10 and attached that to my router using an ethernet cable.

I downloaded the UPnP component for foobar and was up and running in a matter of minutes and enjoying my files in all their 24bit glory.

However, at seemingly random points foobar simply stops playing.  It doesn't stop at any particular time. I've left it playing over-night and it stopped after about 4 hours. Today it's stopped after around 2 1/2 hours. At the weekend it played for 7 hours before stopping. There does not seem to be any pattern to this, it just stops.

It doesn't stop at the end of a track, it can stop at any point. There's no error message and the only way to get foobar started again is to hit play which restarts the track from the beginning.

I've Googled just about everything I can think of and changed settings back and forth and have come to the conclusion that I am probably overlooking something really simple.

Buffer length is currently 1000ms, (I have increased and decreased that but to no avail) and output data format is 24bit.

When it's playing it's perfect but it's driving me nuts trying to figure out what is causing foobar to just stop in the middle of some random track.

These stoppages occur on 16bit tracks, 24bit tracks, 44.1khz, 48kHz, 96khz and 192khz. 

If anybody on here can provide any advice I would be extremely grateful.

Re: foobar2000 streaming problem

Reply #1
The problem is caused by the UPnP receiver not supporting LPCM stream. It's sent regular WAV stream instead and playback stops once the maximum allowed size is reached.

I assume software that doesn't do gapless and sends each file individually doesn't suffer from the problem.

You can test if my workaround component helps. After installing the component it needs to be added to the DSP chain for it to function. It checks the files/streams you play and when it detects a silent track transition where gapless playback isn't needed, it stops the playback and instantly restarts it.

Re: foobar2000 streaming problem

Reply #2
Thank you Case, that is terrific. I will give it a try tomorrow and let you know what happens. Thanks again.

 

Re: foobar2000 streaming problem

Reply #3
Case,

After a week of intensive foobar streaming I think I can safely say that your workaround has solved the problem. 

Thank you very much.

 
SimplePortal 1.0.0 RC1 © 2008-2018