Skip to main content
Topic: foo_dumb (Read 227554 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_dumb

Reply #400
Another track where playptmod sounds differently: syreen2.mod.

Note the discontinuity in the waveform at 42.84 sec:


foo_dumb

Reply #401
Well, you didn't say if playptmod does it wrong or correct, how am I supposed to know? Did you test the module in ProTracker 1.3B and 2.3D? (don't bother with 3.x, it's another story...)
Suspicious DC offset jumps are not too uncommon in modules, it happens if you suddenly switch to another sample while a previous sample is playing on the specific channel. Also keep in mind that playptmod emulates a quirk where a new (not same sample number) sample (with no note given) will not make the active sample change until it has played beyond LEN or LOOP_LEN one time. I aim to make playptmod as PT-accurate as I can, while not focusing too much on FastTracker 1 MODs and whatnot.

foo_dumb

Reply #402
I downloaded ProTracker Win32 from 16-bits.org and that's how it renders this place (yellow dotted line is still at 42.84 sec; and there are many other such places, this is just one of them):



and that's foo_dumb with playptmod disabled:




So I think that foo_dumb+playptmod play this file incorrectly.

foo_dumb

Reply #403
Just checked and my sample has the same discontinuities when played with playptmod enabled, which aren't present in the actual game or when playing the mod with UADE or with playptmod disabled in foo_dumb.

foo_dumb

Reply #404
It must be a bug in my version of playptmod.

foo_dumb

Reply #405
Hello, kode54! (Foobar2000 1.2.6 + DUMB 1.0.23):
1) The song proceeds after its termination. That is doesn't come to an end never. Occurs on IT and XM.
2) Upon multiple transitions on a time scale if, for example, to transfer at 1:00, and then to return at 00:30, there is any mess - the specified place doesn't correspond to the valid.
All this is watched on many different chiptunes.
P.S. When playing MOD the strange thing: Length of a song 0:52. However the song can will end and at 0:53, and 0:54 (if to look on a time scale) before transition to the beginning.

foo_dumb

Reply #406
There is an error message appearing after DUMB Module decoder 1.0.24 update on foobar v.1.2.6 installed on WinXP SP3.
Where can I download the previous version of DUMB Module decoder?
(in Reason: Not found this procedure)

foo_dumb

Reply #407
Palm,

I assume that the installation of the MS Visual C++ 2010 Redistributable Package will fix that.

If it doesn't please tell me and I will upload foo_dumb v1.0.20 for you (older versions back to v0.9.8.04 are also available here).
This is HA. Not the Jerry Springer Show.

foo_dumb

Reply #408
Unfortunately something broke with foo_dumb v1.0.24 which produces a lot of sound distortion with certain modules, similar to a constant high frequent clipping. Reverting back to foo_dumb v1.0.23 solves the issue for me.

Where can I download the previous version of DUMB Module decoder?

Foo_DUMB Module decoder v1.0.23 can be acquired here at MODLAND.
Best regards
deus-ex

foo_dumb

Reply #409
Palm,
I assume that the installation of the MS Visual C++ 2010 Redistributable Package will fix that.

I have installed MS Visual C++ Redistributable packags 2005 SP1, 2008 SP1, 2010 SP1, 2012.

[quote author=deus-ex link=msg=836569 date=1370690380]Foo_DUMB Module decoder v1.0.23 can be acquired here at MODLAND.[/quote]
Thanks for the 1.0.23 version! Error message doesn't appear anymore. 

It is probably decoder developers' error.

foo_dumb

Reply #410
[quote author=deus-ex link=msg=836569 date=1370690380]Unfortunately something broke with foo_dumb v1.0.24 which produces a lot of sound distortion with certain modules, similar to a constant high frequent clipping. Reverting back to foo_dumb v1.0.23 solves the issue for me.[/quote]
Got the same experience with foo_dumb v1.0.25 as described above, reverted back to v1.0.23.
Best regards
deus-ex

foo_dumb

Reply #411
There is no redist issue with foo_dumb, or any of my components, as I use static runtime. The only issue was that 1.0.24 required Vista or newer due to a bug in MSVC 2012 v110_xp targeting pack.

foo_dumb

Reply #412
The only issue was that 1.0.24 required Vista or newer due to a bug in MSVC 2012 v110_xp targeting pack.

I have installed latest version of MS Visual C++ 2012 Redistributable (x86) Update 1 (v11.0.51106.1 from 26.11.2012) for XP.
What should I do? Keep foo_dumb v1.0.23 ?

foo_dumb

Reply #413
Are you sure 1.0.25 does not work? It may require that you have Service Pack 3 installed.


foo_dumb

Reply #415
deus-ex, care to name some modules that show the broken behavior? Perhaps that would get kode54's attention.


foo_dumb

Reply #417
Um, yeah. MSVC 2012 completely breaks my neat SSE intrinsic function based resonant filter function. I've disabled it.

foo_dumb

Reply #418
Yep, confirmed, that fixed it.
Best regards
deus-ex

foo_dumb

Reply #419
1.0.26 also fixes playptmod problem mentioned in post #401.

foo_dumb

Reply #420
(Foobar2000 1.2.6 + DUMB 1.0.26).
Example: (http://amp.dascene.net/downmod.php?index=93603)
Very unpleasant effect is watched.
We include the song. We transfer closer by the end, for example at 2:40. Now we transfer at 1:00.
And now we try to transfer at 3:00. Voila: The song breaks and made a fresh start. There is on .xm, .it, .mod, can on any formats.

foo_dumb

Reply #421
(Foobar2000 1.2.6 + DUMB 1.0.26).
Example: (http://amp.dascene.net/downmod.php?index=93603)
Very unpleasant effect is watched.
We include the song. We transfer closer by the end, for example at 2:40. Now we transfer at 1:00.
And now we try to transfer at 3:00. Voila: The song breaks and made a fresh start. There is on .xm, .it, .mod, can on any formats.

Fixed.

foo_dumb

Reply #422
Um, yeah. MSVC 2012 completely breaks my neat SSE intrinsic function based resonant filter function. I've disabled it.



ahh so that's why there was a msvcrt.dll issue... you were linking against a new version of the MS VC++ RT....?

I didn't know there was a new one..
since you have fixed it already I'll not bother posting my bug report. or I could include the Dependency walker files.. it notes a few missing files and Functions..
I have files to attach... but this forum doesn't seem to allow it....



There is no redist issue with foo_dumb, or any of my components, as I use static runtime. The only issue was that 1.0.24 required Vista or newer due to a bug in MSVC 2012 v110_xp targeting pack.

Static linking is sweet takes allot of head ache out of it.

foo_dumb

Reply #423
In the last foo_dumb versions the extremely unpleasant bug was sometimes shown: When viewing information on the module (Properties) Track Title was displayed only. All remaining fields remained empty even the ambassador of Tools - Reload Info. Decided so: Foobar2000 restarting. Then MP3 file start, and then already again chiptunes opening. Usually occurs in case of start or foobar2000 restarting.
P.S. I tried to delete all files from index-data - works not always.

foo_dumb

Reply #424
If you removed the tags, then all fields will be deleted in the internal database.

 
SimplePortal 1.0.0 RC1 © 2008-2018