Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: DSP Manager problems, 32 bit preview version (Read 326 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

DSP Manager problems, 32 bit preview version

Hi, since a few versions I have massive DSP Manager issues.

I visit "Preferences - DSP Manager"
Load a preset "Playback"
Click "Apply" and "OK"

Foobar2000 shows and uses a different preset now in the DSP preset toolbar item. It's a stupid one with VST fx.

Lets say then I pick the "Playback" preset in the toolbar. Yes, it is displayed and used. But when I double click another track, the toolbar item is empty, no preset, and it uses the stupid one from before again.

In DSP Manager, I reset page. I deleted all DSP presets I do not need. Still if I change tracks manually, it shows no DSP preset. But the chosen DSPs are many, they are not part of an existing DSP preset. But Foobar2000 wants to use those at all cost.

EDIT: Solved, kind of. It's because of https://www.foobar2000.org/components/view/foo_playlist_attributes - I removed it and everything is fine. I am aware it has settings for DSP, (I set DSP to "Global") but still, it created above mess.

Then I deleted all presets. I pressed "Reset page". No active DSPs there. Great. Leave DSP manager. But on track change, again it uses 3 active DSPs. Better than 5 but where does it take them from?

EDIT: It's because of foo_playlist_attributes, discussion should continue there. https://hydrogenaud.io/index.php/topic,73783.new.html#new

X