Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: EAC not detecting CTDB plugin (Read 3601 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

EAC not detecting CTDB plugin

I'm trying to install CTDB plugin (Version 2.1.4) for EAC and following the guide it says I can drop all files (total 6) into the EAC.exe directory and EAC will automatically detect the plugin. However, EAC does not detect the plugin. F9 -> "Audio Plugins" are greyed out, nothing. F12 -> "Metadata Provider" only show "Built-in freedb engine". I would like to use CTDB plugin as metadata provider. I have probably unchecked this plugin when first installing EAC, but it must be possible to install it afterwards as well?

Thanks in advance.

EAC not detecting CTDB plugin

Reply #1
EAC should detect the plugin when restarted. I don't think it can detect adding the files while running.
Did you verify that the six files copied? (admin rights may be required).

korth

EAC not detecting CTDB plugin

Reply #2
I've restarted multiple times as administrator. The files I added (same folder as EAC.exe):

CUETools.AccurateRip.dll
CUETools.CDImage.dll
CUETools.Codecs.dll
CUETools.CTDB.dll
CUETools.CTDB.EACPlugin.dll
CUETools.Parity.dll

EAC not detecting CTDB plugin

Reply #3
I had to reinstall EAC and choose to install CTDB plugin during the installation, and now it works... pretty lame.

EAC not detecting CTDB plugin

Reply #4
I just meant that copying the files might require admin rights if the EAC installation is within the Program Files directory. Sorry it wasn't of help. I'll look into this further and adjust the wiki instructions as required.
You'll probably still need to try copying the files again to upgrade the plugin to 2.1.4. The EAC installer has 2.1.3.
korth

EAC not detecting CTDB plugin

Reply #5
Thanks for the notice, I will upgrade to 2.1.4. At least plugin is activated now so I don't think this will be an issue (will test tomorrow). I used non-system disc so it didn't require admin rights  You are of help, thank you.

Exact Audio Copy (EAC) not loading CTDB plugin due to missing .NET Fra

Reply #6
Gents,

First post here! I'm posting this solution as it might help other people in the same situation 
Setting up my new Win 8.1 -based rig , I had a problem with CueTools CTDB plugin not being loaded by EAC at launch time.
Even tough I had selected the CTDB package through the EAC setup, CTDB just wouldn't show up in EAC Option / Audio Plugins. I had tried removing all EAC files and registry entries and re-installing, to no avail..

Then I recalled that the cause to the issues I had with another plugin, i.e. freedb, in the past on my other rig was that the .NET Framework version 3.5 was missing on the machine (it is not installed by default).
Since I do not use freedb in EAC much anymore it never came to my mind to enable the Framework.

Well, CTDB needs it as well !

Go to
Control Panel / Programs / Turn Windows features on or off
and then just check the box next to ".NET Framework 3.5 (includes .NET 2.0 and 3.0)", and you're set!

Happy ripping !

 
SimplePortal 1.0.0 RC1 © 2008-2021